aboutsummaryrefslogtreecommitdiff
path: root/security/xinetd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/xinetd/Makefile')
-rw-r--r--security/xinetd/Makefile13
1 files changed, 2 insertions, 11 deletions
diff --git a/security/xinetd/Makefile b/security/xinetd/Makefile
index 610a8cedd621..45d86fae8c2e 100644
--- a/security/xinetd/Makefile
+++ b/security/xinetd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xinetd
PORTVERSION= 2.3.14
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= security ipv6
MASTER_SITES= http://www.xinetd.org/
@@ -16,11 +16,9 @@ COMMENT= Replacement for inetd with better control and logging
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_RC_SUBR= yes
+USE_RC_SUBR= xinetd
ALL_TARGET= build
CONFIGURE_ARGS+= --with-loadavg --with-libwrap --with-ipv6
-STARTUP_FILE= ${PREFIX}/etc/rc.d/xinetd.sh
-RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
MAN5= xinetd.conf.5
MAN8= xconv.8 xinetd.8 xinetd.log.8
@@ -30,14 +28,7 @@ post-patch:
${REINPLACE_CMD} -e 's!\@INSTALL\@!/bin/cp!; s!-m 640!!'
@${REINPLACE_CMD} 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/xinetd/xconfig.h
-pre-install:
- -@[ -f ${STARTUP_FILE} ] && \
- (${ECHO} "Remove old ${STARTUP_FILE} before install." && exit 1)
-
post-install:
- @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${FILESDIR}/xinetd.sh.tmpl > ${STARTUP_FILE}
- @${CHMOD} 755 ${STARTUP_FILE}
@${STRIP_CMD} ${PREFIX}/sbin/xinetd
.include <bsd.port.mk>