aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/ike-scan/Makefile27
-rw-r--r--security/ike-scan/distinfo1
-rw-r--r--security/ike-scan/pkg-descr12
-rw-r--r--security/ike-scan/pkg-plist11
5 files changed, 52 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 4803ddec3fbe..c243b7a427a7 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -97,6 +97,7 @@
SUBDIR += identify
SUBDIR += ifd-devkit
SUBDIR += ifd-gpr400
+ SUBDIR += ike-scan
SUBDIR += inflex
SUBDIR += integrit
SUBDIR += ipfmeta
diff --git a/security/ike-scan/Makefile b/security/ike-scan/Makefile
new file mode 100644
index 000000000000..13471ca65df6
--- /dev/null
+++ b/security/ike-scan/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: ike-scan
+# Date created: 04 May 2003
+# Whom: Yonatan <Yonatan@xpert.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ike-scan
+PORTVERSION= 1.0
+CATEGORIES= security
+MASTER_SITES= https://berlin.ccc.de/~cryx/
+
+MAINTAINER= Yonatan@xpert.com
+COMMENT= VPN scanner and identifier
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+= "--datadir=${DATADIR}"
+
+post-install:
+. if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for i in AUTHORS COPYING NEWS README TODO udp-backoff-fingerprinting-paper.txt
+ ${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}
+. endfor
+. endif
+
+.include <bsd.port.mk>
diff --git a/security/ike-scan/distinfo b/security/ike-scan/distinfo
new file mode 100644
index 000000000000..829beb909718
--- /dev/null
+++ b/security/ike-scan/distinfo
@@ -0,0 +1 @@
+MD5 (ike-scan-1.0.tar.gz) = 7299777c7d67d1cea82d9594867b4806
diff --git a/security/ike-scan/pkg-descr b/security/ike-scan/pkg-descr
new file mode 100644
index 000000000000..294a87cd024e
--- /dev/null
+++ b/security/ike-scan/pkg-descr
@@ -0,0 +1,12 @@
+ike-scan discovers IKE hosts and can also fingerprint them using the
+retransmission backoff pattern.
+ike-scan does two things:
+a) Discovery: Determine which hosts are running IKE.
+ This is done by displaying those hosts which respond to the IKE requests
+ sent by ike-scan.
+b) Fingerprinting: Determine which IKE implementation the hosts are using.
+ This is done by recording the times of the IKE response packets from the
+ target hosts and comparing the observed retransmission backoff pattern
+ against known patterns.
+
+WWW: http://www.nta-monitor.com/ike-scan
diff --git a/security/ike-scan/pkg-plist b/security/ike-scan/pkg-plist
new file mode 100644
index 000000000000..28484130df80
--- /dev/null
+++ b/security/ike-scan/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+bin/ike-scan
+share/ike-scan/ike-backoff-patterns
+%%PORTDOCS%%share/doc/ike-scan/AUTHORS
+%%PORTDOCS%%share/doc/ike-scan/COPYING
+%%PORTDOCS%%share/doc/ike-scan/NEWS
+%%PORTDOCS%%share/doc/ike-scan/README
+%%PORTDOCS%%share/doc/ike-scan/TODO
+%%PORTDOCS%%share/doc/ike-scan/udp-backoff-fingerprinting-paper.txt
+%%PORTDOCS%%@dirrm share/doc/ike-scan
+@dirrm share/ike-scan