aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/lasso/Makefile3
-rw-r--r--security/pear-Text_Password/Makefile1
-rw-r--r--security/pecl-crack/Makefile7
-rw-r--r--security/pecl-crypto/Makefile5
-rw-r--r--security/pecl-gnupg/Makefile4
-rw-r--r--security/pecl-pam/Makefile5
-rw-r--r--security/pecl-scrypt/Makefile6
-rw-r--r--security/pecl-ssh2/Makefile4
-rw-r--r--security/pecl-tcpwrap/Makefile4
-rw-r--r--security/php-suhosin/Makefile5
-rw-r--r--security/snortreport/Makefile17
11 files changed, 15 insertions, 46 deletions
diff --git a/security/lasso/Makefile b/security/lasso/Makefile
index 328b312045b6..97cb0793260c 100644
--- a/security/lasso/Makefile
+++ b/security/lasso/Makefile
@@ -43,8 +43,7 @@ CONFIGURE_ARGS+= --enable-php5 \
LDFLAGS+= -L${LOCALBASE}/lib
LIB_DEPENDS+= libexpat.so:textproc/expat2
PLIST_SUB+= PHP5=""
-USE_PHP= yes
-USE_PHP_BUILD= yes
+USES+= php:build
.else
CONFIGURE_ARGS+= --disable-php5
PLIST_SUB+= PHP5="@comment "
diff --git a/security/pear-Text_Password/Makefile b/security/pear-Text_Password/Makefile
index a2ba4e682b91..1dcf3554e32a 100644
--- a/security/pear-Text_Password/Makefile
+++ b/security/pear-Text_Password/Makefile
@@ -8,7 +8,6 @@ CATEGORIES= security www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR random password creator
-USE_PHP= yes
USES= pear
WRKSRC= ${WRKDIR}/Text_Password-${PORTVERSION}
diff --git a/security/pecl-crack/Makefile b/security/pecl-crack/Makefile
index a9081c98203f..2d65c20c501e 100644
--- a/security/pecl-crack/Makefile
+++ b/security/pecl-crack/Makefile
@@ -16,12 +16,7 @@ LICENSE= PHP30
LIB_DEPENDS= libcrack.so:security/cracklib
-USES= tar:tgz
-USE_PHP= yes
-USE_PHPIZE= yes
-USE_PHP_BUILD= yes
-USE_PHPEXT= yes
-PHP_MODNAME= crack
+USES= php:ext tar:tgz
IGNORE_WITH_PHP= 70
EXTRACT_AFTER_ARGS=--no-same-permissions --no-same-owner --exclude libcrack
diff --git a/security/pecl-crypto/Makefile b/security/pecl-crypto/Makefile
index 2d9d8b789209..af467bff4702 100644
--- a/security/pecl-crypto/Makefile
+++ b/security/pecl-crypto/Makefile
@@ -13,11 +13,8 @@ COMMENT= Objective wrapper for OpenSSL Crypto Library
LICENSE= PHP301
-USES= tar:tgz
+USES= php:ext tar:tgz
CONFIGURE_ARGS= --with-crypto
USE_OPENSSL= yes
-USE_PHP= yes
-USE_PHPEXT= yes
-USE_PHPIZE= yes
.include <bsd.port.mk>
diff --git a/security/pecl-gnupg/Makefile b/security/pecl-gnupg/Makefile
index 761a816249b1..14118f48c31b 100644
--- a/security/pecl-gnupg/Makefile
+++ b/security/pecl-gnupg/Makefile
@@ -18,9 +18,7 @@ LIB_DEPENDS= libgpgme.so:security/gpgme
CONFIGURE_ARGS= --with-gnupg=${LOCALBASE}/include
IGNORE_WITH_PHP=70
-USE_PHP= yes
-USE_PHPEXT= yes
-USES= localbase tar:tgz
+USES= localbase php:ext tar:tgz
post-patch:
@${REINPLACE_CMD} -e 's|$$GNUPG_DIR/lib|${LOCALBASE}/lib|; s| -ldl||g' ${WRKSRC}/config.m4
diff --git a/security/pecl-pam/Makefile b/security/pecl-pam/Makefile
index cb2a62ed910c..86fad0acf813 100644
--- a/security/pecl-pam/Makefile
+++ b/security/pecl-pam/Makefile
@@ -12,10 +12,7 @@ COMMENT= PECL classes for PAM integration
LICENSE= PHP202
-USES= tar:tgz
-USE_PHP= yes
-USE_PHPIZE= yes
-USE_PHPEXT= yes
+USES= php:ext tar:tgz
IGNORE_WITH_PHP= 70
.include <bsd.port.mk>
diff --git a/security/pecl-scrypt/Makefile b/security/pecl-scrypt/Makefile
index d50260621a37..5ce13192f4d0 100644
--- a/security/pecl-scrypt/Makefile
+++ b/security/pecl-scrypt/Makefile
@@ -15,10 +15,8 @@ LICENSE= BSD2CLAUSE
BROKEN_powerpc64= Does not build
-USES= compiler tar:tgz
-USE_PHP= hash
-USE_PHPEXT= yes
-USE_PHP_BUILD= yes
+USES= compiler php:ext tar:tgz
+USE_PHP= hash:build
INSTALL_TARGET= install-strip
IGNORE_WITH_PHP= 70
diff --git a/security/pecl-ssh2/Makefile b/security/pecl-ssh2/Makefile
index e7371dbf0662..ae9ae9cf3c1b 100644
--- a/security/pecl-ssh2/Makefile
+++ b/security/pecl-ssh2/Makefile
@@ -14,9 +14,7 @@ LICENSE= PHP301
LIB_DEPENDS= libssh2.so:security/libssh2
-USES= tar:tgz
-USE_PHP= yes
-USE_PHPEXT= yes
+USES= php:ext tar:tgz
IGNORE_WITH_PHP= 70
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/security/pecl-tcpwrap/Makefile b/security/pecl-tcpwrap/Makefile
index 6f7b11c15537..63fe13fc80af 100644
--- a/security/pecl-tcpwrap/Makefile
+++ b/security/pecl-tcpwrap/Makefile
@@ -13,9 +13,7 @@ COMMENT= PECL extension which provides tcpwrappers binding
LICENSE= PHP202
-USES= tar:tgz
-USE_PHP= yes
-USE_PHPEXT= yes
+USES= php:ext tar:tgz
IGNORE_WITH_PHP= 56 70
post-patch:
diff --git a/security/php-suhosin/Makefile b/security/php-suhosin/Makefile
index 48dad7d49113..b5a9522f336d 100644
--- a/security/php-suhosin/Makefile
+++ b/security/php-suhosin/Makefile
@@ -16,9 +16,8 @@ BROKEN_powerpc64= Does not build
OPTIONS_DEFINE= EXAMPLES
-USE_PHP= session
-USE_PHPEXT= yes
-USE_PHP_BUILD= yes
+USES= php:ext
+USE_PHP= session:build
IGNORE_WITH_PHP= 70
CONFIGURE_ARGS= --enable-suhosin
diff --git a/security/snortreport/Makefile b/security/snortreport/Makefile
index e212725abb77..7827b6335f58 100644
--- a/security/snortreport/Makefile
+++ b/security/snortreport/Makefile
@@ -18,23 +18,16 @@ JPGRAPH_DESC= Graphical charting
BARNYARD_RUN_DEPENDS= barnyard2:security/barnyard2
JPGRAPH_RUN_DEPENDS= ${LOCALBASE}/share/jpgraph/jpgraph.php:graphics/jpgraph2
-.include <bsd.port.options.mk>
NO_BUILD= yes
SUB_FILES= pkg-message
PORTDOCS= INSTALL Performance.txt create_indexes.sql
FTYPES= css html js php phps png sample
-USE_PHP= yes
-WANT_PHP_WEB= yes
+USES= php:web
-.if ${PORT_OPTIONS:MMYSQL}
-USE_PHP+= mysql
-.endif
-
-.if ${PORT_OPTIONS:MPGSQL}
-USE_PHP+= pgsql
-.endif
+MYSQL_USE= php=mysql
+PGSQL_USE= php=pgsql
pre-everything::
@${ECHO} ""
@@ -50,10 +43,8 @@ do-install:
${INSTALL} -o ${WWWOWN} -g ${WWWGRP} -m 750 -d ${STAGEDIR}${WWWDIR}
${INSTALL_DATA} ${FTYPES:S|^|${WRKSRC}/*|} ${STAGEDIR}${WWWDIR}
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>