aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/binwalk/Makefile2
-rw-r--r--security/botan110/Makefile2
-rw-r--r--security/bsp_upektfmess/Makefile2
-rw-r--r--security/ckpass/Makefile2
-rw-r--r--security/cvm/Makefile2
-rw-r--r--security/fprint_demo/Makefile2
-rw-r--r--security/ifd-slb_rf60/Makefile2
-rw-r--r--security/keepassx2/Makefile2
-rw-r--r--security/libprelude/Makefile12
-rw-r--r--security/libpreludedb/Makefile16
-rw-r--r--security/opensaml2/Makefile8
-rw-r--r--security/openvpn-beta/Makefile6
-rw-r--r--security/osiris/Makefile2
-rw-r--r--security/p5-Authen-Krb5/Makefile2
-rw-r--r--security/p5-Authen-SASL-Cyrus/Makefile2
-rw-r--r--security/p5-PerlCryptLib/Makefile2
-rw-r--r--security/p5-dicewaregen/Makefile2
-rw-r--r--security/pam_bsdbioapi/Makefile2
-rw-r--r--security/pam_fprint/Makefile2
-rw-r--r--security/pcsc-tools/Makefile2
-rw-r--r--security/pecl-crack/Makefile2
-rw-r--r--security/pecl-ssh2/Makefile6
-rw-r--r--security/pond/Makefile2
-rw-r--r--security/prelude-manager/Makefile16
-rw-r--r--security/prelude-pflogger/Makefile2
-rw-r--r--security/putty/Makefile2
-rw-r--r--security/py-cracklib/Makefile2
-rw-r--r--security/py-kerberos/Makefile4
-rw-r--r--security/razorback-fileInject/Makefile2
-rw-r--r--security/razorback-officeCat/Makefile2
-rw-r--r--security/scannedonly/Makefile2
-rw-r--r--security/skipfish/Makefile6
-rw-r--r--security/stegdetect/Makefile2
-rw-r--r--security/zxid/Makefile2
34 files changed, 62 insertions, 64 deletions
diff --git a/security/binwalk/Makefile b/security/binwalk/Makefile
index 93ee2acd53ae..b42b5ddcdc6c 100644
--- a/security/binwalk/Makefile
+++ b/security/binwalk/Makefile
@@ -11,7 +11,7 @@ COMMENT= Search binary images for embedded files and executable code
LICENSE= MIT
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
PLIST_FILES= bin/binwalk \
etc/binwalk/extract.conf \
diff --git a/security/botan110/Makefile b/security/botan110/Makefile
index 13cb54f8651f..dffba6298fc0 100644
--- a/security/botan110/Makefile
+++ b/security/botan110/Makefile
@@ -43,7 +43,7 @@ CONFIGURE_ARGS+=--with-openssl
.endif
.if ${PORT_OPTIONS:MGMP}
-LIB_DEPENDS+= gmp:${PORTSDIR}/math/gmp
+LIB_DEPENDS+= libgmp.so:${PORTSDIR}/math/gmp
CONFIGURE_ARGS+=--with-gnump
MAKE_ARGS+= LDFLAGS="-L${LOCALBASE}/lib"
.endif
diff --git a/security/bsp_upektfmess/Makefile b/security/bsp_upektfmess/Makefile
index b37933485c51..66c7cc82896d 100644
--- a/security/bsp_upektfmess/Makefile
+++ b/security/bsp_upektfmess/Makefile
@@ -12,7 +12,7 @@ DISTNAME= TFMESS_BSP_FreeBSD_1.1
MAINTAINER= ports@FreeBSD.org
COMMENT= UPEK TouchChip TFM/ESS Fingerprint BSP
-LIB_DEPENDS= bioapi100.0:${PORTSDIR}/security/bioapi
+LIB_DEPENDS= libbioapi100.so:${PORTSDIR}/security/bioapi
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/xext.pc:${PORTSDIR}/x11/libXext
PLIST_FILES= lib/libtfmessbsp.so
diff --git a/security/ckpass/Makefile b/security/ckpass/Makefile
index c2cee5dc7b01..00ecd2b59bec 100644
--- a/security/ckpass/Makefile
+++ b/security/ckpass/Makefile
@@ -11,7 +11,7 @@ COMMENT= Ncurses based password database client
LICENSE= GPLv3
-LIB_DEPENDS= kpass:${PORTSDIR}/security/libkpass
+LIB_DEPENDS= libkpass.so:${PORTSDIR}/security/libkpass
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
diff --git a/security/cvm/Makefile b/security/cvm/Makefile
index d840496e0273..0cb005953ea1 100644
--- a/security/cvm/Makefile
+++ b/security/cvm/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://untroubled.org/${PORTNAME}/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= Credential Validation Modules
-LIB_DEPENDS= bg.2:${PORTSDIR}/devel/bglibs
+LIB_DEPENDS= libbg.so:${PORTSDIR}/devel/bglibs
CONFLICTS= bglibs-1.00*
diff --git a/security/fprint_demo/Makefile b/security/fprint_demo/Makefile
index a660e0b77573..94a67978bda4 100644
--- a/security/fprint_demo/Makefile
+++ b/security/fprint_demo/Makefile
@@ -12,7 +12,7 @@ DISTNAME= ${PORTNAME:C/_/-/}_${PORTVERSION}git.orig
MAINTAINER= lichray@gmail.com
COMMENT= Demo and test application for libfprint
-LIB_DEPENDS= fprint:${PORTSDIR}/security/libfprint
+LIB_DEPENDS= libfprint.so:${PORTSDIR}/security/libfprint
USE_AUTOTOOLS= autoconf automake
AUTOMAKE_ARGS= -a
diff --git a/security/ifd-slb_rf60/Makefile b/security/ifd-slb_rf60/Makefile
index 0aa67d326b2d..2640335b1fe2 100644
--- a/security/ifd-slb_rf60/Makefile
+++ b/security/ifd-slb_rf60/Makefile
@@ -11,7 +11,7 @@ DISTNAME= ${PORTNAME:S/^ifd-//}-drv-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= PC/SC Lite driver for the Reflex 62 serial smart card reader
-LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
+LIB_DEPENDS= libpcsclite.so:${PORTSDIR}/devel/pcsc-lite
USES= gmake
CFLAGS+= -fPIC
diff --git a/security/keepassx2/Makefile b/security/keepassx2/Makefile
index 207db072ccbb..a1cebafc11f5 100644
--- a/security/keepassx2/Makefile
+++ b/security/keepassx2/Makefile
@@ -11,7 +11,7 @@ DISTNAME= ${PORTNAME:tl}-${DISTVERSION}${PKGNAMESUFFIX}6
MAINTAINER= eric@camachat.org
COMMENT= Cross Platform Password Manager
-LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt
CONFLICTS_INSTALL= keepassx-0.*
diff --git a/security/libprelude/Makefile b/security/libprelude/Makefile
index 82aac224cb76..125a1ffd5a51 100644
--- a/security/libprelude/Makefile
+++ b/security/libprelude/Makefile
@@ -10,12 +10,12 @@ MASTER_SITES= https://www.prelude-ids.org/attachments/download/241/
MAINTAINER= ports@FreeBSD.org
COMMENT= Framework library for Prelude NIDS
-LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp \
- gnutls:${PORTSDIR}/security/gnutls \
- gcrypt:${PORTSDIR}/security/libgcrypt \
- gpg-error:${PORTSDIR}/security/libgpg-error \
- nettle:${PORTSDIR}/security/nettle \
- p11-kit:${PORTSDIR}/security/p11-kit
+LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
+ libgnutls.so:${PORTSDIR}/security/gnutls \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt \
+ libgpg-error.so:${PORTSDIR}/security/libgpg-error \
+ libnettle.so:${PORTSDIR}/security/nettle \
+ libp11-kit.so:${PORTSDIR}/security/p11-kit
OPTIONS_DEFINE= PERL PYTHON DOCS
diff --git a/security/libpreludedb/Makefile b/security/libpreludedb/Makefile
index 55966948416e..99a1c3dc1e8c 100644
--- a/security/libpreludedb/Makefile
+++ b/security/libpreludedb/Makefile
@@ -10,13 +10,13 @@ MASTER_SITES= https://www.prelude-ids.org/attachments/download/287/
MAINTAINER= ports@FreeBSD.org
COMMENT= Framework library for access to Prelude NIDS database
-LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp \
- gnutls:${PORTSDIR}/security/gnutls \
- gcrypt:${PORTSDIR}/security/libgcrypt \
- gpg-error:${PORTSDIR}/security/libgpg-error \
- prelude:${PORTSDIR}/security/libprelude \
- nettle:${PORTSDIR}/security/nettle \
- p11-kit:${PORTSDIR}/security/p11-kit
+LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
+ libgnutls.so:${PORTSDIR}/security/gnutls \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt \
+ libgpg-error.so:${PORTSDIR}/security/libgpg-error \
+ libprelude.so:${PORTSDIR}/security/libprelude \
+ libnettle.so:${PORTSDIR}/security/nettle \
+ libp11-kit.so:${PORTSDIR}/security/p11-kit
USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
@@ -79,7 +79,7 @@ PLIST_SUB+= WITH_PGSQL="@comment "
USE_SQLITE= yes
CONFIGURE_ARGS+= --with-sqlite3
PLIST_SUB+= WITH_SQLITE=""
-LIB_DEPENDS+= sqlite3:${PORTSDIR}/databases/sqlite3
+LIB_DEPENDS+= libsqlite3.so:${PORTSDIR}/databases/sqlite3
.else
CONFIGURE_ARGS+= --without-sqlite3
PLIST_SUB+= WITH_SQLITE="@comment "
diff --git a/security/opensaml2/Makefile b/security/opensaml2/Makefile
index e06f6a108fb1..e33eada6abe2 100644
--- a/security/opensaml2/Makefile
+++ b/security/opensaml2/Makefile
@@ -11,10 +11,10 @@ DISTNAME= opensaml-${PORTVERSION}
MAINTAINER= girgen@FreeBSD.org
COMMENT= Open source implementation of SAML2
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- log4shib.1:${PORTSDIR}/devel/log4shib \
- xerces-c.3:${PORTSDIR}/textproc/xerces-c3 \
- xmltooling.6:${PORTSDIR}/devel/xmltooling
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
+ liblog4shib.so:${PORTSDIR}/devel/log4shib \
+ libxerces-c.so:${PORTSDIR}/textproc/xerces-c3 \
+ libxmltooling.so:${PORTSDIR}/devel/xmltooling
BUILD_DEPENDS= boost-libs>=0:${PORTSDIR}/devel/boost-libs
diff --git a/security/openvpn-beta/Makefile b/security/openvpn-beta/Makefile
index df5347d965ca..526e6da5b411 100644
--- a/security/openvpn-beta/Makefile
+++ b/security/openvpn-beta/Makefile
@@ -22,7 +22,7 @@ CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install mandir=${MANPREFIX}/man
-LIB_DEPENDS+= lzo2:${PORTSDIR}/archivers/lzo2
+LIB_DEPENDS+= liblzo2.so:${PORTSDIR}/archivers/lzo2
MAN8= openvpn.8
@@ -49,7 +49,7 @@ CFLAGS+= -DLOG_OPENVPN=${LOG_OPENVPN}
.endif
.if ${PORT_OPTIONS:MPOLARSSL}
-LIB_DEPENDS+= polarssl:${PORTSDIR}/security/polarssl
+LIB_DEPENDS+= libpolarssl.so:${PORTSDIR}/security/polarssl
CONFIGURE_ARGS+= --with-crypto-library=polarssl
WITHOUT_CHECK= yes
.else
@@ -73,7 +73,7 @@ CONFIGURE_ARGS+= --enable-password-save
.endif
.if ${PORT_OPTIONS:MPKCS11}
-LIB_DEPENDS+= pkcs11-helper:${PORTSDIR}/security/pkcs11-helper
+LIB_DEPENDS+= libpkcs11-helper.so:${PORTSDIR}/security/pkcs11-helper
.else
CONFIGURE_ARGS+= --disable-pkcs11
.endif
diff --git a/security/osiris/Makefile b/security/osiris/Makefile
index 119c0770d3c9..f21051516e09 100644
--- a/security/osiris/Makefile
+++ b/security/osiris/Makefile
@@ -25,7 +25,7 @@ CLI_DESC= Management CLI
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/libreadline.so.6)
-LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
+LIB_DEPENDS+= libreadline.so.6:${PORTSDIR}/devel/readline
.endif
post-build:
diff --git a/security/p5-Authen-Krb5/Makefile b/security/p5-Authen-Krb5/Makefile
index 1f59e7c0953d..c8f2de91693d 100644
--- a/security/p5-Authen-Krb5/Makefile
+++ b/security/p5-Authen-Krb5/Makefile
@@ -11,7 +11,7 @@ DISTNAME= Krb5-${PORTVERSION}
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl extension for Kerberos 5
-LIB_DEPENDS= krb5.3:${PORTSDIR}/security/krb5
+LIB_DEPENDS= libkrb5.so:${PORTSDIR}/security/krb5
USES= perl5
USE_PERL5= configure
diff --git a/security/p5-Authen-SASL-Cyrus/Makefile b/security/p5-Authen-SASL-Cyrus/Makefile
index d802c4693dd4..e6cccb1afab1 100644
--- a/security/p5-Authen-SASL-Cyrus/Makefile
+++ b/security/p5-Authen-SASL-Cyrus/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= XS SASL Authentication
BUILD_DEPENDS= p5-Authen-SASL>=0:${PORTSDIR}/security/p5-Authen-SASL
-LIB_DEPENDS= sasl2:${PORTSDIR}/security/cyrus-sasl2
+LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
diff --git a/security/p5-PerlCryptLib/Makefile b/security/p5-PerlCryptLib/Makefile
index f23519db2261..a0107931ad50 100644
--- a/security/p5-PerlCryptLib/Makefile
+++ b/security/p5-PerlCryptLib/Makefile
@@ -11,7 +11,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl interface to Peter Guttman cryptlib API
-LIB_DEPENDS= cl:${PORTSDIR}/security/cryptlib
+LIB_DEPENDS= libcl.so:${PORTSDIR}/security/cryptlib
USES= perl5
USE_PERL5= configure
diff --git a/security/p5-dicewaregen/Makefile b/security/p5-dicewaregen/Makefile
index 884dce7df42b..52b05aebde04 100644
--- a/security/p5-dicewaregen/Makefile
+++ b/security/p5-dicewaregen/Makefile
@@ -10,7 +10,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= graudeejs@gmail.com
COMMENT= A simple perl script to generate Diceware dictionaries for passwords
-LIB_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
+LIB_DEPENDS+= libaspell.so:${PORTSDIR}/textproc/aspell
USES= perl5
USE_PERL5= run
diff --git a/security/pam_bsdbioapi/Makefile b/security/pam_bsdbioapi/Makefile
index 6f44500cd3fa..f2847bb078e4 100644
--- a/security/pam_bsdbioapi/Makefile
+++ b/security/pam_bsdbioapi/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= http://www.shapeshifter.se/pub/pam_bsdbioapi/
MAINTAINER= ports@FreeBSD.org
COMMENT= PAM module for BioAPI
-LIB_DEPENDS= bioapi100.0:${PORTSDIR}/security/bioapi
+LIB_DEPENDS= libbioapi100.so:${PORTSDIR}/security/bioapi
USE_LDCONFIG= yes
SUB_FILES= pkg-message
diff --git a/security/pam_fprint/Makefile b/security/pam_fprint/Makefile
index 3b907cc817fd..e3ac18550049 100644
--- a/security/pam_fprint/Makefile
+++ b/security/pam_fprint/Makefile
@@ -12,7 +12,7 @@ DISTNAME= ${PORTNAME:C/_/-/}_${PORTVERSION}+git.orig
MAINTAINER= lichray@gmail.com
COMMENT= PAM module offering finger print authentication using libfprint
-LIB_DEPENDS= fprint:${PORTSDIR}/security/libfprint
+LIB_DEPENDS= libfprint.so:${PORTSDIR}/security/libfprint
USE_AUTOTOOLS= autoconf automake
AUTOMAKE_ARGS= -a
diff --git a/security/pcsc-tools/Makefile b/security/pcsc-tools/Makefile
index 827d35917d93..5a51cbbab2d8 100644
--- a/security/pcsc-tools/Makefile
+++ b/security/pcsc-tools/Makefile
@@ -11,7 +11,7 @@ COMMENT= Tools to test a PCSC driver, card, or reader
LICENSE= GPLv2
-LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
+LIB_DEPENDS= libpcsclite.so:${PORTSDIR}/devel/pcsc-lite
RUN_DEPENDS= p5-PCSC-Card>=0:${PORTSDIR}/devel/p5-PCSC-Card \
p5-Gtk2>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2
diff --git a/security/pecl-crack/Makefile b/security/pecl-crack/Makefile
index 7b6fb28d8779..1b45e0487f51 100644
--- a/security/pecl-crack/Makefile
+++ b/security/pecl-crack/Makefile
@@ -13,7 +13,7 @@ DIST_SUBDIR= PECL
MAINTAINER= wmoran@collaborativefusion.com
COMMENT= PECL extension to cracklib
-LIB_DEPENDS= crack:${PORTSDIR}/security/cracklib
+LIB_DEPENDS= libcrack.so:${PORTSDIR}/security/cracklib
USE_PHP= yes
USE_PHPIZE= yes
diff --git a/security/pecl-ssh2/Makefile b/security/pecl-ssh2/Makefile
index 4e0f78d538c1..82cac7972d93 100644
--- a/security/pecl-ssh2/Makefile
+++ b/security/pecl-ssh2/Makefile
@@ -11,7 +11,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= miwi@FreeBSD.org
COMMENT= A PECL extension to the libssh2 library
-LIB_DEPENDS= ssh2:${PORTSDIR}/security/libssh2
+LIB_DEPENDS= libssh2.so:${PORTSDIR}/security/libssh2
USE_PHP= yes
USE_PHPEXT= yes
@@ -21,9 +21,7 @@ LDFLAGS+= -L${LOCALBASE}/lib ${EXTRA_LIBS}
CONFIGURE_ARGS= --with-ssh2
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|\$$SSH2_DIR/lib|\$$SSH2_DIR/\$$PHP_LIBDIR|g' ${WRKSRC}/config.m4
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/pond/Makefile b/security/pond/Makefile
index 79f3a47d2295..84208064fe72 100644
--- a/security/pond/Makefile
+++ b/security/pond/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= ${LOCALBASE}/${GO_LIBDIR}/code.google.com/p/go.crypto/bcrypt.a:${
${LOCALBASE}/${GO_LIBDIR}/code.google.com/p/goprotobuf/proto.a:${PORTSDIR}/devel/goprotobuf \
${LOCALBASE}/${GO_LIBDIR}/code.google.com/p/go.net/dict.a:${PORTSDIR}/net/go.net
RUN_DEPENDS= tor:${PORTSDIR}/security/tor
-LIB_DEPENDS= gtkspell:${PORTSDIR}/textproc/gtkspell \
+LIB_DEPENDS= libgtkspell.so:${PORTSDIR}/textproc/gtkspell \
libtspi.so:${PORTSDIR}/security/trousers
BROKEN= Experimental. Know what you do!
diff --git a/security/prelude-manager/Makefile b/security/prelude-manager/Makefile
index 3ae49f0e8051..310bc1ba27bb 100644
--- a/security/prelude-manager/Makefile
+++ b/security/prelude-manager/Makefile
@@ -10,14 +10,14 @@ MASTER_SITES= https://www.prelude-ids.org/attachments/download/243/
MAINTAINER= ports@FreeBSD.org
COMMENT= Prelude Network Intrusion Detection System central logging point
-LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp \
- gnutls:${PORTSDIR}/security/gnutls \
- gcrypt:${PORTSDIR}/security/libgcrypt \
- gpg-error:${PORTSDIR}/security/libgpg-error \
- prelude:${PORTSDIR}/security/libprelude \
- preludedb:${PORTSDIR}/security/libpreludedb \
- nettle:${PORTSDIR}/security/nettle \
- p11-kit:${PORTSDIR}/security/p11-kit
+LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
+ libgnutls.so:${PORTSDIR}/security/gnutls \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt \
+ libgpg-error.so:${PORTSDIR}/security/libgpg-error \
+ libprelude.so:${PORTSDIR}/security/libprelude \
+ libpreludedb.so:${PORTSDIR}/security/libpreludedb \
+ libnettle.so:${PORTSDIR}/security/nettle \
+ libp11-kit.so:${PORTSDIR}/security/p11-kit
USES= pkgconfig gettext iconv gmake
USE_AUTOTOOLS= libltdl
diff --git a/security/prelude-pflogger/Makefile b/security/prelude-pflogger/Makefile
index b5dc9391385a..df6d42b38c23 100644
--- a/security/prelude-pflogger/Makefile
+++ b/security/prelude-pflogger/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://www.prelude-ids.com/download/releases/${PORTNAME}/
MAINTAINER= ports@FreeBSD.org
COMMENT= Prelude-PFlogger Listens at OpenBSD PF
-LIB_DEPENDS+= prelude:${PORTSDIR}/security/libprelude
+LIB_DEPENDS+= libprelude.so:${PORTSDIR}/security/libprelude
USES= gmake
GNU_CONFIGURE= yes
diff --git a/security/putty/Makefile b/security/putty/Makefile
index 3bdaf542b219..aef2f33d5d9d 100644
--- a/security/putty/Makefile
+++ b/security/putty/Makefile
@@ -42,7 +42,7 @@ MAKE_ARGS+= GTK_CONFIG=:
.if ${PORT_OPTIONS:MGSSAPI}
_COMPAT= -DSTATIC_GSSAPI
.if ${OSVERSION} >= 900000
-LIB_DEPENDS+= krb5support:${PORTSDIR}/security/krb5
+LIB_DEPENDS+= libkrb5support.so:${PORTSDIR}/security/krb5
.endif
.else
_COMPAT= -DNO_GSSAPI
diff --git a/security/py-cracklib/Makefile b/security/py-cracklib/Makefile
index f14b9c67cd33..776a460269e0 100644
--- a/security/py-cracklib/Makefile
+++ b/security/py-cracklib/Makefile
@@ -6,7 +6,7 @@ COMMENT= Python bindings for cracklib
LICENSE= LGPL21
-LIB_DEPENDS= crack:${PORTSDIR}/security/cracklib
+LIB_DEPENDS= libcrack.so:${PORTSDIR}/security/cracklib
MASTERDIR= ${.CURDIR}/../cracklib
BUILD_WRKSRC= ${WRKSRC}/python
diff --git a/security/py-kerberos/Makefile b/security/py-kerberos/Makefile
index 3072b2ce46ae..74295d986473 100644
--- a/security/py-kerberos/Makefile
+++ b/security/py-kerberos/Makefile
@@ -13,8 +13,8 @@ COMMENT= Kerberos bindings for python
LICENSE= APACHE20
-BUILD_DEPENDS= krb5-config:${PORTSDIR}/security/krb5
-LIB_DEPENDS= krb5support.0:${PORTSDIR}/security/krb5
+BUILD_DEPENDS= libkrb5-config.so:${PORTSDIR}/security/krb5
+LIB_DEPENDS= libkrb5support.so:${PORTSDIR}/security/krb5
USE_PYTHON= yes
USE_PYDISTUTILS= yes
diff --git a/security/razorback-fileInject/Makefile b/security/razorback-fileInject/Makefile
index a39357ced23c..057e5f44f0d7 100644
--- a/security/razorback-fileInject/Makefile
+++ b/security/razorback-fileInject/Makefile
@@ -14,7 +14,7 @@ COMMENT= Framework for an intelligence driven security - File Injector
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= razorback_api.2:${PORTSDIR}/security/razorback-api
+LIB_DEPENDS= librazorback_api.so:${PORTSDIR}/security/razorback-api
OPTIONS_DEFINE= DEBUG ASSERT
diff --git a/security/razorback-officeCat/Makefile b/security/razorback-officeCat/Makefile
index 350f74464dd9..6261151002a6 100644
--- a/security/razorback-officeCat/Makefile
+++ b/security/razorback-officeCat/Makefile
@@ -14,7 +14,7 @@ COMMENT= Framework for an intelligence driven security - OfficeCat Detection
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= razorback_api:${PORTSDIR}/security/razorback-api
+LIB_DEPENDS= librazorback_api.so:${PORTSDIR}/security/razorback-api
BUILD_DEPENDS= razorback-masterNugget>=0.5.0:${PORTSDIR}/security/razorback-masterNugget \
wine:${PORTSDIR}/emulators/wine
RUN_DEPENDS= razorback-masterNugget>=0.5.0:${PORTSDIR}/security/razorback-masterNugget \
diff --git a/security/scannedonly/Makefile b/security/scannedonly/Makefile
index 1ea837876ff7..faf1f0717b54 100644
--- a/security/scannedonly/Makefile
+++ b/security/scannedonly/Makefile
@@ -11,7 +11,7 @@ COMMENT= A Samba VFS virus scanning daemon
LICENSE= GPLv2
-LIB_DEPENDS= clamav:${PORTSDIR}/security/clamav
+LIB_DEPENDS= libclamav.so:${PORTSDIR}/security/clamav
RUN_DEPENDS= ${LOCALBASE}/bin/clamdscan:${PORTSDIR}/security/clamav \
smbd:${PORTSDIR}/${SAMBA_PORT}
BUILD_DEPENDS+= smbd:${PORTSDIR}/${SAMBA_PORT}
diff --git a/security/skipfish/Makefile b/security/skipfish/Makefile
index 50ecca213084..8bcbce281491 100644
--- a/security/skipfish/Makefile
+++ b/security/skipfish/Makefile
@@ -14,9 +14,9 @@ COMMENT= A fully automated, active web application security reconnaissance tool
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= idn:${PORTSDIR}/dns/libidn \
- pcre:${PORTSDIR}/devel/pcre
-
+LIB_DEPENDS= libidn.so:${PORTSDIR}/dns/libidn \
+ libpcre.so:${PORTSDIR}/devel/pcre
+
USES= gmake
SUB_FILES= pkg-message
diff --git a/security/stegdetect/Makefile b/security/stegdetect/Makefile
index b3ea4ce3e3c0..c7a1bd18bbc3 100644
--- a/security/stegdetect/Makefile
+++ b/security/stegdetect/Makefile
@@ -18,7 +18,7 @@ OPTIONS_DEFAULT= X11
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MX11}
-LIB_DEPENDS= event-1.4:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= libevent-1.4.so:${PORTSDIR}/devel/libevent
USE_GNOME= gtk12
CONFIGURE_ENV+= PATH_GTKCONFIG="${GTK_CONFIG}"
PLIST_SUB+= X11=""
diff --git a/security/zxid/Makefile b/security/zxid/Makefile
index d9046d1dfb65..bf0b1cfceb50 100644
--- a/security/zxid/Makefile
+++ b/security/zxid/Makefile
@@ -11,7 +11,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= clsung@FreeBSD.org
COMMENT= Open Source IdM for the Masses - SAML SSO
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
MAKE_JOBS_UNSAFE= yes