aboutsummaryrefslogtreecommitdiff
path: root/shells/bash1
diff options
context:
space:
mode:
Diffstat (limited to 'shells/bash1')
-rw-r--r--shells/bash1/Makefile37
-rw-r--r--shells/bash1/distinfo2
-rw-r--r--shells/bash1/files/patch-aa20
-rw-r--r--shells/bash1/files/patch-ab56
-rw-r--r--shells/bash1/files/patch-ac41
-rw-r--r--shells/bash1/files/patch-ad47
-rw-r--r--shells/bash1/files/patch-ae17
-rw-r--r--shells/bash1/files/patch-ag13
-rw-r--r--shells/bash1/files/patch-ah54
-rw-r--r--shells/bash1/files/patch-ai11
-rw-r--r--shells/bash1/files/patch-aj12
-rw-r--r--shells/bash1/files/patch-ak13
-rw-r--r--shells/bash1/files/patch-al13
-rw-r--r--shells/bash1/files/patch-bashbug.sh11
-rw-r--r--shells/bash1/files/patch-builtins-common.c30
-rw-r--r--shells/bash1/files/patch-builtins-common.h11
-rw-r--r--shells/bash1/files/patch-error.c102
-rw-r--r--shells/bash1/files/patch-error.h16
-rw-r--r--shells/bash1/files/patch-execute_cmd.c28
-rw-r--r--shells/bash1/files/patch-print_cmd.c41
-rw-r--r--shells/bash1/files/patch-readline-display.c18
-rw-r--r--shells/bash1/files/patch-readline-readline.h12
-rw-r--r--shells/bash1/files/patch-readline-rldefs.h11
-rw-r--r--shells/bash1/files/patch-shell.c11
-rw-r--r--shells/bash1/files/patch-support-mksysdefs14
-rw-r--r--shells/bash1/files/patch-test.c18
-rw-r--r--shells/bash1/pkg-descr10
-rw-r--r--shells/bash1/pkg-plist5
28 files changed, 0 insertions, 674 deletions
diff --git a/shells/bash1/Makefile b/shells/bash1/Makefile
deleted file mode 100644
index 26b51a3b0b2f..000000000000
--- a/shells/bash1/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-# ex:ts=8
-# Ports collection makefile for: bash
-# Date created: 21 August 1994
-# Whom: jkh
-#
-# $FreeBSD$
-#
-
-PORTNAME= bash
-PORTVERSION= 1.14.7
-CATEGORIES= shells
-MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= bash
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= The GNU Bourne Again Shell -- old version
-
-DEPRECATED= Bash 1.x is EOL, please use shells/bash.
-EXPIRATION_DATE= 2004-08-25
-
-NO_LATEST_LINK= yes
-WRKSRC= ${WRKDIR}/${DISTNAME}
-# Don't compress manpages or .so not works.
-NOMANCOMPRESS= yes
-MAN1= bash.1 bash_builtins.1
-INFO= bash
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "ia64"
-BROKEN= "Does not compile on ia64"
-.endif
-
-post-install:
- @install-info ${PREFIX}/info/bash.info ${PREFIX}/info/dir
-
-.include <bsd.port.post.mk>
diff --git a/shells/bash1/distinfo b/shells/bash1/distinfo
deleted file mode 100644
index 7eb2c0e3c32c..000000000000
--- a/shells/bash1/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (bash-1.14.7.tar.gz) = 2ba8f27c9861d57826e695278a240a04
-SIZE (bash-1.14.7.tar.gz) = 1518180
diff --git a/shells/bash1/files/patch-aa b/shells/bash1/files/patch-aa
deleted file mode 100644
index 6103b663f0c4..000000000000
--- a/shells/bash1/files/patch-aa
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.orig Sun Jun 11 11:41:48 1995
-+++ Makefile Sat Nov 27 19:01:13 1999
-@@ -10,7 +10,7 @@
- # If you haven't read README, now might be a good time.
-
- # Include some boilerplate Gnu makefile definitions.
--prefix = /usr/local
-+prefix = $(PREFIX)
- exec_prefix = $(prefix)
- bindir = $(exec_prefix)/bin
- srcdir = .
-@@ -25,7 +25,7 @@
- # Force CPPNAME to be the name of your C preprocesor if Bash can't
- # find it. For instance, `CPPNAME=/usr/libexec/cpp' on 4.4 BSD.
- # If all else fails, set CPPNAME=$(CC) -E
--CPPNAME =
-+CPPNAME = $(CC) -E
- CPP = `$(SHELL) $(CPPMAGIC) $(GETCPPSYMS) "$(CPPNAME)"` -P
-
- CPP_MAKEFILE = $(srcdir)/cpp-Makefile
diff --git a/shells/bash1/files/patch-ab b/shells/bash1/files/patch-ab
deleted file mode 100644
index 908154888e5c..000000000000
--- a/shells/bash1/files/patch-ab
+++ /dev/null
@@ -1,56 +0,0 @@
-*** cpp-Makefile.orig Sun Jun 11 22:44:05 1995
---- cpp-Makefile Wed Jul 19 20:17:18 1995
-***************
-*** 133,139 ****
---- 133,143 ----
- /usr/include. Then it will break.) */
- CC = gcc -traditional -I/usr/include $(GCC_EXTRAS)
- # else /* HAVE_FIXED_INCLUDES */
-+ #ifdef __FreeBSD__
-+ CC += $(GCC_EXTRAS)
-+ #else
- CC = gcc $(GCC_EXTRAS)
-+ #endif
- # endif /* HAVE_FIXED_INCLUDES */
- #else /* !HAVE_GCC */
- CC = CPP_CC
-***************
-*** 151,158 ****
---- 155,167 ----
- AR = ar
-
- INSTALL = $(SUPPORT_SRC)install.sh
-+ #ifndef __FreeBSD__
- INSTALL_PROGRAM = $(INSTALL) -c
- INSTALL_DATA = $(INSTALL) -c -m 644
-+ #else
-+ INSTALL_PROGRAM = install -c -o bin -g bin -m 555
-+ INSTALL_DATA = install -c -o bin -g bin -m 644
-+ #endif
-
- COMPRESS = gzip
- COMPRESS_EXT = .gz
-***************
-*** 300,306 ****
---- 309,317 ----
- /**/# The GNU coding standards don't recognize the possibility that
- /**/# other information besides optimization and debugging might be
- /**/# passed to cc. A different name should have been used.
-+ #ifndef __FreeBSD__
- CFLAGS = -O -g
-+ #endif
-
- SYSTEM_FLAGS = $(LINEBUF) $(VPRINTF) $(UNISTD) $(STDLIB) $(LIMITSH) \
- $(GROUPS) $(RESOURCE) $(PARAM) $(SIGHANDLER) $(SYSDEP) $(WAITH) \
-***************
-*** 308,313 ****
---- 319,327 ----
- $(VARARGSH) $(STRCHR) $(STRCASE) $(DEVFD) \
- -D$(Machine) -D$(OS)
- LDFLAGS = $(NOSHARE) $(SYSDEP_LD) $(EXTRA_LD_PATH) $(PROFILE_FLAGS) $(CFLAGS)
-+ #ifdef __FreeBSD__
-+ LDFLAGS += -s
-+ #endif
- CCFLAGS = $(PROFILE_FLAGS) $(SYSTEM_FLAGS) -DSHELL $(ALLOCA_CFLAGS) \
- $(MALLOC_CFLAGS) $(CFLAGS)
- CPPFLAGS= -I. -I$(srcdir) -I$(LIBSRC)
diff --git a/shells/bash1/files/patch-ac b/shells/bash1/files/patch-ac
deleted file mode 100644
index 4176de4b36a0..000000000000
--- a/shells/bash1/files/patch-ac
+++ /dev/null
@@ -1,41 +0,0 @@
-*** readline.c.orig Wed May 24 18:43:28 1995
---- lib/readline/readline.c Wed Jul 19 20:26:53 1995
-***************
-*** 958,964 ****
- static void
- readline_initialize_everything ()
- {
-! char *t;
-
- /* Find out if we are running in Emacs. */
- running_in_emacs = getenv ("EMACS") != (char *)0;
---- 958,964 ----
- static void
- readline_initialize_everything ()
- {
-! char *t, *t1;
-
- /* Find out if we are running in Emacs. */
- running_in_emacs = getenv ("EMACS") != (char *)0;
-***************
-*** 993,1000 ****
- /* Check for LC_CTYPE and use its value to decide the defaults for
- 8-bit character input and output. */
- t = getenv ("LC_CTYPE");
-! if (t && (strcmp (t, "iso-8859-1") == 0 || strcmp (t, "iso_8859_1") == 0 ||
-! strcmp (t, "ISO-8859-1") == 0))
- {
- _rl_meta_flag = 1;
- _rl_convert_meta_chars_to_ascii = 0;
---- 993,1003 ----
- /* Check for LC_CTYPE and use its value to decide the defaults for
- 8-bit character input and output. */
- t = getenv ("LC_CTYPE");
-! t1 = getenv ("LANG");
-! if (t && (strstr (t, "8859-1") != NULL || strstr (t, "8859_1") != NULL ||
-! strstr (t, "KOI8-R") != NULL || strstr (t, "koi8-r") != NULL) ||
-! t1 && (strstr (t1, "8859-1") != NULL || strstr (t1, "8859_1") != NULL ||
-! strstr (t1, "KOI8-R") != NULL || strstr (t1, "koi8-r") != NULL))
- {
- _rl_meta_flag = 1;
- _rl_convert_meta_chars_to_ascii = 0;
diff --git a/shells/bash1/files/patch-ad b/shells/bash1/files/patch-ad
deleted file mode 100644
index 956d4d2ddbd0..000000000000
--- a/shells/bash1/files/patch-ad
+++ /dev/null
@@ -1,47 +0,0 @@
-*** documentation/Makefile.orig Mon Jun 12 03:45:55 1995
---- documentation/Makefile Mon Jun 16 19:30:13 1997
-***************
-*** 49,55 ****
- $(RM) $@
- ${NROFF} -man $< > $@
-
-! all: ps info dvi text
-
- ps: bash.ps readline.ps article.ps
- dvi: features.dvi features.ps
---- 49,55 ----
- $(RM) $@
- ${NROFF} -man $< > $@
-
-! all: info # ps dvi text
-
- ps: bash.ps readline.ps article.ps
- dvi: features.dvi features.ps
-***************
-*** 90,101 ****
-
- installdirs:
- -[ -d $(mandir) ] || mkdir $(mandir)
-! -[ -d $(man3dir) ] || mkdir $(man3dir)
- -[ -d $(infodir) ] || mkdir $(infodir)
-
- install: all installdirs
- $(INSTALL_DATA) bash.1 $(mandir)
-! $(INSTALL_DATA) readline.3 $(man3dir)
- $(INSTALL_DATA) features.info $(infodir)/bash.info
-
- uninstall:
---- 90,102 ----
-
- installdirs:
- -[ -d $(mandir) ] || mkdir $(mandir)
-! # -[ -d $(man3dir) ] || mkdir $(man3dir)
- -[ -d $(infodir) ] || mkdir $(infodir)
-
- install: all installdirs
- $(INSTALL_DATA) bash.1 $(mandir)
-! $(INSTALL_DATA) builtins.1 $(mandir)/bash_builtins.1
-! # $(INSTALL_DATA) readline.3 $(man3dir)
- $(INSTALL_DATA) features.info $(infodir)/bash.info
-
- uninstall:
diff --git a/shells/bash1/files/patch-ae b/shells/bash1/files/patch-ae
deleted file mode 100644
index ec58ff4ae41a..000000000000
--- a/shells/bash1/files/patch-ae
+++ /dev/null
@@ -1,17 +0,0 @@
-*** documentation/builtins.1.bak Sat Sep 18 00:06:53 1993
---- documentation/builtins.1 Wed Oct 4 23:29:49 1995
-***************
-*** 10,15 ****
- unset, until, wait, while \- bash built-in commands, see \fBbash\fR(1)
- .SH BASH BUILTIN COMMANDS
- .nr zZ 1
-! .so bash.1
- .SH SEE ALSO
- bash(1), sh(1)
---- 10,15 ----
- unset, until, wait, while \- bash built-in commands, see \fBbash\fR(1)
- .SH BASH BUILTIN COMMANDS
- .nr zZ 1
-! .so man1/bash.1
- .SH SEE ALSO
- bash(1), sh(1)
diff --git a/shells/bash1/files/patch-ag b/shells/bash1/files/patch-ag
deleted file mode 100644
index 56b74093c828..000000000000
--- a/shells/bash1/files/patch-ag
+++ /dev/null
@@ -1,13 +0,0 @@
---- documentation/features.texi.orig Fri Aug 5 04:26:21 1994
-+++ documentation/features.texi Mon Jun 16 19:16:56 1997
-@@ -2,6 +2,10 @@
- @c %**start of header
- @setfilename features.info
- @settitle Bash Features
-+@dircategory Shells
-+@direntry
-+* Bash: (bash). GNU Bourne-Again SHell.
-+@end direntry
- @c %**end of header
-
- @ignore
diff --git a/shells/bash1/files/patch-ah b/shells/bash1/files/patch-ah
deleted file mode 100644
index 40571f255852..000000000000
--- a/shells/bash1/files/patch-ah
+++ /dev/null
@@ -1,54 +0,0 @@
---- machines.h.orig Mon Dec 18 20:13:22 1995
-+++ machines.h Fri Dec 12 11:02:59 2003
-@@ -63,7 +63,7 @@
- some machines, our malloc () cannot be used (because of library
- conflicts, for example), and for those, you should specifically
- #undef USE_GNU_MALLOC in the machine description. */
--#define USE_GNU_MALLOC
-+#undef USE_GNU_MALLOC
-
- /* This causes the Gnu malloc library (from glibc) to be used. */
- /* #define USE_GNU_MALLOC_LIBRARY */
-@@ -846,11 +847,6 @@
- # define done386
- # define M_MACHINE "i386"
- # define M_OS "FreeBSD"
--# if __FreeBSD__ > 1
--# define SYSDEP_CFLAGS -D__BSD_4_4__ -DRLIMTYPE=quad_t
--# else
--# define SYSDEP_CFLAGS -DOPENDIR_NOT_ROBUST -DINT_GROUPS_ARRAY
--# endif
- # define HAVE_SYS_SIGLIST
- # define HAVE_SETLINEBUF
- # define HAVE_GETGROUPS
-@@ -2390,3 +2386,30 @@
- # endif /* LD_HAS_NO_DASH_L */
-
- #endif /* UNKNOWN_MACHINE */
-+
-+/* FreeBSD overrides */
-+#if defined (__sparc64__)
-+# define M_MACHINE "sun4u"
-+#endif
-+#if defined (__ia64__)
-+# define M_MACHINE "ia64"
-+#endif
-+#if defined (__amd64__)
-+# define M_MACHINE "amd64"
-+#endif
-+#define M_OS "FreeBSD"
-+#if __FreeBSD__ > 1
-+# define SYSDEP_CFLAGS -D__BSD_4_4__ -DRLIMTYPE=quad_t
-+#else
-+# define SYSDEP_CFLAGS -DOPENDIR_NOT_ROBUST -DINT_GROUPS_ARRAY
-+#endif
-+#define SYSDEP_LDFLAGS -static
-+#define HAVE_SYS_SIGLIST
-+#define HAVE_SETLINEBUF
-+#define HAVE_GETGROUPS
-+#define HAVE_VFPRINTF
-+#define HAVE_STRERROR
-+#define VOID_SIGHANDLER
-+#define HAVE_DIRENT
-+#define HAVE_STRCASECMP
-+#define GCC_STANDARD
diff --git a/shells/bash1/files/patch-ai b/shells/bash1/files/patch-ai
deleted file mode 100644
index e51bb707a183..000000000000
--- a/shells/bash1/files/patch-ai
+++ /dev/null
@@ -1,11 +0,0 @@
---- siglist.h.orig Mon Mar 15 07:21:34 1999
-+++ siglist.h Mon Mar 15 07:21:50 1999
-@@ -28,7 +28,7 @@
- #endif /* Solaris || USGr4_2 || drs6000 || amiga || Minix */
-
- #if !defined (Solaris) && !defined (Linux) && !defined (__BSD_4_4__) && \
-- !defined (Minix) && !defined (NetBSD) && !defined (FreeBSD) && \
-+ !defined (Minix) && !defined (NetBSD) && !defined (__FreeBSD__) && \
- !defined (BSD_OS)
- extern char *sys_siglist[];
- #endif /* !Solaris && !Linux && !__BSD_4_4__ && !Minix && !NetBSD && !FreeBSD && !BSD_OS */
diff --git a/shells/bash1/files/patch-aj b/shells/bash1/files/patch-aj
deleted file mode 100644
index fed357fc09d3..000000000000
--- a/shells/bash1/files/patch-aj
+++ /dev/null
@@ -1,12 +0,0 @@
-*** ./subst.c.orig Wed Nov 17 18:40:38 1999
---- ./subst.c Wed Nov 17 18:40:59 1999
-*************** process_substitute (string, open_for_rea
-*** 2021,2026 ****
---- 2021,2027 ----
- pid = make_child ((char *)NULL, 1);
- if (pid == 0)
- {
-+ reset_terminating_signals();
- /* Cancel traps, in trap.c. */
- restore_original_signals ();
- setup_async_signals ();
diff --git a/shells/bash1/files/patch-ak b/shells/bash1/files/patch-ak
deleted file mode 100644
index db1ef8527ed3..000000000000
--- a/shells/bash1/files/patch-ak
+++ /dev/null
@@ -1,13 +0,0 @@
-*** ./trap.c.orig Wed Nov 17 18:36:19 1999
---- ./trap.c Wed Nov 17 18:36:29 1999
-*************** restore_original_signals ()
-*** 556,563 ****
- {
- register int i;
-
-- reset_terminating_signals (); /* in shell.c */
--
- if (sigmodes[0] & SIG_TRAPPED)
- {
- free_trap_command (0);
---- 556,561 ----
diff --git a/shells/bash1/files/patch-al b/shells/bash1/files/patch-al
deleted file mode 100644
index 77f2b3aa1e06..000000000000
--- a/shells/bash1/files/patch-al
+++ /dev/null
@@ -1,13 +0,0 @@
-*** ./execute_cmd.c.orig Wed Nov 17 18:37:45 1999
---- ./execute_cmd.c Wed Nov 17 18:37:53 1999
-*************** execute_command_internal (command, async
-*** 340,345 ****
---- 340,347 ----
- {
- int user_subshell, return_code, function_value;
-
-+ reset_terminating_signals();
-+
- /* Cancel traps, in trap.c. */
- restore_original_signals ();
- if (asynchronous)
diff --git a/shells/bash1/files/patch-bashbug.sh b/shells/bash1/files/patch-bashbug.sh
deleted file mode 100644
index b2ab8f36e4d1..000000000000
--- a/shells/bash1/files/patch-bashbug.sh
+++ /dev/null
@@ -1,11 +0,0 @@
---- support/bashbug.sh.race Thu Aug 27 17:21:28 1998
-+++ support/bashbug.sh Thu Aug 27 17:23:40 1998
-@@ -15,7 +15,7 @@
- PATH=/bin:/usr/bin:usr/local/bin:$PATH
- export PATH
-
--TEMP=/tmp/bashbug.$$
-+TEMP=`/bin/mktemp /tmp/bashbug.XXXXXX`
-
- BUGADDR=${1-bug-bash@prep.ai.mit.edu}
-
diff --git a/shells/bash1/files/patch-builtins-common.c b/shells/bash1/files/patch-builtins-common.c
deleted file mode 100644
index 1bc0267dd5c7..000000000000
--- a/shells/bash1/files/patch-builtins-common.c
+++ /dev/null
@@ -1,30 +0,0 @@
---- builtins/common.c.orig Fri Aug 29 12:14:26 2003
-+++ builtins/common.c Fri Aug 29 12:18:31 2003
-@@ -20,7 +20,7 @@
- #include <sys/types.h>
- #include "../posixstat.h"
- #if defined (HAVE_VFPRINTF)
--#include <varargs.h>
-+#include <stdarg.h>
- #endif /* VFPRINTF */
-
- #if defined (HAVE_STRING_H)
-@@ -114,16 +114,14 @@
- shell. */
- #if defined (HAVE_VFPRINTF)
- void
--builtin_error (va_alist)
-- va_dcl
-+builtin_error (char *format, ...)
- {
-- char *format;
- va_list args;
-
- if (this_command_name && *this_command_name)
- fprintf (stderr, "%s: ", this_command_name);
-
-- va_start (args);
-+ va_start (args, format);
- format = va_arg (args, char *);
- vfprintf (stderr, format, args);
- va_end (args);
diff --git a/shells/bash1/files/patch-builtins-common.h b/shells/bash1/files/patch-builtins-common.h
deleted file mode 100644
index 68845dc1ca5e..000000000000
--- a/shells/bash1/files/patch-builtins-common.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- builtins/common.h.orig Fri Aug 29 12:14:20 2003
-+++ builtins/common.h Fri Aug 29 12:14:46 2003
-@@ -23,7 +23,7 @@
-
- #define ISOPTION(s, c) (s[0] == '-' && !s[2] && s[1] == c)
-
--extern void builtin_error ();
-+extern void builtin_error (char *, ...);
- extern void bad_option ();
-
- extern int get_numeric_arg ();
diff --git a/shells/bash1/files/patch-error.c b/shells/bash1/files/patch-error.c
deleted file mode 100644
index 6d29429fe339..000000000000
--- a/shells/bash1/files/patch-error.c
+++ /dev/null
@@ -1,102 +0,0 @@
---- error.c.orig Fri Aug 29 12:21:42 2003
-+++ error.c Fri Aug 29 12:24:18 2003
-@@ -22,7 +22,7 @@
- #include <fcntl.h>
-
- #if defined (HAVE_VFPRINTF)
--#include <varargs.h>
-+#include <stdarg.h>
- #endif
-
- #include <errno.h>
-@@ -121,18 +121,15 @@
- #else /* We have VARARGS support, so use it. */
-
- void
--programming_error (va_alist)
-- va_dcl
-+programming_error (char *format, ...)
- {
- va_list args;
-- char *format;
-
- #if defined (JOB_CONTROL)
- give_terminal_to (shell_pgrp);
- #endif /* JOB_CONTROL */
-
-- va_start (args);
-- format = va_arg (args, char *);
-+ va_start (args, format);
- vfprintf (stderr, format, args);
- fprintf (stderr, "\n");
- va_end (args);
-@@ -144,15 +141,12 @@
- }
-
- void
--report_error (va_alist)
-- va_dcl
-+report_error (char *format, ...)
- {
- va_list args;
-- char *format;
-
- fprintf (stderr, "%s: ", get_name_for_error ());
-- va_start (args);
-- format = va_arg (args, char *);
-+ va_start (args, format);
- vfprintf (stderr, format, args);
- fprintf (stderr, "\n");
-
-@@ -162,15 +156,12 @@
- }
-
- void
--fatal_error (va_alist)
-- va_dcl
-+fatal_error (char *format, ...)
- {
- va_list args;
-- char *format;
-
- fprintf (stderr, "%s: ", get_name_for_error ());
-- va_start (args);
-- format = va_arg (args, char *);
-+ va_start (args, format);
- vfprintf (stderr, format, args);
- fprintf (stderr, "\n");
-
-@@ -179,14 +170,12 @@
- }
-
- void
--internal_error (va_alist)
-- va_dcl
-+internal_error (char *format, ...)
- {
- va_list args;
-- char *format;
-
- fprintf (stderr, "%s: ", get_name_for_error ());
-- va_start (args);
-+ va_start (args, format);
- format = va_arg (args, char *);
- vfprintf (stderr, format, args);
- fprintf (stderr, "\n");
-@@ -194,14 +183,12 @@
- va_end (args);
- }
-
--itrace (va_alist)
-- va_dcl
-+itrace (char *format, ...)
- {
- va_list args;
-- char *format;
-
- fprintf(stderr, "TRACE: pid %d: ", getpid());
-- va_start (args);
-+ va_start (args, format);
- format = va_arg (args, char *);
- vfprintf (stderr, format, args);
- fprintf (stderr, "\n");
diff --git a/shells/bash1/files/patch-error.h b/shells/bash1/files/patch-error.h
deleted file mode 100644
index 67f0197faf2f..000000000000
--- a/shells/bash1/files/patch-error.h
+++ /dev/null
@@ -1,16 +0,0 @@
---- error.h.orig Fri Aug 29 12:24:24 2003
-+++ error.h Fri Aug 29 12:25:40 2003
-@@ -25,10 +25,10 @@
- extern void file_error ();
-
- /* Report a programmer's error, and abort. Pass REASON, and ARG1 ... ARG5. */
--extern void programming_error ();
-+extern void programming_error (char *, ...);
-
- /* General error reporting. Pass FORMAT and ARG1 ... ARG5. */
--extern void report_error ();
-+extern void report_error (char *, ...);
-
- /* Report an unrecoverable error and exit. Pass FORMAT and ARG1 ... ARG5. */
--extern void fatal_error ();
-+extern void fatal_error (char *, ...);
diff --git a/shells/bash1/files/patch-execute_cmd.c b/shells/bash1/files/patch-execute_cmd.c
deleted file mode 100644
index 47c4e4f88961..000000000000
--- a/shells/bash1/files/patch-execute_cmd.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- execute_cmd.c.orig Thu Jun 8 17:29:00 1995
-+++ execute_cmd.c Fri Nov 24 14:41:40 2000
-@@ -2718,6 +2718,7 @@
- char *redirectee_word;
- enum r_instruction ri = redirect->instruction;
- REDIRECT *new_redirect;
-+ mode_t um;
-
- if (ri == r_duplicating_input_word || ri == r_duplicating_output_word)
- {
-@@ -2938,11 +2939,15 @@
- pid_t pid = getpid ();
-
- /* Make the filename for the temp file. */
-- sprintf (filename, "/tmp/t%d-sh", pid);
-+ sprintf (filename, "/tmp/t-sh-XXXXXX", pid);
-
-- fd = open (filename, O_TRUNC | O_WRONLY | O_CREAT, 0666);
-+ /* O_TRUNC | O_WRONLY | O_CREAT */
-+ fd = mkstemp (filename);
- if (fd < 0)
- return (errno);
-+ um=umask(022);
-+ umask(um);
-+ fchmod(fd, 0666 & ~um);
-
- errno = 0; /* XXX */
- if (redirectee->word)
diff --git a/shells/bash1/files/patch-print_cmd.c b/shells/bash1/files/patch-print_cmd.c
deleted file mode 100644
index 403dc53cd884..000000000000
--- a/shells/bash1/files/patch-print_cmd.c
+++ /dev/null
@@ -1,41 +0,0 @@
---- print_cmd.c.orig Fri Aug 29 12:06:43 2003
-+++ print_cmd.c Fri Aug 29 12:07:51 2003
-@@ -20,7 +20,7 @@
- #include <stdio.h>
-
- #if defined (HAVE_VARARGS_H)
--# include <varargs.h>
-+# include <stdarg.h>
- #endif
-
- #if defined (HAVE_STRING_H)
-@@ -41,7 +41,8 @@
- static int indentation = 0;
- static int indentation_amount = 4;
-
--static void cprintf (), newline (), indent (), the_printed_command_resize ();
-+static void cprintf (char *, ...);
-+static void newline (), indent (), the_printed_command_resize ();
- static void semicolon ();
-
- static void make_command_string_internal ();
-@@ -730,16 +731,14 @@
-
- /* How to make the string. */
- static void
--cprintf (va_alist)
-- va_dcl
-+cprintf (char *control, ...)
- {
- register char *s;
-- char *control, char_arg[2], *argp;
-+ char char_arg[2], *argp;
- int digit_arg, arg_len, c;
- va_list args;
-
-- va_start (args);
-- control = va_arg (args, char *);
-+ va_start (args, control);
-
- arg_len = strlen (control);
- the_printed_command_resize (arg_len + 1);
diff --git a/shells/bash1/files/patch-readline-display.c b/shells/bash1/files/patch-readline-display.c
deleted file mode 100644
index 17f7216dfd86..000000000000
--- a/shells/bash1/files/patch-readline-display.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- lib/readline/display.c.orig Fri Aug 29 12:28:33 2003
-+++ lib/readline/display.c Fri Aug 29 12:29:29 2003
-@@ -1020,13 +1020,11 @@
- mini-modeline. */
-
- #if defined (HAVE_VARARGS_H)
--rl_message (va_alist)
-- va_dcl
-+rl_message (char *format, ...)
- {
-- char *format;
- va_list args;
-
-- va_start (args);
-+ va_start (args, format);
- format = va_arg (args, char *);
- vsprintf (msg_buf, format, args);
- va_end (args);
diff --git a/shells/bash1/files/patch-readline-readline.h b/shells/bash1/files/patch-readline-readline.h
deleted file mode 100644
index f0ca4a23ae56..000000000000
--- a/shells/bash1/files/patch-readline-readline.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- lib/readline/readline.h.orig Fri Aug 29 12:33:32 2003
-+++ lib/readline/readline.h Fri Aug 29 12:31:34 2003
-@@ -271,7 +271,8 @@
-
- /* Functions in display.c */
- extern void rl_redisplay ();
--extern int rl_message (), rl_clear_message ();
-+extern int rl_message (char *, ...);
-+extern int rl_clear_message ();
- extern int rl_reset_line_state ();
- extern int rl_character_len ();
- extern int rl_show_char ();
diff --git a/shells/bash1/files/patch-readline-rldefs.h b/shells/bash1/files/patch-readline-rldefs.h
deleted file mode 100644
index dd41ce51c848..000000000000
--- a/shells/bash1/files/patch-readline-rldefs.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/readline/rldefs.h.orig Fri Aug 29 12:30:13 2003
-+++ lib/readline/rldefs.h Fri Aug 29 12:30:32 2003
-@@ -150,7 +150,7 @@
- #endif /* !strchr && !__STDC__ */
-
- #if defined (HAVE_VARARGS_H)
--# include <varargs.h>
-+# include <stdarg.h>
- #endif /* HAVE_VARARGS_H */
-
- /* This is needed to include support for TIOCGWINSZ and window resizing. */
diff --git a/shells/bash1/files/patch-shell.c b/shells/bash1/files/patch-shell.c
deleted file mode 100644
index 10114e527055..000000000000
--- a/shells/bash1/files/patch-shell.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- shell.c.orig Sun Sep 28 01:24:33 2003
-+++ shell.c Sun Sep 28 01:25:16 2003
-@@ -43,7 +43,7 @@
- #include "bashansi.h"
-
- #if defined (HAVE_VARARGS_H)
--#include <varargs.h>
-+#include <stdarg.h>
- #endif
-
- #include "shell.h"
diff --git a/shells/bash1/files/patch-support-mksysdefs b/shells/bash1/files/patch-support-mksysdefs
deleted file mode 100644
index d13401281170..000000000000
--- a/shells/bash1/files/patch-support-mksysdefs
+++ /dev/null
@@ -1,14 +0,0 @@
---- support/mksysdefs.orig Fri Aug 29 11:26:47 2003
-+++ support/mksysdefs Fri Aug 29 11:27:59 2003
-@@ -415,7 +415,10 @@
- echo "#endif /* HAVE_STRING_H */" >>$sysdefs
- fi
-
--file=varargs.h
-+# varargs.h and it's var args support is deprecated in GCC 3.3,
-+# and has been obsolete for a while. Assume VARARGS means
-+# STDARG elsewhere in the code.
-+file=stdarg.h
- eval $findf
- if [ -n "$found" ]; then
- echo "" >>$sysdefs
diff --git a/shells/bash1/files/patch-test.c b/shells/bash1/files/patch-test.c
deleted file mode 100644
index 66a14d3e62a5..000000000000
--- a/shells/bash1/files/patch-test.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- test.c.orig Fri Dec 23 06:45:12 1994
-+++ test.c Sat May 4 21:08:08 2002
-@@ -194,6 +194,7 @@
- return (stat (path, finfo));
- }
-
-+#if defined(__FreeBSD__) && __FreeBSD_version < 500023 /* use native FreeBSD libc version */
- /* Do the same thing access(2) does, but use the effective uid and gid,
- and don't make the mistake of telling root that any file is
- executable. */
-@@ -237,6 +238,7 @@
-
- return (-1);
- }
-+#endif
-
- #if defined (HAVE_GETGROUPS)
- /* The number of groups that this user is a member of. */
diff --git a/shells/bash1/pkg-descr b/shells/bash1/pkg-descr
deleted file mode 100644
index b3a252cb863f..000000000000
--- a/shells/bash1/pkg-descr
+++ /dev/null
@@ -1,10 +0,0 @@
-Bash is the GNU Project's Bourne
-Again SHell, an interactive shell with Bourne shell syntax (/bin/sh);
-but also with interactive command line editing, job control on
-architectures that support it, Csh-like history features and brace
-expansion, and a slew of other stuff. For more information on the
-features of Bash that are new to this type of shell, see the file
-`documentation/features.texi'. There is also a processed DVI file
-there, as well as a large man page.
-
-WWW: http://www.gnu.org/software/bash/
diff --git a/shells/bash1/pkg-plist b/shells/bash1/pkg-plist
deleted file mode 100644
index 8d96355917be..000000000000
--- a/shells/bash1/pkg-plist
+++ /dev/null
@@ -1,5 +0,0 @@
-@comment $FreeBSD$
-bin/bash
-@exec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak; echo %D/%F) >/etc/shells
-@unexec echo "updating /etc/shells"; cp /etc/shells /etc/shells.bak; (grep -v %D/%F /etc/shells.bak) >/etc/shells
-bin/bashbug