aboutsummaryrefslogtreecommitdiff
path: root/shells/fd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'shells/fd/Makefile')
-rw-r--r--shells/fd/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/shells/fd/Makefile b/shells/fd/Makefile
index c93d10c07610..9e369fb6b930 100644
--- a/shells/fd/Makefile
+++ b/shells/fd/Makefile
@@ -38,10 +38,10 @@ post-patch:
post-install:
@${ECHO} "Updating /etc/shells"
- @${CP} /etc/shells /etc/shells.bak
- @(${GREP} -v ${PREFIX}/bin/fdsh /etc/shells.bak; \
- ${ECHO_CMD} ${PREFIX}/bin/fdsh) > /etc/shells
- @${RM} /etc/shells.bak
+ @-${CP} /etc/shells /etc/shells.bak; \
+ (${GREP} -v ${PREFIX}/bin/fdsh /etc/shells.bak; \
+ ${ECHO_CMD} ${PREFIX}/bin/fdsh) > /etc/shells; \
+ ${RM} -f /etc/shells.bak
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
@${MKDIR} ${PREFIX}/share/doc/ja/${PORTNAME}