aboutsummaryrefslogtreecommitdiff
path: root/shells/fish/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'shells/fish/Makefile')
-rw-r--r--shells/fish/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/shells/fish/Makefile b/shells/fish/Makefile
index 086c0a288836..62affd5452be 100644
--- a/shells/fish/Makefile
+++ b/shells/fish/Makefile
@@ -9,6 +9,8 @@ MASTER_SITES= http://fishshell.com/files/${PORTVERSION}/
MAINTAINER= nemysis@FreeBSD.org
COMMENT= User friendly command line shell
+LICENSE= GPLv2
+
USES= gmake iconv
USE_AUTOTOOLS= autoconf
@@ -24,6 +26,8 @@ NLS_USES= gettext
NLS_CONFIGURE_ENV= ac_cv_func_gettext=yes
NLS_CONFIGURE_OFF= --without-gettext
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e \
'/^all:/s|user_doc|| ; \
@@ -37,6 +41,10 @@ post-patch:
s|ncurses curses|curses| ; \
s|ncurses.h||' ${WRKSRC}/configure.ac
+.if ! ${PORT_OPTIONS:MDOCS}
+EXTRA_PATCHES+=${FILESDIR}/extra-patch-Makefile.in
+.endif
+
post-install:
.for i in fish fish_indent fish_pager fishd mimedb
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${i}