aboutsummaryrefslogtreecommitdiff
path: root/shells/viewglob/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'shells/viewglob/Makefile')
-rw-r--r--shells/viewglob/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/shells/viewglob/Makefile b/shells/viewglob/Makefile
new file mode 100644
index 000000000000..958799183017
--- /dev/null
+++ b/shells/viewglob/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: viewglob
+# Date created: 06 Oct 2004
+# Whom: Jean-Yves Lefort <jylefort@brutele.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= viewglob
+PORTVERSION= 1.0
+CATEGORIES= shells
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= jylefort@brutele.be
+COMMENT= A GTK+ add-on to bash and zsh
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+USE_X_PREFIX= yes
+USE_GNOME= gtk20
+GNU_CONFIGURE= yes
+
+MAN1= gviewglob.1 viewglob.1
+
+post-extract:
+ @${CP} ${WRKSRC}/src/tc_setraw.h ${WRKSRC}/src/tc_setraw.viewglob.h
+ @${CP} ${WRKSRC}/src/ptutil.h ${WRKSRC}/src/ptutil.viewglob.h
+
+.include <bsd.port.mk>