aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
Diffstat (limited to 'shells')
-rw-r--r--shells/Makefile1
-rw-r--r--shells/viewglob/Makefile30
-rw-r--r--shells/viewglob/distinfo2
-rw-r--r--shells/viewglob/files/patch-src::Makefile.in32
-rw-r--r--shells/viewglob/files/patch-src::ptutil.viewglob.c27
-rw-r--r--shells/viewglob/pkg-descr20
-rw-r--r--shells/viewglob/pkg-plist9
7 files changed, 121 insertions, 0 deletions
diff --git a/shells/Makefile b/shells/Makefile
index 6ea7c5ba7ec8..b2a6a7a8aa3b 100644
--- a/shells/Makefile
+++ b/shells/Makefile
@@ -26,6 +26,7 @@
SUBDIR += scponly
SUBDIR += tcshrc
SUBDIR += v7sh
+ SUBDIR += viewglob
SUBDIR += vshnu
SUBDIR += wapsh
SUBDIR += zoidberg
diff --git a/shells/viewglob/Makefile b/shells/viewglob/Makefile
new file mode 100644
index 000000000000..958799183017
--- /dev/null
+++ b/shells/viewglob/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: viewglob
+# Date created: 06 Oct 2004
+# Whom: Jean-Yves Lefort <jylefort@brutele.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= viewglob
+PORTVERSION= 1.0
+CATEGORIES= shells
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= jylefort@brutele.be
+COMMENT= A GTK+ add-on to bash and zsh
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+USE_X_PREFIX= yes
+USE_GNOME= gtk20
+GNU_CONFIGURE= yes
+
+MAN1= gviewglob.1 viewglob.1
+
+post-extract:
+ @${CP} ${WRKSRC}/src/tc_setraw.h ${WRKSRC}/src/tc_setraw.viewglob.h
+ @${CP} ${WRKSRC}/src/ptutil.h ${WRKSRC}/src/ptutil.viewglob.h
+
+.include <bsd.port.mk>
diff --git a/shells/viewglob/distinfo b/shells/viewglob/distinfo
new file mode 100644
index 000000000000..b85dcf93302c
--- /dev/null
+++ b/shells/viewglob/distinfo
@@ -0,0 +1,2 @@
+MD5 (viewglob-1.0.tar.gz) = 99910845070a03f5d9e925564141fa7c
+SIZE (viewglob-1.0.tar.gz) = 197543
diff --git a/shells/viewglob/files/patch-src::Makefile.in b/shells/viewglob/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..ebae1b814084
--- /dev/null
+++ b/shells/viewglob/files/patch-src::Makefile.in
@@ -0,0 +1,32 @@
+--- src/Makefile.in.orig Wed Oct 6 03:23:40 2004
++++ src/Makefile.in Wed Oct 6 03:29:02 2004
+@@ -91,8 +91,6 @@
+ # Very slight modifications to these files from Marc J. Rochkind's
+ # book Advanced Unix Programming 2nd ed. You can get them on the
+ # web at: http://www.basepath.com/aup/
+-BUILT_SOURCES = ptutil.viewglob.c ptutil.viewglob.h \
+- tc_setraw.viewglob.c tc_setraw.viewglob.h
+
+
+ CLEANFILES = viewglob .zshrc getopt.sh ptutil.viewglob.c \
+@@ -484,16 +482,16 @@
+
+ .zshrc: Makefile
+ cp -f init-viewglob.zshrc .zshrc
+-ptutil.viewglob.c: Makefile
++ptutil.viewglob.c:
+ rm -f ptutil.viewglob.c
+ patch -i ptutil.c.diff -o ptutil.viewglob.c ptutil.c
+-ptutil.viewglob.h: Makefile
++ptutil.viewglob.h:
+ rm -f ptutil.viewglob.h
+ patch -i ptutil.h.diff -o ptutil.viewglob.h ptutil.h
+-tc_setraw.viewglob.c: Makefile
++tc_setraw.viewglob.c:
+ rm -f tc_setraw.viewglob.c
+ patch -i tc_setraw.c.diff -o tc_setraw.viewglob.c tc_setraw.c
+-tc_setraw.viewglob.h: Makefile
++tc_setraw.viewglob.h:
+ rm -f tc_setraw.viewglob.h
+ patch -i tc_setraw.h.diff -o tc_setraw.viewglob.h tc_setraw.h
+
diff --git a/shells/viewglob/files/patch-src::ptutil.viewglob.c b/shells/viewglob/files/patch-src::ptutil.viewglob.c
new file mode 100644
index 000000000000..e770591d03bc
--- /dev/null
+++ b/shells/viewglob/files/patch-src::ptutil.viewglob.c
@@ -0,0 +1,27 @@
+--- src/ptutil.viewglob.c.orig Wed Oct 6 03:34:54 2004
++++ src/ptutil.viewglob.c Wed Oct 6 03:47:51 2004
+@@ -45,7 +45,6 @@
+ #endif
+ /*[incl]*/
+ #ifdef _XOPEN_UNIX
+-#include <stropts.h> /* for STREAMS */
+ #endif
+ #ifdef NEED_TIOCSCTTY
+ #include <sys/ttycom.h> /* for TIOCSCTTY */
+@@ -73,14 +72,9 @@
+ static bool find_and_open_master(PTINFO *p)
+ {
+ #if defined(_XOPEN_UNIX)
+-#if _XOPEN_VERSION >= 600
+ p->pt_name_m[0] = '\0'; /* don't know or need name */
+- ec_neg1( p->pt_fd_m = posix_openpt(O_RDWR | O_NOCTTY) )
+-#else
+- strcpy(p->pt_name_m, "/dev/ptmx"); /* clone device */
+- if ( (p->pt_fd_m = open(p->pt_name_m, O_RDWR)) == -1)
+- goto failure;
+-#endif
++ if ((p->pt_fd_m = posix_openpt(O_RDWR | O_NOCTTY)) == -1)
++ return false;
+ #elif defined(MASTER_NAME_SEARCH)
+ int i, j;
+ char proto[] = PTY_PROTO;
diff --git a/shells/viewglob/pkg-descr b/shells/viewglob/pkg-descr
new file mode 100644
index 000000000000..64dcd876f674
--- /dev/null
+++ b/shells/viewglob/pkg-descr
@@ -0,0 +1,20 @@
+viewglob is an utility designed to complement the Unix shell in
+graphical environments. It has two parts:
+
+ 1. A tool that sits as a layer between the shell and X terminal,
+ keeping track of the user's current directory and command line.
+ 2. A graphical display which shows the layouts of directories
+ referenced on the command line (including pwd).
+
+The display reveals the results of file globs and expansions as they
+are typed (hence the name), highlighting selected files and potential
+name completions.
+
+It can also be used as a surrogate terminal, where keystrokes typed in
+the display are passed to the shell. Files and directories can be
+double-clicked to insert their names and/or paths into the terminal.
+
+WWW: http://viewglob.sourceforge.net/
+
+- Jean-Yves Lefort
+jylefort@brutele.be
diff --git a/shells/viewglob/pkg-plist b/shells/viewglob/pkg-plist
new file mode 100644
index 000000000000..f7ecde22a459
--- /dev/null
+++ b/shells/viewglob/pkg-plist
@@ -0,0 +1,9 @@
+bin/gviewglob
+bin/viewglob
+lib/viewglob/.zshrc
+lib/viewglob/getopt.sh
+lib/viewglob/glob-expand
+lib/viewglob/gviewglob
+lib/viewglob/init-viewglob.bashrc
+lib/viewglob/seer
+@dirrm lib/viewglob