aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gsmartcontrol/files
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/gsmartcontrol/files')
-rw-r--r--sysutils/gsmartcontrol/files/extra-Makefile.in33
-rw-r--r--sysutils/gsmartcontrol/files/patch-data_Makefile.in11
-rw-r--r--sysutils/gsmartcontrol/files/patch-data_gsmartcontrol-root.in8
3 files changed, 52 insertions, 0 deletions
diff --git a/sysutils/gsmartcontrol/files/extra-Makefile.in b/sysutils/gsmartcontrol/files/extra-Makefile.in
new file mode 100644
index 000000000000..57b6a55ebb42
--- /dev/null
+++ b/sysutils/gsmartcontrol/files/extra-Makefile.in
@@ -0,0 +1,33 @@
+--- ./Makefile.in.orig 2009-03-23 18:59:37.000000000 +0100
++++ Makefile.in 2009-03-26 17:34:55.000000000 +0100
+@@ -328,14 +328,6 @@
+ compilation_flags: $(top_builddir)/config.status $(srcdir)/compilation_flags.in
+ cd $(top_builddir) && $(SHELL) ./config.status $@
+ install-dist_docDATA: $(dist_doc_DATA)
+- @$(NORMAL_INSTALL)
+- test -z "$(docdir)" || $(MKDIR_P) "$(DESTDIR)$(docdir)"
+- @list='$(dist_doc_DATA)'; for p in $$list; do \
+- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+- f=$(am__strip_dir) \
+- echo " $(dist_docDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(docdir)/$$f'"; \
+- $(dist_docDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(docdir)/$$f"; \
+- done
+
+ uninstall-dist_docDATA:
+ @$(NORMAL_UNINSTALL)
+@@ -345,15 +337,6 @@
+ rm -f "$(DESTDIR)$(docdir)/$$f"; \
+ done
+ install-nobase_dist_docDATA: $(nobase_dist_doc_DATA)
+- @$(NORMAL_INSTALL)
+- test -z "$(docdir)" || $(MKDIR_P) "$(DESTDIR)$(docdir)"
+- @$(am__vpath_adj_setup) \
+- list='$(nobase_dist_doc_DATA)'; for p in $$list; do \
+- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+- $(am__vpath_adj) \
+- echo " $(nobase_dist_docDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(docdir)/$$f'"; \
+- $(nobase_dist_docDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(docdir)/$$f"; \
+- done
+
+ uninstall-nobase_dist_docDATA:
+ @$(NORMAL_UNINSTALL)
diff --git a/sysutils/gsmartcontrol/files/patch-data_Makefile.in b/sysutils/gsmartcontrol/files/patch-data_Makefile.in
new file mode 100644
index 000000000000..a4e3ffa4b66b
--- /dev/null
+++ b/sysutils/gsmartcontrol/files/patch-data_Makefile.in
@@ -0,0 +1,11 @@
+--- ./data/Makefile.in.orig 2009-03-26 11:27:18.000000000 +0100
++++ data/Makefile.in 2009-03-26 11:27:35.000000000 +0100
+@@ -686,7 +686,7 @@
+ uninstall-extra-mans:
+ cd $(DESTDIR)$(mandir)/man1 && rm -f gsmartcontrol-root.1
+
+-install-data-hook: install-extra-mans update-icon-cache
++install-data-hook: update-icon-cache
+ uninstall-hook: uninstall-extra-mans update-icon-cache
+
+ update-icon-cache:
diff --git a/sysutils/gsmartcontrol/files/patch-data_gsmartcontrol-root.in b/sysutils/gsmartcontrol/files/patch-data_gsmartcontrol-root.in
new file mode 100644
index 000000000000..dc30ce42614a
--- /dev/null
+++ b/sysutils/gsmartcontrol/files/patch-data_gsmartcontrol-root.in
@@ -0,0 +1,8 @@
+--- ./data/gsmartcontrol-root.in.orig 2009-03-26 18:58:31.000000000 +0100
++++ data/gsmartcontrol-root.in 2009-03-26 18:58:44.000000000 +0100
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+ ############################################################################
+ # Copyright:
+ # (C) 2008 Alexander Shaduri <ashaduri 'at' gmail.com>