aboutsummaryrefslogtreecommitdiff
path: root/sysutils/jvmtop/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/jvmtop/Makefile')
-rw-r--r--sysutils/jvmtop/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/sysutils/jvmtop/Makefile b/sysutils/jvmtop/Makefile
index 4500568c3676..141b1e127a3f 100644
--- a/sysutils/jvmtop/Makefile
+++ b/sysutils/jvmtop/Makefile
@@ -3,26 +3,30 @@
PORTNAME= jvmtop
PORTVERSION= 0.8.0
+PORTREVISION= 1
CATEGORIES= sysutils java
-MASTER_SITES= GOOGLE_CODE
MAINTAINER= jgh@FreeBSD.org
COMMENT= Lightweight console application to monitor running jvms
-LICENSE= GPLv3
+LICENSE= GPLv2
USE_JAVA= yes
JAVA_VERSION= 1.6+
+USE_ANT= yes
PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar \
bin/${PORTNAME}
SUB_LIST= JAVA_HOME=${JAVA_HOME}
SUB_FILES= ${PORTNAME}.sh
-NO_BUILD= yes
+
+GH_ACCOUNT= patric-r
+GH_TAG= 3d6978c
+USE_GITHUB= YES
do-install:
@${MKDIR} ${STAGEDIR}${JAVAJARDIR}
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.jar ${STAGEDIR}${JAVAJARDIR}
+ ${INSTALL_DATA} ${WRKSRC}/dist/${PORTNAME}.jar ${STAGEDIR}${JAVAJARDIR}
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>