aboutsummaryrefslogtreecommitdiff
path: root/sysutils/osquery/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/osquery/Makefile')
-rw-r--r--sysutils/osquery/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/sysutils/osquery/Makefile b/sysutils/osquery/Makefile
index 1cc1b8a72c6a..a8b9dfc4ff07 100644
--- a/sysutils/osquery/Makefile
+++ b/sysutils/osquery/Makefile
@@ -10,6 +10,7 @@ MAINTAINER= zi@FreeBSD.org
COMMENT= SQL powered OS instrumentation, monitoring, and analytics
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= snappy>0:archivers/snappy \
rocksdb>0:databases/rocksdb \
@@ -28,6 +29,8 @@ LIB_DEPENDS= libboost_regex.so:devel/boost-libs \
libgflags.so:devel/gflags \
libicuuc.so:devel/icu
+BROKEN= does not build (error: no matching constructor for initialization of 'gflags::FlagRegisterer')
+
USES= cmake:outsource gmake libtool python:build compiler:c++11-lib
CONFIGURE_ENV+= OSQUERY_BUILD_VERSION="${PORTVERSION}" HOME="${WRKDIR}" \
SKIP_TESTS="yes" CC="${CC}" CXX="${CXX}"