aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/atop/Makefile2
-rw-r--r--sysutils/cdls/Makefile14
-rw-r--r--sysutils/htop/Makefile2
-rw-r--r--sysutils/libcdio/Makefile8
-rw-r--r--sysutils/logmon/Makefile2
5 files changed, 11 insertions, 17 deletions
diff --git a/sysutils/atop/Makefile b/sysutils/atop/Makefile
index 6640fe40318b..d0c4d380f1eb 100644
--- a/sysutils/atop/Makefile
+++ b/sysutils/atop/Makefile
@@ -16,7 +16,7 @@ GH_PROJECT= atop-freebsd
GH_TAGNAME= ${PORTNAME}-${PORTVERSION:C|b|fbsd.beta|}
GH_COMMIT= f9357ca
-USE_NCURSES= yes
+USES= ncurses
MAKEFILE= BSDmakefile
MAN1= atop.1 atopsar.1
MAN5= atoprc.5
diff --git a/sysutils/cdls/Makefile b/sysutils/cdls/Makefile
index fc7f25030a1f..8941fd96e829 100644
--- a/sysutils/cdls/Makefile
+++ b/sysutils/cdls/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cdls
-# Date created: 13 april 2012
-# Whom: Hans de Hartog <hans@dehartog.nl>
-#
+# Created by: Hans de Hartog <hans@dehartog.nl>
# $FreeBSD$
-#
PORTNAME= cdls
PORTVERSION= 4.2
@@ -15,9 +11,11 @@ COMMENT= A curses based file manager for system managers
PLIST_FILES= bin/cdls
-USE_NCURSES= yes
+USES= ncurses
-.if defined(WITH_NCURSES_BASE)
+.include <bsd.port.pre.mk>
+
+.if ${NCURSESBASE} == /usr
# no need to use ncurses-config if we use ncurses from the base system
CONFIGURE_ARGS+= NCURSES_CONFIG=/usr/bin/true
.endif
@@ -25,4 +23,4 @@ CONFIGURE_ARGS+= NCURSES_CONFIG=/usr/bin/true
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/htop/Makefile b/sysutils/htop/Makefile
index a6def425cd84..7be57bac99d7 100644
--- a/sysutils/htop/Makefile
+++ b/sysutils/htop/Makefile
@@ -23,8 +23,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= LIBS="-lexecinfo"
CONFIGURE_ARGS= --with-proc=/compat/linux/proc --enable-unicode
+USES= ncurses
USE_AUTOTOOLS= autoconf aclocal automake libtool
-USE_NCURSES= yes
ACLOCAL_ARGS= -I ${ACLOCAL_DIR}
USE_PYTHON_BUILD= yes
diff --git a/sysutils/libcdio/Makefile b/sysutils/libcdio/Makefile
index 0528ee5047d1..ccff32c1ac3a 100644
--- a/sysutils/libcdio/Makefile
+++ b/sysutils/libcdio/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: libcdio
-# Date created: 2004-04-04
-# Whom: arved
-#
+# Created by: arved
# $FreeBSD$
PORTNAME= libcdio
@@ -22,10 +19,9 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
-USES= pathfix pkgconfig iconv
+USES= pathfix pkgconfig iconv ncurses
USE_GMAKE= yes
USE_LDCONFIG= yes
-USE_NCURSES= yes
CONFIGURE_ARGS+= --with-libpopt-prefix=${LOCALBASE} \
--with-libiconv-prefix=${LOCALBASE} \
USE_PERL5_BUILD=yes
diff --git a/sysutils/logmon/Makefile b/sysutils/logmon/Makefile
index a4e659966a2d..9c82571ca401 100644
--- a/sysutils/logmon/Makefile
+++ b/sysutils/logmon/Makefile
@@ -12,8 +12,8 @@ COMMENT= Ncurses-based split window log monitoring program
LICENSE= ART10
+USES= ncurses
USE_BZIP2= yes
-USE_NCURSES= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes