aboutsummaryrefslogtreecommitdiff
path: root/textproc/asm-xml/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/asm-xml/Makefile')
-rw-r--r--textproc/asm-xml/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/textproc/asm-xml/Makefile b/textproc/asm-xml/Makefile
new file mode 100644
index 000000000000..aa08189a0987
--- /dev/null
+++ b/textproc/asm-xml/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: asm-xml
+# Date created: 22 February 2007
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= asm-xml
+PORTVERSION= 0.2
+CATEGORIES= textproc
+MASTER_SITES= SF
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Very fast XML parser and decoder written in pure assembler
+
+BUILD_DEPENDS= fasm:${PORTSDIR}/lang/fasm
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_DOS2UNIX= YES
+
+PLIST_FILES= include/asm-xml.h lib/libasm-xml.a
+
+post-extract:
+ ${RM} -rf ${WRKSRC}/obj
+
+post-patch:
+ @${CP} ${FILESDIR}/Makefile ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>