aboutsummaryrefslogtreecommitdiff
path: root/textproc/gnomespell/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/gnomespell/Makefile')
-rw-r--r--textproc/gnomespell/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/textproc/gnomespell/Makefile b/textproc/gnomespell/Makefile
index 1b06467397a7..9d3bb125ae8f 100644
--- a/textproc/gnomespell/Makefile
+++ b/textproc/gnomespell/Makefile
@@ -20,17 +20,15 @@ LIB_DEPENDS= aspell.11:${PORTSDIR}/textproc/aspell
USE_X_PREFIX= yes
USE_PERL5= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack libglade gal
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>