aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-citeproc-hs
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/hs-citeproc-hs')
-rw-r--r--textproc/hs-citeproc-hs/Makefile18
-rw-r--r--textproc/hs-citeproc-hs/distinfo5
-rw-r--r--textproc/hs-citeproc-hs/pkg-plist30
3 files changed, 16 insertions, 37 deletions
diff --git a/textproc/hs-citeproc-hs/Makefile b/textproc/hs-citeproc-hs/Makefile
index e2e991bf7606..5f7cd4cf79c6 100644
--- a/textproc/hs-citeproc-hs/Makefile
+++ b/textproc/hs-citeproc-hs/Makefile
@@ -6,27 +6,37 @@
#
PORTNAME= citeproc-hs
-PORTVERSION= 0.2
+PORTVERSION= 0.3.2
CATEGORIES= textproc haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= A Citation Style Language implementation in Haskell
-USE_HACKAGE= hxt>=8.1
+LICENSE= BSD
+
+USE_CABAL= json mtl pandoc-types>=1.8 utf8-string xml
PORTDATA= *
-OPTIONS= BIBUTILS "Use Chris Putnam's Bibutils" off
+OPTIONS= BIBUTILS "Use Chris Putnam's Bibutils" on \
+ NETWORK "Use network and HTTP to retrieve CSL file" on
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
.include <bsd.port.options.mk>
.if defined(WITH_BIBUTILS)
CONFIGURE_ARGS+= --flags="bibutils"
-USE_HACKAGE+= hs-bibutils
+USE_CABAL+= hs-bibutils>=0.3
.else
CONFIGURE_ARGS+= --flags="-bibutils"
.endif
+.if defined(WITH_NETWORK)
+CONFIGURE_ARGS+= --flags="network"
+USE_CABAL+= HTTP>=4000.0.9 network>=2
+.else
+CONFIGURE_ARGS+= --flags="-network"
+.endif
+
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/textproc/hs-citeproc-hs/distinfo b/textproc/hs-citeproc-hs/distinfo
index 444325e49387..a96f3aa9b524 100644
--- a/textproc/hs-citeproc-hs/distinfo
+++ b/textproc/hs-citeproc-hs/distinfo
@@ -1,3 +1,2 @@
-MD5 (cabal/citeproc-hs-0.2.tar.gz) = d9fd2f297917861ee4131f144d44042b
-SHA256 (cabal/citeproc-hs-0.2.tar.gz) = d7cf725e6bab06cde4bbc51d8e3b816ecf16f7b1a1e4face326692965c65302c
-SIZE (cabal/citeproc-hs-0.2.tar.gz) = 64300
+SHA256 (cabal/citeproc-hs-0.3.2.tar.gz) = eedd04b29521c38394d090e37d36edc7b8a46220fce2a85324562be903079812
+SIZE (cabal/citeproc-hs-0.3.2.tar.gz) = 90757
diff --git a/textproc/hs-citeproc-hs/pkg-plist b/textproc/hs-citeproc-hs/pkg-plist
deleted file mode 100644
index 068c76915c7e..000000000000
--- a/textproc/hs-citeproc-hs/pkg-plist
+++ /dev/null
@@ -1,30 +0,0 @@
-@comment $FreeBSD$
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Paths_citeproc_hs.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/CSL.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/CSL/Eval.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/CSL/Input/Bibutils.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/CSL/Input/MODS.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/CSL/Output/Pandoc.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/CSL/Output/Plain.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/CSL/Parser.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/CSL/Proc.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/CSL/Proc/Collapse.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/CSL/Proc/Disamb.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/CSL/Reference.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/CSL/Style.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
-%%LIBDIR_REL%%/register.sh
-%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
-%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
-@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/CSL/Proc
-@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/CSL/Output
-@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/CSL/Input
-@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/CSL
-@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text
-@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%
-@dirrm %%LIBDIR_REL%%
-@exec /bin/sh %D/%%LIBDIR_REL%%/register.sh
-@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
-@unexec %D/bin/ghc-pkg unregister %%PORTNAME%%-%%PORTVERSION%%
-@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old