aboutsummaryrefslogtreecommitdiff
path: root/textproc/liblrdf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/liblrdf/Makefile')
-rw-r--r--textproc/liblrdf/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/textproc/liblrdf/Makefile b/textproc/liblrdf/Makefile
new file mode 100644
index 000000000000..19f2e23731c0
--- /dev/null
+++ b/textproc/liblrdf/Makefile
@@ -0,0 +1,30 @@
+# New ports collection Makefile for: liblrdf
+# Date created: 26 April 2003
+# Whom: Tilman Linneweh <arved@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= liblrdf
+PORTVERSION= 0.3.0
+CATEGORIES= textproc
+MASTER_SITES= http://plugin.org.uk/releases/lrdf/
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= Library for manipulating RDF files describing LADSPA plugins
+
+LIB_DEPENDS= raptor.0:${PORTSDIR}/textproc/raptor
+
+GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+USE_REINPLACE= yes
+USE_GNOME= gnomehack
+INSTALLS_SHLIB= yes
+CONFIGURE_TARGET=
+CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,1:2:2,1:2:1,' ${WRKSRC}/configure
+
+.include <bsd.port.mk>