aboutsummaryrefslogtreecommitdiff
path: root/textproc/libtre/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/libtre/Makefile')
-rw-r--r--textproc/libtre/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/textproc/libtre/Makefile b/textproc/libtre/Makefile
index 452a3a0e5d26..d56b9231c242 100644
--- a/textproc/libtre/Makefile
+++ b/textproc/libtre/Makefile
@@ -29,17 +29,18 @@ PGO_DESC= Enable Profile-Guided Optimization
MAN1= tre_agrep.1
-.include <bsd.port.pre.mk>
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+.include <bsd.port.pre.mk>
+
.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
CFLAGS+= -Wuninitialized -ffast-math -finline-functions \
-fomit-frame-pointer -fexpensive-optimizations \