aboutsummaryrefslogtreecommitdiff
path: root/textproc/msort/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/msort/Makefile')
-rw-r--r--textproc/msort/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/textproc/msort/Makefile b/textproc/msort/Makefile
new file mode 100644
index 000000000000..ee489d1ebb57
--- /dev/null
+++ b/textproc/msort/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: msort
+# Date created: 2006-08-11
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= msort
+PORTVERSION= 8.27
+CATEGORIES= textproc
+MASTER_SITES= http://billposer.org/Software/Downloads/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Sorting files in sophisticated ways
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+LIB_DEPENDS= tre:${PORTSDIR}/textproc/libtre
+RUN_DEPENDS= iwidgets>=0:${PORTSDIR}/x11-toolkits/iwidgets
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+GNU_CONFIGURE= yes
+USE_TK= yes
+
+PLIST_FILES= bin/msg bin/msort
+
+MAN1= msort.1
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,^#include <alloca.h>,,g' ${WRKSRC}/msort.c
+
+.include <bsd.port.mk>