aboutsummaryrefslogtreecommitdiff
path: root/textproc/openfts/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/openfts/Makefile')
-rw-r--r--textproc/openfts/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/textproc/openfts/Makefile b/textproc/openfts/Makefile
index 313e6655442c..82220a84d0f2 100644
--- a/textproc/openfts/Makefile
+++ b/textproc/openfts/Makefile
@@ -17,23 +17,19 @@ USE_PGSQL= yes
USES= perl5
USE_PERL5= configure
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= DOCS EXAMPLES
PORTDOCS= Changes INSTALL README primer.html
post-install:
-.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
@${CP} -R ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
@${ECHO_MSG} "===> Examples installed in ${STAGEDIR}${EXAMPLESDIR}."
-.endif
-.if !defined(NOPORTDOCS)
@${CP} -p ${WRKSRC}/doc/primer.html ${WRKSRC}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${STAGEDIR}${DOCSDIR}."
-.endif
# Sample DB initialization.
DBNAME?= openfts
@@ -43,4 +39,4 @@ create-database:
psql ${DBNAME} < tsearch2.sql && \
psql ${DBNAME} < openfts.sql
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>