aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Apache-XBEL/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-Apache-XBEL/Makefile')
-rw-r--r--textproc/p5-Apache-XBEL/Makefile44
1 files changed, 0 insertions, 44 deletions
diff --git a/textproc/p5-Apache-XBEL/Makefile b/textproc/p5-Apache-XBEL/Makefile
deleted file mode 100644
index a630fe8675be..000000000000
--- a/textproc/p5-Apache-XBEL/Makefile
+++ /dev/null
@@ -1,44 +0,0 @@
-# New ports collection makefile for: p5-Apache-XBEL
-# Date created: August 03 2004
-# Whom: Aaron Straup Cope <ascope@cpan.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= Apache-XBEL
-PORTVERSION= 13
-PORTREVISION= 2
-CATEGORIES= textproc perl5
-MASTER_SITES= CPAN
-PKGNAMEPREFIX= p5-
-DISTNAME= ${PORTNAME}-${DISTVERSIONPREFIX}1.3${DISTVERSIONSUFFIX}
-
-MAINTAINER= perl@FreeBSD.org
-COMMENT= Apache mod_perl handler to render an XBEL file as an HTML tree
-
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache.pm:${PORTSDIR}/www/mod_perl \
- ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
- ${SITE_PERL}/${PERL_ARCH}/XML/LibXSLT.pm:${PORTSDIR}/textproc/p5-XML-LibXSLT \
- ${SITE_PERL}/Memoize.pm:${PORTSDIR}/devel/p5-Memoize
-RUN_DEPENDS:= ${BUILD_DEPENDS}
-
-DEPRECATED= apache13 is deprecated, migrate to 2.2.x+ now
-EXPIRATION_DATE= 2012-01-01
-
-MAKE_JOBS_SAFE= yes
-
-PERL_CONFIGURE= yes
-
-MAN3= Apache::XBEL.3
-
-.if defined(NOXSL)
-PLIST_SUB+= XSL="@Comment "
-.else
-PLIST_SUB+= XSL=""
-post-install:
- @${ECHO} "Installing ${DATADIR}/apache-xbel.xsl"
- @${MKDIR} ${DATADIR}
- @${INSTALL_DATA} ${WRKSRC}/xsl/apache-xbel.xsl ${DATADIR}
-.endif
-
-.include <bsd.port.mk>