aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Parse-Flex/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-Parse-Flex/Makefile')
-rw-r--r--textproc/p5-Parse-Flex/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/textproc/p5-Parse-Flex/Makefile b/textproc/p5-Parse-Flex/Makefile
new file mode 100644
index 000000000000..5a3f99973673
--- /dev/null
+++ b/textproc/p5-Parse-Flex/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Parse-Flex
+# Date created: 30 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Parse-Flex
+PORTVERSION= 0.11
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Parse
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= The Fastest Lexer in the West
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ ${SITE_PERL}/XSLoader.pm:${PORTSDIR}/devel/p5-XSLoader
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Parse::Flex.3 Parse::Flex::Generate.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>