aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-RDFStore
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-RDFStore')
-rw-r--r--textproc/p5-RDFStore/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/textproc/p5-RDFStore/Makefile b/textproc/p5-RDFStore/Makefile
index 2b91199473cf..b349377d1720 100644
--- a/textproc/p5-RDFStore/Makefile
+++ b/textproc/p5-RDFStore/Makefile
@@ -18,7 +18,8 @@ COMMENT= Perl API for RDF Storage
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
${SITE_PERL}/Digest.pm:${PORTSDIR}/security/p5-Digest \
${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+ ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_BDB= yes
@@ -51,10 +52,4 @@ pre-configure:
BROKEN= does not compile on ${ARCH}
.endif
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI-137
-.else
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
-.endif
-
.include <bsd.port.post.mk>