aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-python-docx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/py-python-docx/Makefile')
-rw-r--r--textproc/py-python-docx/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/textproc/py-python-docx/Makefile b/textproc/py-python-docx/Makefile
index 265ac19b43a2..ceeb4b582cc1 100644
--- a/textproc/py-python-docx/Makefile
+++ b/textproc/py-python-docx/Makefile
@@ -1,5 +1,5 @@
PORTNAME= python-docx
-PORTVERSION= 0.8.11
+PORTVERSION= 1.1.0
CATEGORIES= textproc python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,11 +10,13 @@ WWW= https://github.com/python-openxml/python-docx
LICENSE= MIT
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=61.0.0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=3.3.4:devel/py-lxml@${PY_FLAVOR}
# Python3 ready
USES= python
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist pep517
NO_ARCH= yes
.include <bsd.port.mk>