aboutsummaryrefslogtreecommitdiff
path: root/textproc/scim/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/scim/Makefile')
-rw-r--r--textproc/scim/Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/textproc/scim/Makefile b/textproc/scim/Makefile
index e7ebf0c7fc93..8f365d730136 100644
--- a/textproc/scim/Makefile
+++ b/textproc/scim/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= scim
-PORTVERSION= 1.0.2
-PORTREVISION= 1
+PORTVERSION= 1.2.0
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=scim
@@ -15,7 +14,7 @@ MASTER_SITE_SUBDIR=scim
MAINTAINER= gaoj@cpsc.ucalgary.ca
COMMENT= Smart Common Input Method platform
-USE_GNOME= gconf2 gnomehier gtk20 intlhack
+USE_GNOME= gnomehack gnomehier gtk20 intlhack
USE_X_PREFIX= yes
USE_ICONV= yes
@@ -26,8 +25,6 @@ USE_LIBTOOL_VER= 15
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
-GCONF_SCHEMAS= scim.schemas
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500035
@@ -36,7 +33,6 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/stlport" \
LDFLAGS="-L${LOCALBASE}/lib -lstlport_gcc -lintl ${PTHREAD_LIBS}"
EXTRA_PATCHES= ${FILESDIR}/extra-patch-4-stable
-PLIST_SUB= NOSTABLE="@comment "
.else
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
@@ -44,8 +40,6 @@ PLIST_SUB= NOSTABLE=""
.endif
post-patch:
- ${REINPLACE_CMD} '/^pkgconfigdir/s|$$(libdir)|$${exec_prefix}/libdata|' \
- ${WRKSRC}/Makefile.in
${REINPLACE_CMD} 's|$$(datadir)/pixmaps|$$(prefix)/share/gnome/pixmaps|' \
${WRKSRC}/data/pixmaps/Makefile.in
${REINPLACE_CMD} -e 's|$$(datadir)/app|$$(prefix)/share/gnome/app| ; \