aboutsummaryrefslogtreecommitdiff
path: root/textproc/sigil
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/sigil')
-rw-r--r--textproc/sigil/Makefile23
-rw-r--r--textproc/sigil/distinfo3
-rw-r--r--textproc/sigil/files/patch-ZipArchive44
-rw-r--r--textproc/sigil/pkg-descr24
-rw-r--r--textproc/sigil/pkg-plist1
5 files changed, 95 insertions, 0 deletions
diff --git a/textproc/sigil/Makefile b/textproc/sigil/Makefile
new file mode 100644
index 000000000000..ad25b733b3d9
--- /dev/null
+++ b/textproc/sigil/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: sigil
+# Date created: 2010-09-07
+# Whom: Jonathan Chen <jonc@chen.org.nz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sigil
+PORTVERSION= 0.2.4
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+DISTNAME= Sigil-${PORTVERSION}-Code
+
+MAINTAINER= jonc@chen.org.nz
+COMMENT= WYSIWYG ePub editor
+
+USE_ZIP= yes
+USE_CMAKE= yes
+USE_DOS2UNIX= DirEnumerator.cpp ZipFile_stl.cpp ZipPlatform_lnx.cpp
+USE_QT_VER= 4
+QT_COMPONENTS= qmake gui svg webkit xml moc uic rcc
+
+.include <bsd.port.mk>
diff --git a/textproc/sigil/distinfo b/textproc/sigil/distinfo
new file mode 100644
index 000000000000..efaf842ba167
--- /dev/null
+++ b/textproc/sigil/distinfo
@@ -0,0 +1,3 @@
+MD5 (Sigil-0.2.4-Code.zip) = dc643e8410f69bdaef8d89ec07d3c0bc
+SHA256 (Sigil-0.2.4-Code.zip) = 001a535986c90f67bdfa0860964a2c70a0b1c23091cf86ea7f618e02fbc776c3
+SIZE (Sigil-0.2.4-Code.zip) = 9299387
diff --git a/textproc/sigil/files/patch-ZipArchive b/textproc/sigil/files/patch-ZipArchive
new file mode 100644
index 000000000000..4d01d73f7dc3
--- /dev/null
+++ b/textproc/sigil/files/patch-ZipArchive
@@ -0,0 +1,44 @@
+diff -ruN /tmp/Sigil-0.2.4-Code/src/ZipArchive/DirEnumerator.cpp ./src/ZipArchive/DirEnumerator.cpp
+--- /tmp/Sigil-0.2.4-Code/src/ZipArchive/DirEnumerator.cpp 2010-08-12 17:50:52.000000000 +1200
++++ ./src/ZipArchive/DirEnumerator.cpp 2010-09-07 22:01:02.000000000 +1200
+@@ -73,7 +73,7 @@
+ if (!entry)
+ break;
+ CZipString path(m_szCurrentDirectory + entry->d_name);
+- #if !defined __APPLE__ && !defined __CYGWIN__ && !defined __NetBSD__
++ #if !defined __APPLE__ && !defined __CYGWIN__ && !defined __NetBSD__ && !defined __FreeBSD__
+ struct stat64 sStats;
+ if (stat64(path, &sStats) == -1)
+ #else
+diff -ruN /tmp/Sigil-0.2.4-Code/src/ZipArchive/ZipFile_stl.cpp ./src/ZipArchive/ZipFile_stl.cpp
+--- /tmp/Sigil-0.2.4-Code/src/ZipArchive/ZipFile_stl.cpp 2010-08-12 17:50:52.000000000 +1200
++++ ./src/ZipArchive/ZipFile_stl.cpp 2010-09-07 22:01:02.000000000 +1200
+@@ -16,7 +16,7 @@
+
+ #if (defined _ZIP_IMPL_STL && (!defined _ZIP_FILE_IMPLEMENTATION || _ZIP_FILE_IMPLEMENTATION == ZIP_ZFI_DEFAULT)) || _ZIP_FILE_IMPLEMENTATION == ZIP_ZFI_STL
+
+-#if defined __APPLE__ || defined __CYGWIN__ || defined __NetBSD__
++#if defined __APPLE__ || defined __CYGWIN__ || defined __NetBSD__ || defined __FreeBSD__
+ #define FILE_FUNCTIONS_64B_BY_DEFAULT
+ #else
+ #undef FILE_FUNCTIONS_64B_BY_DEFAULT
+diff -ruN /tmp/Sigil-0.2.4-Code/src/ZipArchive/ZipPlatform_lnx.cpp ./src/ZipArchive/ZipPlatform_lnx.cpp
+--- /tmp/Sigil-0.2.4-Code/src/ZipArchive/ZipPlatform_lnx.cpp 2010-08-12 17:50:52.000000000 +1200
++++ ./src/ZipArchive/ZipPlatform_lnx.cpp 2010-09-07 22:01:02.000000000 +1200
+@@ -16,7 +16,7 @@
+
+ #ifdef _ZIP_SYSTEM_LINUX
+
+-#if defined __APPLE__ || defined __CYGWIN__ || defined __NetBSD__
++#if defined __APPLE__ || defined __CYGWIN__ || defined __NetBSD__ || defined __FreeBSD__
+ #define FILE_FUNCTIONS_64B_BY_DEFAULT
+ #else
+ #undef FILE_FUNCTIONS_64B_BY_DEFAULT
+@@ -34,7 +34,7 @@
+
+ #include <sys/types.h>
+
+-#if defined (__FreeBSD__) || defined (__APPLE__) || defined (__NetBSD__)
++#if defined (__FreeBSD__) || defined (__APPLE__) || defined (__NetBSD__) || defined (__FreeBSD__)
+ #include <sys/param.h>
+ #include <sys/mount.h>
diff --git a/textproc/sigil/pkg-descr b/textproc/sigil/pkg-descr
new file mode 100644
index 000000000000..b317449cf607
--- /dev/null
+++ b/textproc/sigil/pkg-descr
@@ -0,0 +1,24 @@
+Sigil is a multi-platform WYSIWYG ebook editor. It is designed to edit books
+in ePub format.
+* Free and open source software under GPLv3
+* Multi-platform: runs on Windows, FreeBSD, Linux and Mac
+* Full Unicode support: everything you see in Sigil is in UTF-16
+* Full EPUB spec support
+* WYSIWYG editing
+* Multiple Views: Book View, Code View and Split View
+* Metadata editor with full support for all possible metadata entries
+(more than 200) with full descriptions for each
+* Table Of Contents editor
+* Multi-level TOC support
+* Book View fully supports the display of any XHTML document possible
+under the OPS spec
+* SVG support
+* Basic XPGT support
+* Advanced automatic conversion of all imported documents to Unicode
+* Currently imports TXT, HTML and EPUB files; more will be added with time
+* Embedded HTML Tidy; all imported documents are thoroughly cleaned;
+ changing views cleans the document so no matter how much you screw
+ up your code, it will fix it (usually)
+* An actually usable user interface
+
+WWW: http://code.google.com/p/sigil/
diff --git a/textproc/sigil/pkg-plist b/textproc/sigil/pkg-plist
new file mode 100644
index 000000000000..b1795282a702
--- /dev/null
+++ b/textproc/sigil/pkg-plist
@@ -0,0 +1 @@
+bin/sigil