aboutsummaryrefslogtreecommitdiff
path: root/textproc/xalan-c/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/xalan-c/Makefile')
-rw-r--r--textproc/xalan-c/Makefile25
1 files changed, 14 insertions, 11 deletions
diff --git a/textproc/xalan-c/Makefile b/textproc/xalan-c/Makefile
index 4ad8c4b20eef..cbd44f052e88 100644
--- a/textproc/xalan-c/Makefile
+++ b/textproc/xalan-c/Makefile
@@ -2,27 +2,30 @@
# $FreeBSD$
PORTNAME= xalan-c
-PORTVERSION= 1.11
+PORTVERSION= 1.12
CATEGORIES= textproc
MASTER_SITES= APACHE/xalan/xalan-c/sources
-DISTNAME= xalan_c-${PORTVERSION}-src
+DISTNAME= xalan_c-${PORTVERSION}
-MAINTAINER= rleigh@codelibre.net
+MAINTAINER= rleigh@apache.org
COMMENT= XSLT processor from the Apache XML Project
LICENSE= APACHE20
LIB_DEPENDS= libxerces-c.so:textproc/xerces-c3
-GNU_CONFIGURE= yes
-USES= gmake libtool localbase pathfix
+USES= cmake compiler:c++11-lang
USE_LDCONFIG= yes
-MAKE_JOBS_UNSAFE= yes
-CONFIGURE_ENV= XALANCROOT=${WRKSRC} XALAN_LOCALE_SYSTEM=inmem \
- XALAN_LOCALE=en_US
-MAKE_ENV= ${CONFIGURE_ENV}
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-WRKSRC_SUBDIR= c
+CMAKE_ARGS= -Dmsgloader=inmemory -Dmessage-locale=en_US
+
+OPTIONS_DEFINE= ICU
+OPTIONS_DEFAULT= ICU
+OPTIONS_SUB= yes
+
+ICU_LIB_DEPENDS= libicuuc.so:devel/icu
+ICU_DESC= Use ICU for transcoding
+ICU_CMAKE_ON= -Dtranscoder=icu
+ICU_CMAKE_OFF= -Dtranscoder=default
.include <bsd.port.mk>