aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-wbxml/Makefile29
-rw-r--r--textproc/py-wbxml/distinfo3
-rw-r--r--textproc/py-wbxml/pkg-descr3
4 files changed, 36 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index fe0d0fc9e08b..4441629ab2ac 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -852,6 +852,7 @@
SUBDIR += py-texttable
SUBDIR += py-tvgrab
SUBDIR += py-twistedLore
+ SUBDIR += py-wbxml
SUBDIR += py-wordnet
SUBDIR += py-xlwriter
SUBDIR += py-xml
diff --git a/textproc/py-wbxml/Makefile b/textproc/py-wbxml/Makefile
new file mode 100644
index 000000000000..2780444a3048
--- /dev/null
+++ b/textproc/py-wbxml/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: py-wbxml
+# Date Created: 13 June 2008
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wbxml
+PORTVERSION= 0.1
+CATEGORIES= textproc python
+MASTER_SITES= SF/synce
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= py${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ports@logvinov.com
+COMMENT= Python bindings for the wbxml2 library
+
+LIB_DEPENDS= wbxml2.0:${PORTSDIR}/textproc/wbxml2
+BUILD_DEPENDS= pyrexc:${PORTSDIR}/devel/pyrex
+
+GNU_CONFIGURE= yes
+USE_GNOME= gnometarget
+USE_PYTHON= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/pywbxml.a \
+ %%PYTHON_SITELIBDIR%%/pywbxml.la \
+ %%PYTHON_SITELIBDIR%%/pywbxml.so
+
+.include <bsd.port.mk>
diff --git a/textproc/py-wbxml/distinfo b/textproc/py-wbxml/distinfo
new file mode 100644
index 000000000000..42ea02f06c4b
--- /dev/null
+++ b/textproc/py-wbxml/distinfo
@@ -0,0 +1,3 @@
+MD5 (pywbxml-0.1.tar.gz) = 6a1181b7be09ba69fe6768a0f6156416
+SHA256 (pywbxml-0.1.tar.gz) = 8cc3e6131780ac0720f3765cd6e30c4757945508a988491c60e4abf4c6a17fcc
+SIZE (pywbxml-0.1.tar.gz) = 315507
diff --git a/textproc/py-wbxml/pkg-descr b/textproc/py-wbxml/pkg-descr
new file mode 100644
index 000000000000..143deac41ecf
--- /dev/null
+++ b/textproc/py-wbxml/pkg-descr
@@ -0,0 +1,3 @@
+Python bindings for the wbxml2 library.
+
+WWW: http://www.synce.org/moin/