aboutsummaryrefslogtreecommitdiff
path: root/www/adzap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/adzap/Makefile')
-rw-r--r--www/adzap/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/www/adzap/Makefile b/www/adzap/Makefile
index 8557cb57b9b6..e6f86e4f4685 100644
--- a/www/adzap/Makefile
+++ b/www/adzap/Makefile
@@ -3,7 +3,7 @@
PORTNAME= adzap
PORTVERSION= 20110915
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= http://adzapper.sourceforge.net/
@@ -12,7 +12,8 @@ COMMENT= Filter out animated ad banners from web pages
LICENSE= BSD3CLAUSE
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= scripts/squid_redirect-nodata scripts/wrapzap scripts/zapchain
NO_BUILD= yes
USE_PERL5= run
@@ -22,11 +23,8 @@ PORTDOCS= index.html update-instructions.txt TODO my-bsd-license.html
PORTEXAMPLES= *
SUB_FILES= adzap.conf pkg-message
-do-configure:
-.for FILE in squid_redirect-nodata wrapzap zapchain
- @${REINPLACE_CMD} -e "s:/usr/bin/perl:${PERL5}:g" \
- -e "s:%%PREFIX%%:${PREFIX}:g" ${WRKSRC}/scripts/${FILE}
-.endfor
+post-patch:
+ @${REINPLACE_CMD} -e "s:%%PREFIX%%:${PREFIX}:g" ${WRKSRC}/scripts/wrapzap
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/scripts/squid_redirect-nodata ${STAGEDIR}${PREFIX}/libexec/squid_redirect