aboutsummaryrefslogtreecommitdiff
path: root/www/apache20
diff options
context:
space:
mode:
Diffstat (limited to 'www/apache20')
-rw-r--r--www/apache20/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index 95692e9992fa..374d74077448 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -36,9 +36,16 @@ CONFLICTS= apache+mod_ssl-1.* apache+mod_ssl+ipv6-1.* apache+mod_ssl+modsnmp-1.*
caudium-devel-1.* caudium10-1.* caudium12-1.* caudium14-1.* \
ru-apache+mod_ssl-1.* ru-apache-1.*
-.if defined(WITH_EXPERIMENTAL_PATCHES)
-IGNORE= please define WITH_KQUEUE_SUPPORT instead
-.endif
+OPTIONS= \
+ IPV6 "Enable IPv6 support" On \
+ BDB "Enable BerkeleyDB dbm" Off \
+ KQUEUE_SUPPORT "Enable kqueue in bundled apr" Off \
+ SSL "Enable SSL support" On \
+ SSL_EXPERIMENTAL_ENGINE "Use Experimental SSL engine" Off \
+ DEBUG "Enable debugging" Off \
+ EXCEPTION_HOOK "Enable Exception Hook" On \
+ LDAP "Enable LDAP Support" Off \
+ THREADS "Enable threads in apr Off
.if defined(WITH_KQUEUE_SUPPORT)
EXTRA_PATCHES+= ${FILESDIR}/exp-apr-kqueue.patch