aboutsummaryrefslogtreecommitdiff
path: root/www/dpsearch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/dpsearch/Makefile')
-rw-r--r--www/dpsearch/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/www/dpsearch/Makefile b/www/dpsearch/Makefile
index 999e6741a185..a28ccae76f07 100644
--- a/www/dpsearch/Makefile
+++ b/www/dpsearch/Makefile
@@ -19,7 +19,8 @@ COMMENT= Open source search engine for Internet and Intranet sites
INSTALLS_SHLIB= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
DOCSDIR= ${PREFIX}/share/doc/dataparksearch
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+=--sysconfdir=${PREFIX}/etc/dpsearch \
@@ -122,6 +123,10 @@ CONFIGURE_ARGS+= --with-sqlite=${LOCALBASE}
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
+ ${WRKSRC}/configure
+
pre-install:
@${MKDIR} ${DATADIR}