aboutsummaryrefslogtreecommitdiff
path: root/www/drupal7/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/drupal7/Makefile')
-rw-r--r--www/drupal7/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/www/drupal7/Makefile b/www/drupal7/Makefile
index 466709acd0d6..d854e2322511 100644
--- a/www/drupal7/Makefile
+++ b/www/drupal7/Makefile
@@ -31,6 +31,9 @@ DOCS= CHANGELOG.txt INSTALL.mysql.txt INSTALL.sqlite.txt \
SUB_FILES+= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
+PGSQL_USES= pgsql
+PGSQL_USE= PHP=pdo_pgsql
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSQLITE3}
@@ -40,10 +43,6 @@ USE_PHP+= pdo_sqlite
USE_MYSQL= yes
USE_PHP+= pdo_mysql
.endif
-.if ${PORT_OPTIONS:MPGSQL}
-USE_PGSQL= yes
-USE_PHP+= pdo_pgsql
-.endif
do-install:
${MKDIR} ${STAGEDIR}${DRUPAL_DIR}