aboutsummaryrefslogtreecommitdiff
path: root/www/dufs/Makefile.crates
diff options
context:
space:
mode:
Diffstat (limited to 'www/dufs/Makefile.crates')
-rw-r--r--www/dufs/Makefile.crates266
1 files changed, 138 insertions, 128 deletions
diff --git a/www/dufs/Makefile.crates b/www/dufs/Makefile.crates
index 7fac6a2c5203..5fddbd424a2d 100644
--- a/www/dufs/Makefile.crates
+++ b/www/dufs/Makefile.crates
@@ -1,73 +1,77 @@
CARGO_CRATES= adler-1.0.2 \
aho-corasick-0.7.20 \
- alphanumeric-sort-1.4.4 \
+ aho-corasick-1.0.1 \
+ alphanumeric-sort-1.5.1 \
+ android-tzdata-0.1.1 \
android_system_properties-0.1.5 \
- anyhow-1.0.69 \
- assert_cmd-2.0.8 \
- assert_fs-1.0.10 \
+ anstream-0.3.2 \
+ anstyle-1.0.0 \
+ anstyle-parse-0.2.0 \
+ anstyle-query-1.0.0 \
+ anstyle-wincon-1.0.1 \
+ anyhow-1.0.71 \
+ assert_cmd-2.0.11 \
+ assert_fs-1.0.13 \
async-compression-0.3.15 \
- async-stream-0.3.4 \
- async-stream-impl-0.3.4 \
- async-trait-0.1.64 \
- async_zip-0.0.12 \
+ async-stream-0.3.5 \
+ async-stream-impl-0.3.5 \
+ async-trait-0.1.68 \
+ async_zip-0.0.15 \
autocfg-1.1.0 \
base64-0.13.1 \
- base64-0.21.0 \
+ base64-0.21.2 \
bitflags-1.3.2 \
- block-buffer-0.9.0 \
- block-buffer-0.10.3 \
- bstr-1.3.0 \
- bumpalo-3.12.0 \
+ block-buffer-0.10.4 \
+ bstr-1.5.0 \
+ bumpalo-3.13.0 \
bytes-1.4.0 \
cc-1.0.79 \
cfg-if-1.0.0 \
- chrono-0.4.23 \
- clap-4.1.6 \
- clap_complete-4.1.2 \
- clap_lex-0.3.1 \
- codespan-reporting-0.11.1 \
+ chardetng-0.1.17 \
+ chrono-0.4.26 \
+ clap-4.3.0 \
+ clap_builder-4.3.0 \
+ clap_complete-4.3.0 \
+ clap_lex-0.5.0 \
+ colorchoice-1.0.0 \
content_inspector-0.2.4 \
core-foundation-0.9.3 \
- core-foundation-sys-0.8.3 \
- cpufeatures-0.2.5 \
+ core-foundation-sys-0.8.4 \
+ cpufeatures-0.2.7 \
crc32fast-1.3.2 \
crypto-common-0.1.6 \
- cxx-1.0.91 \
- cxx-build-1.0.91 \
- cxxbridge-flags-1.0.91 \
- cxxbridge-macro-1.0.91 \
difflib-0.4.0 \
- digest-0.9.0 \
- digest-0.10.6 \
- digest_auth-0.3.0 \
- diqwest-1.1.1 \
+ digest-0.10.7 \
+ digest_auth-0.3.1 \
+ diqwest-1.2.0 \
doc-comment-0.3.3 \
either-1.8.1 \
encoding_rs-0.8.32 \
- errno-0.2.8 \
+ errno-0.3.1 \
errno-dragonfly-0.1.2 \
fastrand-1.9.0 \
- flate2-1.0.25 \
+ flate2-1.0.26 \
float-cmp-0.9.0 \
fnv-1.0.7 \
foreign-types-0.3.2 \
foreign-types-shared-0.1.1 \
form_urlencoded-1.1.0 \
- futures-0.3.26 \
- futures-channel-0.3.26 \
- futures-core-0.3.26 \
- futures-executor-0.3.26 \
- futures-io-0.3.26 \
- futures-macro-0.3.26 \
- futures-sink-0.3.26 \
- futures-task-0.3.26 \
+ futures-0.3.28 \
+ futures-channel-0.3.28 \
+ futures-core-0.3.28 \
+ futures-executor-0.3.28 \
+ futures-io-0.3.28 \
+ futures-macro-0.3.28 \
+ futures-sink-0.3.28 \
+ futures-task-0.3.28 \
futures-timer-3.0.2 \
- futures-util-0.3.26 \
- generic-array-0.14.6 \
- getrandom-0.2.8 \
+ futures-util-0.3.28 \
+ generic-array-0.14.7 \
+ getrandom-0.2.9 \
+ glob-0.3.1 \
globset-0.4.10 \
globwalk-0.8.1 \
- h2-0.3.15 \
+ h2-0.3.19 \
hashbrown-0.12.3 \
headers-0.3.8 \
headers-core-0.2.0 \
@@ -78,153 +82,159 @@ CARGO_CRATES= adler-1.0.2 \
http-body-0.4.5 \
httparse-1.8.0 \
httpdate-1.0.2 \
- hyper-0.14.24 \
- hyper-rustls-0.23.2 \
+ hyper-0.14.26 \
+ hyper-rustls-0.24.0 \
hyper-tls-0.5.0 \
- iana-time-zone-0.1.53 \
- iana-time-zone-haiku-0.1.1 \
+ iana-time-zone-0.1.56 \
+ iana-time-zone-haiku-0.1.2 \
idna-0.3.0 \
- if-addrs-0.8.0 \
+ if-addrs-0.10.1 \
ignore-0.4.20 \
- indexmap-1.9.2 \
+ indexmap-1.9.3 \
instant-0.1.12 \
- io-lifetimes-1.0.5 \
- ipnet-2.7.1 \
- is-terminal-0.4.3 \
+ io-lifetimes-1.0.11 \
+ ipnet-2.7.2 \
+ is-terminal-0.4.7 \
itertools-0.10.5 \
- itoa-1.0.5 \
- js-sys-0.3.61 \
+ itoa-1.0.6 \
+ js-sys-0.3.63 \
lazy_static-1.4.0 \
- libc-0.2.139 \
- link-cplusplus-1.0.8 \
- linux-raw-sys-0.1.4 \
- log-0.4.17 \
- md-5-0.9.1 \
+ libc-0.2.144 \
+ linux-raw-sys-0.3.8 \
+ log-0.4.18 \
+ md-5-0.10.5 \
md5-0.7.0 \
memchr-2.5.0 \
- mime-0.3.16 \
+ mime-0.3.17 \
mime_guess-2.0.4 \
- miniz_oxide-0.6.2 \
- mio-0.8.6 \
+ miniz_oxide-0.7.1 \
+ mio-0.8.8 \
native-tls-0.2.11 \
normalize-line-endings-0.3.0 \
- num-integer-0.1.45 \
num-traits-0.2.15 \
num_cpus-1.15.0 \
- once_cell-1.17.1 \
- opaque-debug-0.3.0 \
- openssl-0.10.45 \
- openssl-macros-0.1.0 \
+ once_cell-1.17.2 \
+ openssl-0.10.54 \
+ openssl-macros-0.1.1 \
openssl-probe-0.1.5 \
- openssl-sys-0.9.80 \
- os_str_bytes-6.4.1 \
+ openssl-sys-0.9.88 \
percent-encoding-2.2.0 \
- pin-project-1.0.12 \
- pin-project-internal-1.0.12 \
+ pin-project-1.1.0 \
+ pin-project-internal-1.1.0 \
pin-project-lite-0.2.9 \
pin-utils-0.1.0 \
- pkg-config-0.3.26 \
+ pkg-config-0.3.27 \
port_check-0.1.5 \
ppv-lite86-0.2.17 \
- predicates-2.1.5 \
- predicates-core-1.0.5 \
- predicates-tree-1.0.7 \
- proc-macro2-1.0.51 \
- quote-1.0.23 \
+ predicates-3.0.3 \
+ predicates-core-1.0.6 \
+ predicates-tree-1.0.9 \
+ proc-macro2-1.0.59 \
+ quote-1.0.28 \
rand-0.8.5 \
rand_chacha-0.3.1 \
rand_core-0.6.4 \
- redox_syscall-0.2.16 \
- regex-1.7.1 \
+ redox_syscall-0.3.5 \
+ regex-1.8.3 \
regex-automata-0.1.10 \
- regex-syntax-0.6.28 \
- remove_dir_all-0.5.3 \
- reqwest-0.11.14 \
+ regex-syntax-0.7.2 \
+ reqwest-0.11.18 \
ring-0.16.20 \
- rstest-0.16.0 \
- rstest_macros-0.16.0 \
+ rstest-0.17.0 \
+ rstest_macros-0.17.0 \
rustc_version-0.4.0 \
- rustix-0.36.8 \
- rustls-0.20.8 \
+ rustix-0.37.19 \
+ rustls-0.21.1 \
rustls-pemfile-1.0.2 \
- ryu-1.0.12 \
+ rustls-webpki-0.100.1 \
+ ryu-1.0.13 \
same-file-1.0.6 \
schannel-0.1.21 \
- scratch-1.0.3 \
sct-0.7.0 \
- security-framework-2.8.2 \
- security-framework-sys-2.8.0 \
- semver-1.0.16 \
- serde-1.0.152 \
- serde_derive-1.0.152 \
- serde_json-1.0.93 \
+ security-framework-2.9.1 \
+ security-framework-sys-2.9.0 \
+ semver-1.0.17 \
+ serde-1.0.163 \
+ serde_derive-1.0.163 \
+ serde_json-1.0.96 \
serde_urlencoded-0.7.1 \
sha1-0.10.5 \
- sha2-0.9.9 \
+ sha2-0.10.6 \
signal-hook-registry-1.4.1 \
slab-0.4.8 \
- socket2-0.4.7 \
+ socket2-0.4.9 \
+ socket2-0.5.3 \
spin-0.5.2 \
strsim-0.10.0 \
- syn-1.0.107 \
- tempfile-3.3.0 \
- termcolor-1.2.0 \
- terminal_size-0.2.5 \
- termtree-0.4.0 \
- thiserror-1.0.38 \
- thiserror-impl-1.0.38 \
+ syn-1.0.109 \
+ syn-2.0.18 \
+ tempfile-3.5.0 \
+ terminal_size-0.2.6 \
+ termtree-0.4.1 \
+ thiserror-1.0.40 \
+ thiserror-impl-1.0.40 \
thread_local-1.1.7 \
time-0.1.45 \
tinyvec-1.6.0 \
tinyvec_macros-0.1.1 \
- tokio-1.25.0 \
- tokio-macros-1.8.2 \
+ tokio-1.28.2 \
+ tokio-macros-2.1.0 \
tokio-native-tls-0.3.1 \
- tokio-rustls-0.23.4 \
- tokio-util-0.7.7 \
+ tokio-rustls-0.24.0 \
+ tokio-util-0.7.8 \
tower-service-0.3.2 \
tracing-0.1.37 \
- tracing-core-0.1.30 \
+ tracing-core-0.1.31 \
try-lock-0.2.4 \
typenum-1.16.0 \
unicase-2.6.0 \
- unicode-bidi-0.3.10 \
- unicode-ident-1.0.6 \
+ unicode-bidi-0.3.13 \
+ unicode-ident-1.0.9 \
unicode-normalization-0.1.22 \
- unicode-width-0.1.10 \
untrusted-0.7.1 \
url-2.3.1 \
urlencoding-2.1.2 \
- uuid-1.3.0 \
+ utf8parse-0.2.1 \
+ uuid-1.3.3 \
vcpkg-0.2.15 \
version_check-0.9.4 \
wait-timeout-0.2.0 \
- walkdir-2.3.2 \
+ walkdir-2.3.3 \
want-0.3.0 \
wasi-0.10.0+wasi-snapshot-preview1 \
wasi-0.11.0+wasi-snapshot-preview1 \
- wasm-bindgen-0.2.84 \
- wasm-bindgen-backend-0.2.84 \
- wasm-bindgen-futures-0.4.34 \
- wasm-bindgen-macro-0.2.84 \
- wasm-bindgen-macro-support-0.2.84 \
- wasm-bindgen-shared-0.2.84 \
- web-sys-0.3.61 \
+ wasm-bindgen-0.2.86 \
+ wasm-bindgen-backend-0.2.86 \
+ wasm-bindgen-futures-0.4.36 \
+ wasm-bindgen-macro-0.2.86 \
+ wasm-bindgen-macro-support-0.2.86 \
+ wasm-bindgen-shared-0.2.86 \
+ web-sys-0.3.63 \
webpki-0.22.0 \
webpki-roots-0.22.6 \
winapi-0.3.9 \
winapi-i686-pc-windows-gnu-0.4.0 \
winapi-util-0.1.5 \
winapi-x86_64-pc-windows-gnu-0.4.0 \
+ windows-0.48.0 \
windows-sys-0.42.0 \
windows-sys-0.45.0 \
- windows-targets-0.42.1 \
- windows_aarch64_gnullvm-0.42.1 \
- windows_aarch64_msvc-0.42.1 \
- windows_i686_gnu-0.42.1 \
- windows_i686_msvc-0.42.1 \
- windows_x86_64_gnu-0.42.1 \
- windows_x86_64_gnullvm-0.42.1 \
- windows_x86_64_msvc-0.42.1 \
+ windows-sys-0.48.0 \
+ windows-targets-0.42.2 \
+ windows-targets-0.48.0 \
+ windows_aarch64_gnullvm-0.42.2 \
+ windows_aarch64_gnullvm-0.48.0 \
+ windows_aarch64_msvc-0.42.2 \
+ windows_aarch64_msvc-0.48.0 \
+ windows_i686_gnu-0.42.2 \
+ windows_i686_gnu-0.48.0 \
+ windows_i686_msvc-0.42.2 \
+ windows_i686_msvc-0.48.0 \
+ windows_x86_64_gnu-0.42.2 \
+ windows_x86_64_gnu-0.48.0 \
+ windows_x86_64_gnullvm-0.42.2 \
+ windows_x86_64_gnullvm-0.48.0 \
+ windows_x86_64_msvc-0.42.2 \
+ windows_x86_64_msvc-0.48.0 \
winreg-0.10.1 \
- xml-rs-0.8.4
+ xml-rs-0.8.13