aboutsummaryrefslogtreecommitdiff
path: root/www/gallery2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/gallery2/Makefile')
-rw-r--r--www/gallery2/Makefile40
1 files changed, 25 insertions, 15 deletions
diff --git a/www/gallery2/Makefile b/www/gallery2/Makefile
index fc90679c4a44..eb49ec666a34 100644
--- a/www/gallery2/Makefile
+++ b/www/gallery2/Makefile
@@ -16,7 +16,7 @@ DIST_SUBDIR= gallery2
MAINTAINER= freebsd-ports@varju.ca
COMMENT= Gallery is a web based photo album written using PHP
-USE_PHP= pcre session mysql
+USE_PHP= pcre session
WANT_PHP_WEB= yes
WRKSRC= ${WRKDIR}/${DIST_SUBDIR}
@@ -29,29 +29,39 @@ GALLERY2DIR?= www/data/gallery2
WWWOWN?= www
WWWGRP?= www
-OPTIONS= NETPBM "Enable netpbm support" on \
- IMAGEMAGICK "Enable imagemagick support" on \
- JHEAD "Enable jhead support" on \
- UNZIP "Enable unzip support" on \
- GD "Enable gd support" off \
- DCRAW "Enable dcraw support" off \
- FFMPEG "Enable ffmpeg support" off
+# Note that USE_PHP must be set before bsd.port.pre.mk is included, so
+# OPTIONS can't be used right now without making portlint angry
+#OPTIONS= NETPBM "Enable netpbm support" on \
+# IMAGEMAGICK "Enable imagemagick support" on \
+# PGSQL "Use PostgreSQL instead of MySQL" off \
+# JHEAD "Enable jhead support" on \
+# UNZIP "Enable unzip support" on \
+# GD "Enable gd support" off \
+# DCRAW "Enable dcraw support" off \
+# FFMPEG "Enable ffmpeg support" off
+
+.if defined(WITH_PGSQL)
+USE_PHP+= pgsql
+.else
+USE_PHP+= mysql
+.endif
+.if defined(WITH_GD)
+USE_PHP+= gd
+RUN_DEPENDS+= pngtogd:${PORTSDIR}/graphics/gd
+.endif
.include <bsd.port.pre.mk>
-.if defined(WITH_NETPBM)
+.if !defined(WITHOUT_NETPBM)
RUN_DEPENDS+= giftopnm:${PORTSDIR}/graphics/netpbm
.endif
-.if defined(WITH_IMAGEMAGICK)
+.if !defined(WITHOUT_IMAGEMAGICK)
RUN_DEPENDS+= convert:${PORTSDIR}/graphics/ImageMagick
.endif
-.if defined(WITH_GD)
-RUN_DEPENDS+= pngtogd:${PORTSDIR}/graphics/gd
-.endif
-.if defined(WITH_JHEAD)
+.if !defined(WITHOUT_JHEAD)
RUN_DEPENDS+= jhead:${PORTSDIR}/graphics/jhead
.endif
-.if defined(WITH_UNZIP)
+.if !defined(WITHOUT_UNZIP)
RUN_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
.endif
.if defined(WITH_FFMPEG)