aboutsummaryrefslogtreecommitdiff
path: root/www/igal/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/igal/Makefile')
-rw-r--r--www/igal/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/www/igal/Makefile b/www/igal/Makefile
new file mode 100644
index 000000000000..64870b7d99dd
--- /dev/null
+++ b/www/igal/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: igal
+# Date created: 14 Aug 2002
+# Whom: Dylan Carlson <absinthe@pobox.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= igal
+PORTVERSION= 1.3
+CATEGORIES= www graphics
+MASTER_SITES= http://www.stanford.edu/~epop/igal/ \
+ http://planetmirror.com/pub/igal/
+
+MAINTAINER= absinthe@pobox.com
+COMMENT= A static html image gallery generator for *nix
+
+USE_REINPLACE= yes
+
+RUN_DEPENDS= ${LOCALBASE}/bin/cjpeg:${PORTSDIR}/graphics/jpeg \
+ ${LOCALBASE}/include/Magick++.h:${PORTSDIR}/graphics/ImageMagick
+
+MAN1= igal.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},g' ${WRKSRC}/Makefile \
+ ${WRKSRC}/igal
+
+.include <bsd.port.mk>