aboutsummaryrefslogtreecommitdiff
path: root/www/mod_chroot/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_chroot/Makefile')
-rw-r--r--www/mod_chroot/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/www/mod_chroot/Makefile b/www/mod_chroot/Makefile
index fe3e6d660682..421d0fc2e40d 100644
--- a/www/mod_chroot/Makefile
+++ b/www/mod_chroot/Makefile
@@ -10,17 +10,14 @@ MASTER_SITES= http://core.segfault.pl/~hobbit/mod_chroot/dist/
MAINTAINER= apache@FreeBSD.org
COMMENT= The mod_chroot makes running Apache in a chroot easy
-
USE_APACHE= 22+
AP_FAST_BUILD= yes
AP_GENPLIST= yes
PORTDOCS= INSTALL CAVEATS README.Apache20 README
-NO_STAGE= yes
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>