aboutsummaryrefslogtreecommitdiff
path: root/www/mod_dnssd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_dnssd/Makefile')
-rw-r--r--www/mod_dnssd/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/www/mod_dnssd/Makefile b/www/mod_dnssd/Makefile
new file mode 100644
index 000000000000..a3a890947bce
--- /dev/null
+++ b/www/mod_dnssd/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: mod_dnssd
+# Date created: 27 February 2009
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_dnssd
+PORTVERSION= 0.6
+CATEGORIES= www
+MASTER_SITES= http://0pointer.de/lennart/projects/mod_dnssd/
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= An Apache module that provides DNS-SD capabilities
+
+LIB_DEPENDS= avahi-client.3:${PORTSDIR}/net/avahi-app
+
+USE_GMAKE= yes
+USE_APACHE= 2.0+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/README ${DOCSDIR}/README
+.endif
+
+.include <bsd.port.mk>