aboutsummaryrefslogtreecommitdiff
path: root/www/mod_php5/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mod_php5/Makefile')
-rw-r--r--www/mod_php5/Makefile24
1 files changed, 22 insertions, 2 deletions
diff --git a/www/mod_php5/Makefile b/www/mod_php5/Makefile
index 78777d258b80..0bbf3dd5f6b1 100644
--- a/www/mod_php5/Makefile
+++ b/www/mod_php5/Makefile
@@ -1,9 +1,9 @@
-# New ports collection makefile for: apache HTTPD
+# New ports collection makefile for: apache HTTPD and HTTPSD
# Version required: 1.1.1
# Date created: Fri Aug 25 16:42:36 CDT 1995
# Whom: erich@rrnet.com
#
-# $Id: Makefile,v 1.15 1996/07/12 06:41:05 pst Exp $
+# $Id: Makefile,v 1.16 1996/07/12 10:27:53 asami Exp $
#
DISTNAME= apache_1.1.1
@@ -13,6 +13,26 @@ MASTER_SITES= ftp://www.apache.org/apache/dist/
MAINTAINER= ache@freebsd.org
+.if defined(SECURE_SERVER)
+PKGNAME= apache_SSL-1.1.1
+MAIN_SRC= ${DISTNAME}${EXTRACT_SUFX}
+SSL_EXTRAS= ${DISTNAME}+1.3.ssl${EXTRACT_SUFX}
+DISTFILES= ${MAIN_SRC} ${SSL_EXTRAS}
+MASTER_SITES+= ftp://ftp.ox.ac.uk/pub/crypto/SSL/
+EXTRACT_ONLY= ${MAIN_SRC}
+MD5_FILE= ${FILESDIR}/md5.SSL
+PATCHDIR= ${.CURDIR}/patches.SSL
+PKGDIR= ${.CURDIR}/pkg.SSL
+CONFIGURE_SCRIPT= configure.SSL
+DEPENDS= ssleay:${PORTSDIR}/security/SSLeay
+
+post-extract:
+ @cd ${WRKSRC} && tar xzf ${DISTDIR}/${SSL_EXTRAS}
+
+pre-patch:
+ @cd ${WRKSRC} && ${PATCH} ${PATCH_DIST_ARGS} < SSLpatch
+.endif
+
post-install:
@if [ ! -f ${PREFIX}/etc/rc.d/apache.sh ]; then \
echo "Installing ${PREFIX}/etc/rc.d/apache.sh startup file."; \