aboutsummaryrefslogtreecommitdiff
path: root/www/netscape-remote/files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/netscape-remote/files/Makefile')
-rw-r--r--www/netscape-remote/files/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/www/netscape-remote/files/Makefile b/www/netscape-remote/files/Makefile
new file mode 100644
index 000000000000..f6b116fdbb42
--- /dev/null
+++ b/www/netscape-remote/files/Makefile
@@ -0,0 +1,22 @@
+X11BASE ?= /usr/X11R6
+INCDIR = -I$(X11BASE)/include
+LIBDIR = -L$(X11BASE)/lib
+LIBS = -lX11 -lXmu
+OBJS = remote.o
+CFLAGS += -DSTANDALONE -g $(INCDIR)
+PREFIX ?= /usr/local
+BSD_INSTALL_PROGRAM ?= /usr/bin/install -c -s
+
+BINARY = netscape-remote
+
+all: remote
+
+remote: $(OBJS)
+ $(CC) $(CFLAGS) $(LIBDIR) $(LIBS) -o $(BINARY) $(OBJS)
+
+install: all
+ $(BSD_INSTALL_PROGRAM) $(BINARY) $(PREFIX)/bin
+
+clean:
+ for i in $(OBJS); do rm -f $$i; done
+ rm -f $(BINARY)