aboutsummaryrefslogtreecommitdiff
path: root/www/ocaml-net/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/ocaml-net/Makefile')
-rw-r--r--www/ocaml-net/Makefile74
1 files changed, 48 insertions, 26 deletions
diff --git a/www/ocaml-net/Makefile b/www/ocaml-net/Makefile
index 637b2b1e121a..44403c1847ee 100644
--- a/www/ocaml-net/Makefile
+++ b/www/ocaml-net/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= net
-PORTVERSION= 3.3.3
+PORTVERSION= 3.5.1
CATEGORIES= www
MASTER_SITES= http://download.camlcity.org/download/
PKGNAMEPREFIX= ocaml-
@@ -15,8 +15,7 @@ DISTNAME= ocaml${PORTNAME}-${PORTVERSION}
MAINTAINER= jaapb@kerguelen.org
COMMENT= OCaml modules for Internet applications
-BUILD_DEPENDS= ${SA_DIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre \
- camlp5:${PORTSDIR}/devel/ocaml-camlp5
+BUILD_DEPENDS= ${SA_DIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre
RUN_DEPENDS:= ${BUILD_DEPENDS}
CONFLICTS= ocaml-equeue-2* ocaml-netclient-0*
@@ -38,14 +37,12 @@ DOCSDIR= ${PREFIX}/share/doc/ocaml/${PKGNAMEPREFIX}${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PKGNAMEPREFIX}${PORTNAME}
SA_DIR= ${LOCALBASE}/${OCAML_SITELIBDIR}
-.if !defined(NOPORTDOCS)
PORTDOCS= *
PORTEXAMPLES= *
-.endif
OCAML_PKGDIRS= netsys netshm equeue shell netstring rpc-generator \
rpc pop smtp netclient netcgi2 netgssapi netplex \
- netcgi2-plex netcamlbox netmulticore
+ netcgi2-plex netcamlbox netmulticore rpc-auth-local
OCAML_LDLIBS= ${OCAML_PKGDIRS:S/^/${OCAML_SITELIBDIR}\//}
OPTIONS= SSL "Enable SSL support" ON \
@@ -53,42 +50,44 @@ OPTIONS= SSL "Enable SSL support" ON \
AUTH_DH "Enable Diffie-Hellman authorization support" OFF \
GTK "Enable GTK support" OFF \
GTK2 "Enable GTK2 support" OFF \
- APACHE "Enable Apache mod connector (experimental)" OFF
+ APACHE "Enable Apache mod connector (experimental)" OFF \
+ ZIP "Enable compression support" OFF \
+ SCRAM "Enable SCRAM support" OFF
.include <bsd.port.options.mk>
.if defined(WITHOUT_SSL)
-CONFIGURE_ARGS+= -disable-ssl
+CONFIGURE_ARGS+= -disable-ssl
.else
-CONFIGURE_ARGS+= -enable-ssl
-BUILD_DEPENDS+= ${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl
-RUN_DEPENDS+= ${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl
-OCAML_PKGDIRS+= equeue-ssl rpc-ssl
+CONFIGURE_ARGS+= -enable-ssl
+BUILD_DEPENDS+= ${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl
+RUN_DEPENDS+= ${SA_DIR}/ssl/ssl.a:${PORTSDIR}/security/ocaml-ssl
+OCAML_PKGDIRS+= equeue-ssl rpc-ssl
.endif
.if defined(WITH_NETHTTPD)
-CONFIGURE_ARGS+= -with-nethttpd
-OCAML_PKGDIRS+= nethttpd nethttpd-for-netcgi2
+CONFIGURE_ARGS+= -with-nethttpd
+OCAML_PKGDIRS+= nethttpd nethttpd-for-netcgi2
.else
-CONFIGURE_ARGS+= -without-nethttpd
+CONFIGURE_ARGS+= -without-nethttpd
.endif
.if defined(WITH_AUTH_DH)
-CONFIGURE_ARGS+= -with-rpc-auth-dh
-BUILD_DEPENDS+= ${SA_DIR}/cryptgps/cryptgps.a:${PORTSDIR}/security/ocaml-cryptgps
-RUN_DEPENDS+= ${SA_DIR}/cryptgps/cryptgps.a:${PORTSDIR}/security/ocaml-cryptgps
-OCAML_PKGDIRS+= rpc-auth-dh
+CONFIGURE_ARGS+= -with-rpc-auth-dh
+BUILD_DEPENDS+= ${SA_DIR}/cryptgps/cryptgps.a:${PORTSDIR}/security/ocaml-cryptgps
+RUN_DEPENDS+= ${SA_DIR}/cryptgps/cryptgps.a:${PORTSDIR}/security/ocaml-cryptgps
+OCAML_PKGDIRS+= rpc-auth-dh
.else
-CONFIGURE_ARGS+= -without-rpc-auth-dh
+CONFIGURE_ARGS+= -without-rpc-auth-dh
.endif
.if defined(WITH_GTK)
-CONFIGURE_ARGS+= -enable-gtk
-BUILD_DEPENDS+= lablgtk:${PORTSDIR}/x11-toolkits/ocaml-lablgtk
-RUN_DEPENDS+= lablgtk:${PORTSDIR}/x11-toolkits/ocaml-lablgtk
-OCAML_PKGDIRS+= equeue-gtk1
+CONFIGURE_ARGS+= -enable-gtk
+BUILD_DEPENDS+= lablgtk:${PORTSDIR}/x11-toolkits/ocaml-lablgtk
+RUN_DEPENDS+= lablgtk:${PORTSDIR}/x11-toolkits/ocaml-lablgtk
+OCAML_PKGDIRS+= equeue-gtk1
.else
-CONFIGURE_ARGS+= -disable-gtk
+CONFIGURE_ARGS+= -disable-gtk
.endif
.if defined(WITH_GTK2)
@@ -108,15 +107,38 @@ OCAML_PKGDIRS+= netcgi_apache
CONFIGURE_ARGS+= -disable-apache
.endif
+.if defined(WITH_ZIP)
+CONFIGURE_ARGS+= -enable-zip
+BUILD_DEPENDS+= ${SA_DIR}/zip/zip.a:${PORTSDIR}/archivers/ocaml-zip
+RUN_DEPENDS+= ${SA_DIR}/zip/zip.a:${PORTSDIR}/archivers/ocaml-zip
+OCAML_PKGDIRS+= netzip
+.else
+CONFIGURE_ARGS+= -disable-zip
+.endif
+
+.if defined(WITH_SCRAM)
+CONFIGURE_ARGS+= -enable-crypto
+BUILD_DEPENDS+= ${SA_DIR}/cryptokit/cryptokit.a:${PORTSDIR}/security/ocaml-cryptokit
+RUN_DEPENDS+= ${SA_DIR}/cryptokit/cryptokit.a:${PORTSDIR}/security/ocaml-cryptokit
+OCAML_PKGDIRS+= netmech-scram
+.else
+CONFIGURE_ARGS+= -disable-crypto
+.endif
+
post-patch:
${REINPLACE_CMD} -e '/\.libs/d' \
${WRKSRC}/src/netcgi2-apache/Makefile.def
+ ${REINPLACE_CMD} -e 's/camlzip/zip/' \
+ ${WRKSRC}/configure \
+ ${WRKSRC}/src/netzip/META.in \
+ ${WRKSRC}/src/netzip/Makefile
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}/
@(cd ${WRKSRC}/doc/ && ${COPYTREE_SHARE} \* ${DOCSDIR}/)
-
+.endif
+.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}/
@(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}/)
.endif