aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Apache-Admin-Config/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-Apache-Admin-Config/Makefile')
-rw-r--r--www/p5-Apache-Admin-Config/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/www/p5-Apache-Admin-Config/Makefile b/www/p5-Apache-Admin-Config/Makefile
new file mode 100644
index 000000000000..d8b43bdaa1bd
--- /dev/null
+++ b/www/p5-Apache-Admin-Config/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: www/p5-Apache-Admin-Config
+# Date created: 05 December 2001
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Apache-Admin-Config
+PORTVERSION= 0.12
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MAN3= Apache::Admin::Config.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+post-patch:
+ ${PERL} -pi -e 's/(!\$$)/0 && $1/;' \
+ -e 's|(VERSION_FROM\s+=>\s+)(.*)(,.*)$$|$$1$$2$$3\nMAN3PODS=>{$$2=>q!\\\$$(INST_MAN3DIR)/${MAN3}!},|;' \
+ ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>