aboutsummaryrefslogtreecommitdiff
path: root/www/p5-CIF-Client/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-CIF-Client/Makefile')
-rw-r--r--www/p5-CIF-Client/Makefile34
1 files changed, 18 insertions, 16 deletions
diff --git a/www/p5-CIF-Client/Makefile b/www/p5-CIF-Client/Makefile
index cfb202461d56..8bc41c944ba9 100644
--- a/www/p5-CIF-Client/Makefile
+++ b/www/p5-CIF-Client/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= CIF-Client
-PORTVERSION= 0.06
+PORTVERSION= 0.07
CATEGORIES= www perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:SAXJAZMAN/cif
@@ -15,21 +15,23 @@ PKGNAMEPREFIX= p5-
MAINTAINER= pauls@utdallas.edu
COMMENT= Extends REST::Client for use with the CI-Framework REST interface
-BUILD_DEPENDS= p5-REST-Client>=0:${PORTSDIR}/www/p5-REST-Client \
- p5-Module-Install>=0:${PORTSDIR}/devel/p5-Module-Install \
- p5-Text-Table>=0:${PORTSDIR}/textproc/p5-Text-Table \
- p5-HTML-Table>=0:${PORTSDIR}/www/p5-HTML-Table \
- p5-JSON>=0:${PORTSDIR}/converters/p5-JSON \
- p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress \
- p5-Config-Simple>=0:${PORTSDIR}/devel/p5-Config-Simple \
- p5-Snort-Rule>=0:${PORTSDIR}/security/p5-Snort-Rule \
- p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
- p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
- p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
- p5-Module-Pluggable>=0:${PORTSDIR}/devel/p5-Module-Pluggable \
- p5-Regexp-Common>=0:${PORTSDIR}/textproc/p5-Regexp-Common \
- p5-Regexp-Common-net-CIDR>=0:${PORTSDIR}/textproc/p5-Regexp-Common-net-CIDR \
- p5-HTTP-Server-Simple>=0:${PORTSDIR}/www/p5-HTTP-Server-Simple
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-HTML-Table>=2.08:${PORTSDIR}/www/p5-HTML-Table \
+ p5-HTTP-Server-Simple>0:${PORTSDIR}/www/p5-HTTP-Server-Simple \
+ p5-IO-Compress>=2.008:${PORTSDIR}/archivers/p5-IO-Compress \
+ p5-JSON>=2.07:${PORTSDIR}/converters/p5-JSON \
+ p5-LWP-Protocol-https>0:${PORTSDIR}/www/p5-LWP-Protocol-https \
+ p5-REST-Client>=243:${PORTSDIR}/www/p5-REST-Client \
+ p5-Class-Accessor>=0.31:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Config-Simple>=4.58:${PORTSDIR}/devel/p5-Config-Simple \
+ p5-Digest-SHA1>=2.11:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-Module-Install>=1.00:${PORTSDIR}/devel/p5-Module-Install \
+ p5-Regexp-Common>=2.108:${PORTSDIR}/textproc/p5-Regexp-Common \
+ p5-Regexp-Common-net-CIDR>=0.02:${PORTSDIR}/textproc/p5-Regexp-Common-net-CIDR \
+ p5-Snort-Rule>=1.07:${PORTSDIR}/security/p5-Snort-Rule \
+ p5-Text-Table>=1.114:${PORTSDIR}/textproc/p5-Text-Table
RUN_DEPENDS:= ${BUILD_DEPENDS}