aboutsummaryrefslogtreecommitdiff
path: root/www/py-plone.folder/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-plone.folder/Makefile')
-rw-r--r--www/py-plone.folder/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/www/py-plone.folder/Makefile b/www/py-plone.folder/Makefile
index c36bcd5e0fa4..bd8794475314 100644
--- a/www/py-plone.folder/Makefile
+++ b/www/py-plone.folder/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= plone.folder
-PORTVERSION= 1.0.4
-PORTREVISION= 1
+PORTVERSION= 1.0.7
CATEGORIES= www python zope
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,12 +13,16 @@ COMMENT= BTree-based folder implementation with order support
LICENSE= GPLv2
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}plone.memoize>0:${PORTSDIR}/www/py-plone.memoize \
+ ${PYTHON_PKGNAMEPREFIX}Products.BTreeFolder2>0:${PORTSDIR}/devel/py-Products.BTreeFolder2 \
+ ${PYTHON_PKGNAMEPREFIX}Products.CMFCore>0:${PORTSDIR}/devel/py-Products.CMFCore \
+ ${PYTHON_PKGNAMEPREFIX}Products.ZCatalog>0:${PORTSDIR}/devel/py-Products.ZCatalog \
${PYTHON_PKGNAMEPREFIX}zope.interface>0:${PORTSDIR}/devel/py-zope.interface \
${PYTHON_PKGNAMEPREFIX}zope.component>0:${PORTSDIR}/devel/py-zope.component \
${PYTHON_PKGNAMEPREFIX}zope.annotation>0:${PORTSDIR}/devel/py-zope.annotation \
${PYTHON_PKGNAMEPREFIX}zope.container>0:${PORTSDIR}/devel/py-zope.container
-USES= python zip
-USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+USES= python
+USE_PYTHON= autoplist distutils
.include <bsd.port.mk>