aboutsummaryrefslogtreecommitdiff
path: root/www/py-plone.registry/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-plone.registry/Makefile')
-rw-r--r--www/py-plone.registry/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/www/py-plone.registry/Makefile b/www/py-plone.registry/Makefile
new file mode 100644
index 000000000000..a80dfba25086
--- /dev/null
+++ b/www/py-plone.registry/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: py-plone.registry
+# Date created: 25 December 2011
+# Whom: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= plone.registry
+PORTVERSION= 1.0
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= Registry for storing application settings
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= zodb${PYTHON_PKGNAMESUFFIX}>=0:${PORTSDIR}/databases/zodb3 \
+ ${PYTHON_PKGNAMEPREFIX}zope.schema>=0:${PORTSDIR}/devel/py-zope.schema \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>=0:${PORTSDIR}/devel/py-zope.interface \
+ ${PYTHON_PKGNAMEPREFIX}zope.component>=0:${PORTSDIR}/devel/py-zope.component \
+ ${PYTHON_PKGNAMEPREFIX}zope.dottedname>=0:${PORTSDIR}/devel/py-zope.dottedname \
+ ${PYTHON_PKGNAMEPREFIX}zope.event>=0:${PORTSDIR}/devel/py-zope.event \
+ ${PYTHON_PKGNAMEPREFIX}zope.testing>=0:${PORTSDIR}/devel/py-zope.testing
+
+DIST_SUBDIR= zope
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+USE_ZIP= yes
+
+.include <bsd.port.mk>