aboutsummaryrefslogtreecommitdiff
path: root/www/snownews/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/snownews/Makefile')
-rw-r--r--www/snownews/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/www/snownews/Makefile b/www/snownews/Makefile
index 0418318c153a..c14463acb802 100644
--- a/www/snownews/Makefile
+++ b/www/snownews/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# New ports collection makefile for: snownews
-# Date created: Nov 3 2003
-# Whom: Cheng-Lung Sung <clsung@dragon2.net>
-#
+# Created by: Cheng-Lung Sung <clsung@dragon2.net>
# $FreeBSD$
-#
PORTNAME= snownews
PORTVERSION= 1.5.12
@@ -20,16 +15,18 @@ USE_GMAKE= yes
USE_GNOME= libxml2
HAS_CONFIGURE= yes
-OPTIONS= OPML "Outline Processor Markup Support" on
+OPTIONS_DEFINE= OPML NLS
+OPTIONS_DEFAULT= OPML
+OPML_DESC= Outline Processor Markup Support
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
.endif
-.if defined(WITHOUT_OPML)
+.if ! ${PORT_OPTIONS:MOPML}
EXTRA_PATCHES= ${FILESDIR}/extra-patch-Makefile
PLIST_SUB+= OPML="@comment "
.else
@@ -48,7 +45,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|gcc|${CC}|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|make|${GMAKE}|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|share/man|man|' ${WRKSRC}/Makefile
-.if defined(WITHOUT_NLS)
+.if ! ${PORT_OPTIONS:MNLS}
${REINPLACE_CMD} -e 's/ install-locales / /g' ${WRKSRC}/Makefile
${REINPLACE_CMD} -e 's/ locales$$//g' ${WRKSRC}/Makefile
.endif