aboutsummaryrefslogtreecommitdiff
path: root/www/squid30
diff options
context:
space:
mode:
Diffstat (limited to 'www/squid30')
-rw-r--r--www/squid30/Makefile6
-rw-r--r--www/squid30/files/squid.sh21
2 files changed, 22 insertions, 5 deletions
diff --git a/www/squid30/Makefile b/www/squid30/Makefile
index 7595a8afd6f6..92a95b12339c 100644
--- a/www/squid30/Makefile
+++ b/www/squid30/Makefile
@@ -108,11 +108,7 @@ post-install:
${MKDIR} ${PREFIX}/squid/cache
@if [ ! -f ${PREFIX}/etc/rc.d/squid.sh ]; then \
${ECHO} "Installing ${PREFIX}/etc/rc.d/squid.sh startup file."; \
- ${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/squid.sh; \
- ${ECHO} "if [ -x ${PREFIX}/sbin/RunCache -a -f ${PREFIX}/etc/squid/squid.conf ]; then" >> ${PREFIX}/etc/rc.d/squid.sh; \
- ${ECHO} " (cd /tmp; ${PREFIX}/sbin/RunCache >/dev/null 2>&1 &) ; ${ECHO} -n ' squid'" >> ${PREFIX}/etc/rc.d/squid.sh; \
- ${ECHO} "fi" >> ${PREFIX}/etc/rc.d/squid.sh; \
- ${CHMOD} 751 ${PREFIX}/etc/rc.d/squid.sh; \
+ ${INSTALL_SCRIPT} -m 751 ${FILESDIR}/squid.sh ${PREFIX}/etc/rc.d/squid.sh; \
fi
.include <bsd.port.mk>
diff --git a/www/squid30/files/squid.sh b/www/squid30/files/squid.sh
new file mode 100644
index 000000000000..e9a3144e8c93
--- /dev/null
+++ b/www/squid30/files/squid.sh
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
+ echo "$0: Cannot determine the PREFIX" >&2
+ exit 1
+fi
+
+case "$1" in
+start)
+ if [ -x ${PREFIX}/sbin/RunCache -a -f ${PREFIX}/etc/squid/squid.conf ]; then
+ (cd /tmp; ${PREFIX}/sbin/RunCache >/dev/null 2>&1 &) ; echo -n ' squid'
+ fi
+ ;;
+stop)
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ ;;
+esac
+
+exit 0