aboutsummaryrefslogtreecommitdiff
path: root/www/trac-remind/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/trac-remind/Makefile')
-rw-r--r--www/trac-remind/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/www/trac-remind/Makefile b/www/trac-remind/Makefile
new file mode 100644
index 000000000000..28f67bc4d9d3
--- /dev/null
+++ b/www/trac-remind/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: trac-remind
+# Date created: May 18 2007
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= remind
+PORTVERSION= 1
+CATEGORIES= www devel python
+MASTER_SITES= http://www.unixmedia.it/
+PKGNAMEPREFIX= trac-
+DISTNAME= trac${PORTNAME}
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= Trac tickets reminder script
+
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
+
+NO_BUILD= yes
+USE_ZIP= yes
+USE_PYTHON= 2.3+
+
+PLIST_FILES= bin/tracremind.py etc/tracremind.conf
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX}," \
+ -e "s,%%PYTHON%%,${PYTHON_CMD}," ${WRKSRC}/tracremind.py
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/tracremind.py ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/tracremind.conf ${PREFIX}/etc
+
+.include <bsd.port.mk>