aboutsummaryrefslogtreecommitdiff
path: root/www/twig/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/twig/Makefile')
-rw-r--r--www/twig/Makefile29
1 files changed, 23 insertions, 6 deletions
diff --git a/www/twig/Makefile b/www/twig/Makefile
index e0a4ca3da914..11ec64d78a46 100644
--- a/www/twig/Makefile
+++ b/www/twig/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= twig
-PORTVERSION= 2.7.6
+PORTVERSION= 2.7.7
CATEGORIES= www mail
-MASTER_SITES= http://twig.screwdriver.net/download/
+MASTER_SITES= http://twig.info/download/ \
+ http://twig.screwdriver.net/download/
MAINTAINER= dinoex@FreeBSD.org
@@ -23,11 +24,27 @@ LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
.endif
NO_BUILD= YES
-TWIG?= www/data.default/twig
+TWIG?= www/data-dist/twig
PLIST_SUB+= TWIG=${TWIG}
+ROOTFILES= index.php3 test.php3 goto.php3
+CONFFILES= .htaccess mailfooter.inc.php3.sample
+USERFILES= announcements.inc.php3 config.inc.php3 dbconfig.inc.php3 \
+ defaults.inc.php3 footer.inc.php3 header.inc.php3 \
+ images.inc.php3 login.footer.inc.php3 login.form.php3 \
+ login.header.inc.php3 mainmenu.inc.php3 newusergroups.inc.php3
do-install:
- -${MKDIR} ${PREFIX}/${TWIG}/
- (cd ${WRKSRC} && ./twig-install ${PREFIX}/${TWIG} )
-
+ -${MKDIR} ${PREFIX}/${TWIG}/config
+ @(cd ${WRKSRC} && ${CP} ${ROOTFILES} ${PREFIX}/${TWIG}/ )
+ @(cd ${WRKSRC} && ${CP} -R features ${PREFIX}/${TWIG}/ )
+ @(cd ${WRKSRC} && ${CP} -R images ${PREFIX}/${TWIG}/ )
+ @(cd ${WRKSRC} && ${CP} -R lib ${PREFIX}/${TWIG}/ )
+ @(cd ${WRKSRC}/config && ${CP} ${CONFFILES} ${PREFIX}/${TWIG}/config/ )
+.for i in ${USERFILES}
+ @${CP} ${WRKSRC}/config/${i} ${PREFIX}/${TWIG}/config/${i}-dist
+ @if test ! -f ${PREFIX}/${TWIG}/config/${i} ; then \
+ ${CP} ${WRKSRC}/config/${i} ${PREFIX}/${TWIG}/config/${i}; \
+ fi
+.endfor
+
.include <bsd.port.mk>