aboutsummaryrefslogtreecommitdiff
path: root/www/wadcomblog
diff options
context:
space:
mode:
Diffstat (limited to 'www/wadcomblog')
-rw-r--r--www/wadcomblog/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/www/wadcomblog/Makefile b/www/wadcomblog/Makefile
index 38d237699f12..580c33c96643 100644
--- a/www/wadcomblog/Makefile
+++ b/www/wadcomblog/Makefile
@@ -12,19 +12,21 @@ COMMENT= Simple open-source static blog engine written in Python
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+.include <bsd.port.options.mk>
-NO_STAGE= yes
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_MAN} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${ECHO_MSG} "installing additional examples to ${EXAMPLESDIR}"
- @${MKDIR} ${EXAMPLESDIR}
- @(cd ${WRKSRC}/sample/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @(cd ${WRKSRC}/sample/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR})
.endif
.include <bsd.port.mk>