aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/amphetadesk/Makefile2
-rw-r--r--www/apache24/Makefile.options1
-rw-r--r--www/axis/Makefile1
-rw-r--r--www/cgicc/Makefile3
-rw-r--r--www/elixir-html_entities/Makefile2
-rw-r--r--www/elixir-html_sanitize_ex/Makefile2
-rw-r--r--www/elixir-httpoison/Makefile2
-rw-r--r--www/elixir-httpotion/Makefile2
-rw-r--r--www/elixir-joken/Makefile2
-rw-r--r--www/elixir-maru/Makefile2
-rw-r--r--www/elixir-phoenix/Makefile2
-rw-r--r--www/elixir-phoenix_ecto/Makefile2
-rw-r--r--www/elixir-phoenix_html/Makefile2
-rw-r--r--www/elixir-phoenix_pubsub/Makefile2
-rw-r--r--www/elixir-webassembly/Makefile2
-rw-r--r--www/erlang-cowboy/Makefile2
-rw-r--r--www/erlang-cowlib/Makefile2
-rw-r--r--www/erlang-hackney/Makefile2
-rw-r--r--www/erlang-ibrowse/Makefile2
-rw-r--r--www/erlang-mochiweb-basho/Makefile2
-rw-r--r--www/erlang-mochiweb/Makefile2
-rw-r--r--www/erlang-webmachine/Makefile2
-rw-r--r--www/hypermail/Makefile2
-rw-r--r--www/jericho-html/Makefile2
-rw-r--r--www/linux-opera/Makefile2
-rw-r--r--www/luakit/Makefile2
-rw-r--r--www/mod_auth_cas/Makefile2
-rw-r--r--www/mod_auth_external2/Makefile4
-rw-r--r--www/mod_auth_mysql_another/Makefile2
-rw-r--r--www/mod_auth_pam2/Makefile2
-rw-r--r--www/mod_auth_pgsql2/Makefile2
-rw-r--r--www/mod_authnz_external24/Makefile2
-rw-r--r--www/mod_cfg_ldap/Makefile4
-rw-r--r--www/mod_chroot/Makefile2
-rw-r--r--www/mod_cvs2/Makefile2
-rw-r--r--www/mod_domaintree/Makefile2
-rw-r--r--www/mod_evasive/Makefile2
-rw-r--r--www/mod_fastcgi/Makefile4
-rw-r--r--www/mod_geoip2/Makefile2
-rw-r--r--www/mod_gzip2/Makefile2
-rw-r--r--www/mod_http2-devel/Makefile2
-rw-r--r--www/mod_limitipconn2/Makefile2
-rw-r--r--www/mod_md-devel/Makefile2
-rw-r--r--www/mod_rpaf2/Makefile2
-rw-r--r--www/php-templates/Makefile2
-rw-r--r--www/pmwiki/Makefile2
-rw-r--r--www/polipo/Makefile2
-rw-r--r--www/privatebin/Makefile2
-rw-r--r--www/roundup/Makefile2
-rw-r--r--www/spdylay/Makefile2
-rw-r--r--www/spreadlogd/Makefile2
-rw-r--r--www/squidanalyzer/Makefile2
-rw-r--r--www/varnish-libvmod-awsrest/Makefile2
-rw-r--r--www/varnish-libvmod-digest/Makefile2
-rw-r--r--www/varnish-libvmod-maxminddb/Makefile2
-rw-r--r--www/varnish4/Makefile2
-rw-r--r--www/varnish5/Makefile2
-rw-r--r--www/varnish6/Makefile2
-rw-r--r--www/volta/Makefile2
-rw-r--r--www/webinject/Makefile2
-rw-r--r--www/websh/Makefile2
-rw-r--r--www/www6to4/Makefile2
-rw-r--r--www/xshttpd-devel/Makefile2
-rw-r--r--www/xshttpd/Makefile2
64 files changed, 124 insertions, 9 deletions
diff --git a/www/amphetadesk/Makefile b/www/amphetadesk/Makefile
index 94d572475d75..bea32ca64edc 100644
--- a/www/amphetadesk/Makefile
+++ b/www/amphetadesk/Makefile
@@ -38,6 +38,8 @@ SUB_LIST+= PERL="${PERL}"
PORTDOCS= *
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
post-patch:
diff --git a/www/apache24/Makefile.options b/www/apache24/Makefile.options
index 4980ae71e634..14828e0c7be3 100644
--- a/www/apache24/Makefile.options
+++ b/www/apache24/Makefile.options
@@ -85,6 +85,7 @@ ALL_MODULES= ${MOST_ENABLED_MODULES} ${MOST_DISABLED_MODULES} \
${EXAMPLE_MODULES} ${META_MODULES}
OPTIONS_DEFINE= \
+ DOCS \
${MOST_ENABLED_MODULES} \
${MOST_DISABLED_MODULES}\
${ADDITIONAL_OPT} \
diff --git a/www/axis/Makefile b/www/axis/Makefile
index a60ea613c41e..928dd48fc5aa 100644
--- a/www/axis/Makefile
+++ b/www/axis/Makefile
@@ -13,6 +13,7 @@ COMMENT= Java SOAP implementation by Apache
LICENSE= APACHE20
+OPTIONS_DEFINE= DOCS
OPTIONS_SINGLE= AS
OPTIONS_SINGLE_AS= TOMCAT6 TOMCAT7
OPTIONS_DEFAULT= TOMCAT6
diff --git a/www/cgicc/Makefile b/www/cgicc/Makefile
index f2756ffd48a7..ac1c0f53824d 100644
--- a/www/cgicc/Makefile
+++ b/www/cgicc/Makefile
@@ -11,7 +11,7 @@ COMMENT= C++ class library for writing CGI applications
LICENSE= LGPL3+
-OPTIONS_DEFINE= DOXYGEN
+OPTIONS_DEFINE= DOXYGEN DOCS
USES= gmake pathfix libtool
GNU_CONFIGURE= yes
@@ -24,6 +24,7 @@ CXXFLAGS+= -Wno-unknown-pragmas
PORTDOCS= *
+DOXYGEN_IMPLIES= DOCS
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
DOXYGEN_CONFIGURE_ENV_OFF= ac_cv_prog_DOXYGEN="${ECHO_CMD}"
diff --git a/www/elixir-html_entities/Makefile b/www/elixir-html_entities/Makefile
index 08296be23d89..f012ebc95ceb 100644
--- a/www/elixir-html_entities/Makefile
+++ b/www/elixir-html_entities/Makefile
@@ -17,4 +17,6 @@ GH_ACCOUNT= martinsvalin
MIX_REWRITE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/www/elixir-html_sanitize_ex/Makefile b/www/elixir-html_sanitize_ex/Makefile
index 7f81788da679..f1e08952ae49 100644
--- a/www/elixir-html_sanitize_ex/Makefile
+++ b/www/elixir-html_sanitize_ex/Makefile
@@ -19,4 +19,6 @@ MIX_BUILD_DEPS= www/erlang-mochiweb
MIX_RUN_DEPS:= ${MIX_BUILD_DEPS}
MIX_REWRITE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/www/elixir-httpoison/Makefile b/www/elixir-httpoison/Makefile
index 5a21a91c8f5b..f4568886efd5 100644
--- a/www/elixir-httpoison/Makefile
+++ b/www/elixir-httpoison/Makefile
@@ -18,4 +18,6 @@ GH_ACCOUNT= edgurgel
MIX_BUILD_DEPS= www/erlang-hackney
MIX_RUN_DEPS:= ${MIX_BUILD_DEPS}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/www/elixir-httpotion/Makefile b/www/elixir-httpotion/Makefile
index 3f9bf1bbadbc..02a2cbd642f4 100644
--- a/www/elixir-httpotion/Makefile
+++ b/www/elixir-httpotion/Makefile
@@ -19,4 +19,6 @@ MIX_BUILD_DEPS= www/erlang-ibrowse
MIX_RUN_DEPS:= ${MIX_BUILD_DEPS}
MIX_REWRITE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/www/elixir-joken/Makefile b/www/elixir-joken/Makefile
index e7221efd3642..06d732dbe450 100644
--- a/www/elixir-joken/Makefile
+++ b/www/elixir-joken/Makefile
@@ -19,4 +19,6 @@ MIX_BUILD_DEPS= devel/elixir-plug \
security/elixir-jose
MIX_RUN_DEPS:= ${MIX_BUILD_DEPS}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/www/elixir-maru/Makefile b/www/elixir-maru/Makefile
index 0339542ef659..2b362f71a41b 100644
--- a/www/elixir-maru/Makefile
+++ b/www/elixir-maru/Makefile
@@ -20,4 +20,6 @@ MIX_BUILD_DEPS= devel/elixir-plug \
www/erlang-cowboy
MIX_RUN_DEPS:= ${MIX_BUILD_DEPS}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/www/elixir-phoenix/Makefile b/www/elixir-phoenix/Makefile
index e8054e3230d1..838de1a58910 100644
--- a/www/elixir-phoenix/Makefile
+++ b/www/elixir-phoenix/Makefile
@@ -15,7 +15,7 @@ USES= elixir
USE_GITHUB= yes
GH_ACCOUNT= phoenixframework
-OPTIONS_DEFINE= COWBOY
+OPTIONS_DEFINE= COWBOY DOCS
COWBOY_DESC= Use Cowboy library
COWBOY_BUILD_DEPENDS= erlang-cowboy>=0:www/erlang-cowboy
diff --git a/www/elixir-phoenix_ecto/Makefile b/www/elixir-phoenix_ecto/Makefile
index 915679b8ae32..deee537ff17a 100644
--- a/www/elixir-phoenix_ecto/Makefile
+++ b/www/elixir-phoenix_ecto/Makefile
@@ -22,4 +22,6 @@ MIX_BUILD_DEPS= databases/elixir-ecto \
MIX_RUN_DEPS:= ${MIX_BUILD_DEPS}
MIX_REWRITE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/www/elixir-phoenix_html/Makefile b/www/elixir-phoenix_html/Makefile
index 2509717eca45..b528647490b9 100644
--- a/www/elixir-phoenix_html/Makefile
+++ b/www/elixir-phoenix_html/Makefile
@@ -19,4 +19,6 @@ MIX_BUILD_DEPS= devel/elixir-plug
MIX_RUN_DEPS:= ${MIX_BUILD_DEPS}
MIX_REWRITE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/www/elixir-phoenix_pubsub/Makefile b/www/elixir-phoenix_pubsub/Makefile
index 97cd12a1c9c2..2e5d702cd8e8 100644
--- a/www/elixir-phoenix_pubsub/Makefile
+++ b/www/elixir-phoenix_pubsub/Makefile
@@ -17,4 +17,6 @@ GH_ACCOUNT= phoenixframework
MIX_REWRITE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/www/elixir-webassembly/Makefile b/www/elixir-webassembly/Makefile
index e1e9de064075..2bb815b528a2 100644
--- a/www/elixir-webassembly/Makefile
+++ b/www/elixir-webassembly/Makefile
@@ -15,4 +15,6 @@ USES= elixir
USE_GITHUB= yes
GH_ACCOUNT= herenowcoder
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/www/erlang-cowboy/Makefile b/www/erlang-cowboy/Makefile
index b7dbbbc022f3..28897f766f80 100644
--- a/www/erlang-cowboy/Makefile
+++ b/www/erlang-cowboy/Makefile
@@ -18,6 +18,8 @@ ERL_BUILD_DEPS= www/erlang-cowlib
ERL_RUN_DEPS= www/erlang-cowlib \
net/erlang-ranch
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}
diff --git a/www/erlang-cowlib/Makefile b/www/erlang-cowlib/Makefile
index 66ca4067f285..06457f42a3f3 100644
--- a/www/erlang-cowlib/Makefile
+++ b/www/erlang-cowlib/Makefile
@@ -15,4 +15,6 @@ USES= erlang:rebar
USE_GITHUB= yes
GH_ACCOUNT= ninenines
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/www/erlang-hackney/Makefile b/www/erlang-hackney/Makefile
index 65c984671b88..9cce3b684f6b 100644
--- a/www/erlang-hackney/Makefile
+++ b/www/erlang-hackney/Makefile
@@ -21,6 +21,8 @@ ERL_BUILD_DEPS= dns/erlang-idna \
misc/erlang-mimerl
ERL_RUN_DEPS:= ${ERL_BUILD_DEPS}
+OPTIONS_DEFINE= DOCS
+
pre-build:
@${MKDIR} ${WRKSRC}/_build/default/lib
.for lib in idna certifi ssl_verify_fun metrics mimerl
diff --git a/www/erlang-ibrowse/Makefile b/www/erlang-ibrowse/Makefile
index ad3facf1ee42..b19a8c5eae03 100644
--- a/www/erlang-ibrowse/Makefile
+++ b/www/erlang-ibrowse/Makefile
@@ -16,4 +16,6 @@ USES= erlang:rebar
USE_GITHUB= yes
GH_ACCOUNT= cmullaparthi
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/www/erlang-mochiweb-basho/Makefile b/www/erlang-mochiweb-basho/Makefile
index f1640e60bbd6..1530f83299fc 100644
--- a/www/erlang-mochiweb-basho/Makefile
+++ b/www/erlang-mochiweb-basho/Makefile
@@ -18,6 +18,8 @@ USE_GITHUB= yes
GH_ACCOUNT= basho
GH_TAGNAME= 4d38821 # required
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}
diff --git a/www/erlang-mochiweb/Makefile b/www/erlang-mochiweb/Makefile
index d69708d4b4ec..553397cba147 100644
--- a/www/erlang-mochiweb/Makefile
+++ b/www/erlang-mochiweb/Makefile
@@ -18,6 +18,8 @@ CPE_VENDOR= mochiweb_project
USE_GITHUB= yes
GH_ACCOUNT= mochi
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR}
diff --git a/www/erlang-webmachine/Makefile b/www/erlang-webmachine/Makefile
index c7e20b004e9d..252aa4f191a0 100644
--- a/www/erlang-webmachine/Makefile
+++ b/www/erlang-webmachine/Makefile
@@ -17,4 +17,6 @@ GH_ACCOUNT= webmachine
ERL_BUILD_DEPS= www/erlang-mochiweb-basho
ERL_RUN_DEPS:= ${ERL_BUILD_DEPS}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/www/hypermail/Makefile b/www/hypermail/Makefile
index e19ef899d790..688965954614 100644
--- a/www/hypermail/Makefile
+++ b/www/hypermail/Makefile
@@ -24,6 +24,8 @@ CONFIGURE_ARGS= --with-htmldir=${STAGEDIR}${PREFIX}/share/doc/hypermail \
CFLAGS+= -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/${PORTNAME}
+OPTIONS_DEFINE= DOCS
+
post-install:
${STRIP_CMD} ${STAGEDIR}/${PREFIX}/bin/hypermail \
${STAGEDIR}/${PREFIX}/bin/msg2archive \
diff --git a/www/jericho-html/Makefile b/www/jericho-html/Makefile
index 5e1ce2349f51..de30f4572e3e 100644
--- a/www/jericho-html/Makefile
+++ b/www/jericho-html/Makefile
@@ -21,6 +21,8 @@ INTERFACES:= "compile-time-dependencies/slf4j-api-1.6.1.jar:\
PORTDOCS= *
PLIST_FILES+= %%JAVAJARDIR%%/${PORTNAME}.jar
+OPTIONS_DEFINE= DOCS
+
do-build:
(cd ${WRKSRC} && ${RM} -r classes/* && ${SETENV} \
LANG=en_US.ISO8859-1 LC_ALL=en_US.ISO8859-1 ${JAVAC} \
diff --git a/www/linux-opera/Makefile b/www/linux-opera/Makefile
index 7768fc123f9d..2584e3348e94 100644
--- a/www/linux-opera/Makefile
+++ b/www/linux-opera/Makefile
@@ -38,6 +38,8 @@ RENAME= opera lib/opera \
share/doc/opera share/opera man/man1/opera.1 \
share/mime/packages/opera-extension.xml
+OPTIONS_DEFINE= DOCS
+
post-extract:
@${GUNZIP_CMD} ${WRKSRC}/share/man/man1/*.gz
@${MV} ${WRKSRC}/share/man ${WRKSRC}/man
diff --git a/www/luakit/Makefile b/www/luakit/Makefile
index ec3d36333b35..196a7474ca40 100644
--- a/www/luakit/Makefile
+++ b/www/luakit/Makefile
@@ -30,7 +30,7 @@ NOT_FOR_ARCHS_REASON_sparc64= Does not install on sparc64
MAKE_ARGS+= DEVELOPMENT_PATHS=0
-OPTIONS_DEFINE= LUAJIT
+OPTIONS_DEFINE= DOCS LUAJIT
LUAJIT_DESC= Use the Just-In-Time compiler for lua
LUAJIT_LIB_DEPENDS= libluajit-5.1.so:lang/luajit
LUAJIT_MAKE_ARGS= USE_LUAJIT=1
diff --git a/www/mod_auth_cas/Makefile b/www/mod_auth_cas/Makefile
index a8f693eb3032..f617e7899ce8 100644
--- a/www/mod_auth_cas/Makefile
+++ b/www/mod_auth_cas/Makefile
@@ -35,6 +35,8 @@ SUB_FILES= ${APMOD_FILE}
APMOD_FILE= 250_${PORTNAME}.conf.sample
PLIST_SUB+= APMOD_FILE=${APMOD_FILE}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
do-install:
diff --git a/www/mod_auth_external2/Makefile b/www/mod_auth_external2/Makefile
index 3477a9825f1b..eeefed8f67c5 100644
--- a/www/mod_auth_external2/Makefile
+++ b/www/mod_auth_external2/Makefile
@@ -21,7 +21,9 @@ SHORTMODNAME= auth_external
PORTDOCS= AUTHENTICATORS INSTALL README
-post-install:
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/www/mod_auth_mysql_another/Makefile b/www/mod_auth_mysql_another/Makefile
index 4813913ce7f6..8915ebe4b60e 100644
--- a/www/mod_auth_mysql_another/Makefile
+++ b/www/mod_auth_mysql_another/Makefile
@@ -25,6 +25,8 @@ AP_EXTRAS= -lmysqlclient_r -lz -lm
PORTDOCS= CONFIGURE CHANGES
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/www/mod_auth_pam2/Makefile b/www/mod_auth_pam2/Makefile
index 7fecef1e7583..1e51a61bbade 100644
--- a/www/mod_auth_pam2/Makefile
+++ b/www/mod_auth_pam2/Makefile
@@ -24,6 +24,8 @@ AP_GENPLIST= yes
AP_EXTRAS+= -lpam
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/samples/httpd ${STAGEDIR}${EXAMPLESDIR}/pam-httpd.sample
diff --git a/www/mod_auth_pgsql2/Makefile b/www/mod_auth_pgsql2/Makefile
index 61839d5c4890..2f74ea0b8e7b 100644
--- a/www/mod_auth_pgsql2/Makefile
+++ b/www/mod_auth_pgsql2/Makefile
@@ -19,6 +19,8 @@ AP_FAST_BUILD= yes
AP_GENPLIST= yes
PORTDOCS= mod_auth_pgsql.html
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/www/mod_authnz_external24/Makefile b/www/mod_authnz_external24/Makefile
index fb7a93efd423..9f74666523ee 100644
--- a/www/mod_authnz_external24/Makefile
+++ b/www/mod_authnz_external24/Makefile
@@ -21,6 +21,8 @@ SHORTMODNAME= authnz_external
PORTDOCS= AUTHENTICATORS INSTALL README \
CHANGES UPGRADE INSTALL.HARDCODE
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/www/mod_cfg_ldap/Makefile b/www/mod_cfg_ldap/Makefile
index f1cddeddd19b..8089c50acd12 100644
--- a/www/mod_cfg_ldap/Makefile
+++ b/www/mod_cfg_ldap/Makefile
@@ -26,7 +26,9 @@ AP_LIB+= ${LDAP_LIB}
PORTDOCS= AUTHORS cfg_ldap.conf ChangeLog COPYING INSTALL \
mod_cfg_ldap.schema README TODO
-post-install:
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/www/mod_chroot/Makefile b/www/mod_chroot/Makefile
index 25592bcf4aca..0571d07dea48 100644
--- a/www/mod_chroot/Makefile
+++ b/www/mod_chroot/Makefile
@@ -17,6 +17,8 @@ AP_GENPLIST= yes
PORTDOCS= INSTALL CAVEATS README.Apache20 README
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/www/mod_cvs2/Makefile b/www/mod_cvs2/Makefile
index 3dbea8b05288..d023a5e7a8ef 100644
--- a/www/mod_cvs2/Makefile
+++ b/www/mod_cvs2/Makefile
@@ -22,6 +22,8 @@ AP_GENPLIST= yes
PORTDOCS= reference.html guide.html README
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
diff --git a/www/mod_domaintree/Makefile b/www/mod_domaintree/Makefile
index 99a52b0395a7..dea58047532d 100644
--- a/www/mod_domaintree/Makefile
+++ b/www/mod_domaintree/Makefile
@@ -18,6 +18,8 @@ AP_GENPLIST= yes
PORTDOCS= LICENSE.txt ChangeLog
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/www/mod_evasive/Makefile b/www/mod_evasive/Makefile
index cffd8b0f0803..6e36b62571d2 100644
--- a/www/mod_evasive/Makefile
+++ b/www/mod_evasive/Makefile
@@ -24,6 +24,8 @@ MODULENAME= ${PORTNAME}20
PORTDOCS= README test.pl
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
post-patch:
diff --git a/www/mod_fastcgi/Makefile b/www/mod_fastcgi/Makefile
index 88ebc5911055..e68892b317de 100644
--- a/www/mod_fastcgi/Makefile
+++ b/www/mod_fastcgi/Makefile
@@ -19,7 +19,9 @@ AP_GENPLIST= yes
SRC_FILE= *.c
PORTDOCS= mod_fastcgi.html
-post-install:
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${STAGEDIR}${DOCSDIR}
diff --git a/www/mod_geoip2/Makefile b/www/mod_geoip2/Makefile
index 1dc1cf454af6..010a2deea1d5 100644
--- a/www/mod_geoip2/Makefile
+++ b/www/mod_geoip2/Makefile
@@ -26,6 +26,8 @@ AP_LIB+= ${LOCALBASE}/lib -lGeoIP
SUB_FILES+= pkg-message
PORTDOCS= Changes INSTALL.md README.md README.php
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
diff --git a/www/mod_gzip2/Makefile b/www/mod_gzip2/Makefile
index 60f5fc5cad53..ddded470a5f8 100644
--- a/www/mod_gzip2/Makefile
+++ b/www/mod_gzip2/Makefile
@@ -21,6 +21,8 @@ USES= apache:2.2+ gmake
PORTDOCS= commands.txt samples.txt
PORTEXAMPLES= mod_gzip2.conf.sample
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${MV} ${WRKSRC}/mod_gzip.c ${WRKSRC}/${PORTNAME}.c
diff --git a/www/mod_http2-devel/Makefile b/www/mod_http2-devel/Makefile
index e805137fa865..c400c1e07d2b 100644
--- a/www/mod_http2-devel/Makefile
+++ b/www/mod_http2-devel/Makefile
@@ -31,6 +31,8 @@ CFLAGS+= -I${LOCALBASE}/include
SUB_FILES= 200_mod_http2.conf 300_mod_proxy_http2.conf
PORTDOCS= README README.md
+OPTIONS_DEFINE= DOCS
+
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEETCDIR}/modules.d
${INSTALL_DATA} ${WRKDIR}/200_mod_http2.conf \
diff --git a/www/mod_limitipconn2/Makefile b/www/mod_limitipconn2/Makefile
index 7b2a015aac3d..713e12940416 100644
--- a/www/mod_limitipconn2/Makefile
+++ b/www/mod_limitipconn2/Makefile
@@ -22,6 +22,8 @@ AP_GENPLIST= yes
PORTDOCS= ChangeLog INSTALL README
+OPTIONS_DEFINE= DOCS
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}/
diff --git a/www/mod_md-devel/Makefile b/www/mod_md-devel/Makefile
index 7c98878b4a7b..5c2ceee6fbcc 100644
--- a/www/mod_md-devel/Makefile
+++ b/www/mod_md-devel/Makefile
@@ -39,6 +39,8 @@ SUB_FILES= 999_mod_md.conf pkg-message
DOCSDIR= share/doc/mod_md
PORTDOCS= README README.md
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100085 && ${SSL_DEFAULT} == base
diff --git a/www/mod_rpaf2/Makefile b/www/mod_rpaf2/Makefile
index d991f46e21f4..6c9618c9f071 100644
--- a/www/mod_rpaf2/Makefile
+++ b/www/mod_rpaf2/Makefile
@@ -31,6 +31,8 @@ SUB_FILES= ${APMOD_FILE}
PORTDOCS= README.md
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
post-install:
diff --git a/www/php-templates/Makefile b/www/php-templates/Makefile
index 4017cc379de9..067c5567c07f 100644
--- a/www/php-templates/Makefile
+++ b/www/php-templates/Makefile
@@ -26,6 +26,8 @@ SUB_FILES= pkg-message
PORTDOCS= *
+OPTIONS_DEFINE= DOCS
+
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/php/${PHP_EXT_DIR}
${INSTALL_LIB} ${WRKSRC}/modules/templates.so \
diff --git a/www/pmwiki/Makefile b/www/pmwiki/Makefile
index 89f3615f3cae..4503685459be 100644
--- a/www/pmwiki/Makefile
+++ b/www/pmwiki/Makefile
@@ -25,6 +25,8 @@ PLIST_SUB= PMWIKIDIR=${PMWIKIDIR} WWWGRP=${WWWGRP} WWWOWN=${WWWOWN}
SUB_LIST+= PMWIKIDIR=${PMWIKIDIR}
SUB_FILES= pkg-message
+OPTIONS_DEFINE= DOCS
+
pre-fetch:
.if !defined(PMWIKIDIR)
@${ECHO_MSG} ""
diff --git a/www/polipo/Makefile b/www/polipo/Makefile
index 40e86a74fbc4..1e6ed01f29ac 100644
--- a/www/polipo/Makefile
+++ b/www/polipo/Makefile
@@ -18,6 +18,8 @@ USE_RC_SUBR= polipo
INFO= polipo
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
DOCSDIR= ${DATADIR}/www/doc
diff --git a/www/privatebin/Makefile b/www/privatebin/Makefile
index 35a73e73004b..e33a3b95e0f8 100644
--- a/www/privatebin/Makefile
+++ b/www/privatebin/Makefile
@@ -19,6 +19,8 @@ USE_PHP= gd hash json wddx zlib
USE_GITHUB= yes
GH_PROJECT= PrivateBin
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e 's:%%DATADBDIR%%:/var/db/${PORTNAME}:' \
${WRKSRC}/index.php
diff --git a/www/roundup/Makefile b/www/roundup/Makefile
index 59d6fcfd0c96..cb5d8dc4e661 100644
--- a/www/roundup/Makefile
+++ b/www/roundup/Makefile
@@ -17,7 +17,7 @@ CPE_VENDOR= roundup-tracker
USE_PYTHON= distutils
NO_ARCH= yes
-OPTIONS_DEFINE= SQLITE PGSQL MYSQL NLS
+OPTIONS_DEFINE= DOCS SQLITE PGSQL MYSQL NLS
OPTIONS_DEFAULT=SQLITE
OPTIONS_SUB= yes
diff --git a/www/spdylay/Makefile b/www/spdylay/Makefile
index fc0db34b5f55..7247101dae86 100644
--- a/www/spdylay/Makefile
+++ b/www/spdylay/Makefile
@@ -34,6 +34,8 @@ USES= compiler:c++11-lang gnome libtool pathfix pkgconfig ssl tar:xz
PORTDOCS= *
+OPTIONS_DEFINE= DOCS
+
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/examples/spdycli ${STAGEDIR}${PREFIX}/bin/
${INSTALL_DATA} ${WRKSRC}/shrpx.conf.sample ${STAGEDIR}${PREFIX}/etc/
diff --git a/www/spreadlogd/Makefile b/www/spreadlogd/Makefile
index 13f8f3e31c9e..3cc8d7f711f9 100644
--- a/www/spreadlogd/Makefile
+++ b/www/spreadlogd/Makefile
@@ -21,6 +21,8 @@ PLIST_FILES= sbin/spreadlogd etc/spreadlogd.conf.sample
PORTDOCS= README
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|' ${WRKSRC}/spreadlogd.c
diff --git a/www/squidanalyzer/Makefile b/www/squidanalyzer/Makefile
index ca9ffde924b9..a93c0d501259 100644
--- a/www/squidanalyzer/Makefile
+++ b/www/squidanalyzer/Makefile
@@ -33,6 +33,8 @@ SUB_FILES= pkg-message
CONF_FILES= excluded included network-aliases \
squidanalyzer.conf user-aliases
+OPTIONS_DEFINE= DOCS
+
post-install:
.for file in ${CONF_FILES}
@${MV} ${STAGEDIR}${ETCDIR}/${file} \
diff --git a/www/varnish-libvmod-awsrest/Makefile b/www/varnish-libvmod-awsrest/Makefile
index a8e9ecbf4eac..4f80790623b6 100644
--- a/www/varnish-libvmod-awsrest/Makefile
+++ b/www/varnish-libvmod-awsrest/Makefile
@@ -24,4 +24,6 @@ INSTALL_TARGET= install-strip
USE_GITHUB= yes
GH_ACCOUNT= xcir
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/www/varnish-libvmod-digest/Makefile b/www/varnish-libvmod-digest/Makefile
index e8d3799317b7..c50bac7b3bee 100644
--- a/www/varnish-libvmod-digest/Makefile
+++ b/www/varnish-libvmod-digest/Makefile
@@ -23,4 +23,6 @@ INSTALL_TARGET= install-strip
USE_GITHUB= yes
GH_ACCOUNT= varnish
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/www/varnish-libvmod-maxminddb/Makefile b/www/varnish-libvmod-maxminddb/Makefile
index 5a9e260dd1e6..b56704c685d0 100644
--- a/www/varnish-libvmod-maxminddb/Makefile
+++ b/www/varnish-libvmod-maxminddb/Makefile
@@ -26,4 +26,6 @@ GH_TAGNAME= 4ae6a7f
MAKE_JOBS_UNSAFE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/www/varnish4/Makefile b/www/varnish4/Makefile
index b425a0ffecec..0d6e6d833032 100644
--- a/www/varnish4/Makefile
+++ b/www/varnish4/Makefile
@@ -44,6 +44,8 @@ BAD_TESTS+= r00832
EXTRA_PATCHES+= ${FILESDIR}/no-inet6.patch
.endif
+OPTIONS_DEFINE= DOCS
+
post-patch:
.if defined(BAD_TESTS)
${RM} ${BAD_TESTS:C|.+|${WRKSRC}/bin/varnishtest/tests/\0.vtc|}
diff --git a/www/varnish5/Makefile b/www/varnish5/Makefile
index 595c1d058b96..d1f912fc5f20 100644
--- a/www/varnish5/Makefile
+++ b/www/varnish5/Makefile
@@ -43,6 +43,8 @@ BAD_TESTS+= r00832
EXTRA_PATCHES+= ${FILESDIR}/no-inet6.patch
.endif
+OPTIONS_DEFINE= DOCS
+
post-patch:
.if defined(BAD_TESTS)
${RM} ${BAD_TESTS:C|.+|${WRKSRC}/bin/varnishtest/tests/\0.vtc|}
diff --git a/www/varnish6/Makefile b/www/varnish6/Makefile
index 182196207294..ae3a8ab4befe 100644
--- a/www/varnish6/Makefile
+++ b/www/varnish6/Makefile
@@ -43,6 +43,8 @@ BAD_TESTS+= r00832
EXTRA_PATCHES+= ${FILESDIR}/no-inet6.patch
.endif
+OPTIONS_DEFINE= DOCS
+
post-patch:
.if defined(BAD_TESTS)
${RM} ${BAD_TESTS:C|.+|${WRKSRC}/bin/varnishtest/tests/\0.vtc|}
diff --git a/www/volta/Makefile b/www/volta/Makefile
index 72867a1b1564..b7a0633dda4c 100644
--- a/www/volta/Makefile
+++ b/www/volta/Makefile
@@ -25,6 +25,8 @@ PLIST_FILES= bin/volta
PORTDOCS= README INSTALL LICENSE ChangeLog
SUB_FILES= pkg-message
+OPTIONS_DEFINE= DOCS
+
do-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
diff --git a/www/webinject/Makefile b/www/webinject/Makefile
index 56bc38f4c46e..e7988b1c8c26 100644
--- a/www/webinject/Makefile
+++ b/www/webinject/Makefile
@@ -32,6 +32,8 @@ PLIST_FILES= bin/webinject.pl \
PORTDOCS= LICENSE README
+OPTIONS_DEFINE= DOCS
+
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
@cd ${WRKSRC} && ${INSTALL_DATA} *.xml ${STAGEDIR}${DATADIR}
diff --git a/www/websh/Makefile b/www/websh/Makefile
index 8f9852a19b1b..f78f6b45af03 100644
--- a/www/websh/Makefile
+++ b/www/websh/Makefile
@@ -29,6 +29,8 @@ PORTEXAMPLES= *
CONFIGURE_ARGS+=--with-httpdinclude=`apxs -q includedir`
+OPTIONS_DEFINE= DOCS
+
CPPFLAGS+= -I ${LOCALBASE}/include/apr-1
.if !defined(NO_WERROR) && ${CC} == "cc" || ${CC:T:Mgcc*} != ""
CPPFLAGS+= -Wall -Werror
diff --git a/www/www6to4/Makefile b/www/www6to4/Makefile
index 09e3a3775fd2..efeb24c4cc2e 100644
--- a/www/www6to4/Makefile
+++ b/www/www6to4/Makefile
@@ -20,6 +20,8 @@ PORTDOCS= README
ALL_TARGET= www6to4
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e 's,/etc,${ETCDIR},' \
${WRKSRC}/www6to4.c ${WRKSRC}/www6to4.conf
diff --git a/www/xshttpd-devel/Makefile b/www/xshttpd-devel/Makefile
index 4c78c6aea709..5cc1b6861883 100644
--- a/www/xshttpd-devel/Makefile
+++ b/www/xshttpd-devel/Makefile
@@ -22,7 +22,7 @@ USE_RC_SUBR= xshttpd
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-hier=bsd --with-userid=${WWWOWN}:${WWWGRP}
-OPTIONS_DEFINE= BDB CURL LDAP M4 NETPBM PERL
+OPTIONS_DEFINE= BDB CURL LDAP M4 NETPBM PERL DOCS
OPTIONS_DEFAULT= BDB CURL M4 NETPBM
OPTIONS_SUB= yes
BDB_USES= bdb:5+
diff --git a/www/xshttpd/Makefile b/www/xshttpd/Makefile
index 1a68b3fb844d..a35b925cca91 100644
--- a/www/xshttpd/Makefile
+++ b/www/xshttpd/Makefile
@@ -24,7 +24,7 @@ GNU_CONFIGURE= yes
WWWDIR= ${PREFIX}/www/${PORTNAME}
CONFIGURE_ARGS+=--with-rootdir=${WWWDIR}
-OPTIONS_DEFINE= SSL PCRE LDAP CURL M4_CONFIG PERSISTENT_PERL
+OPTIONS_DEFINE= SSL PCRE LDAP CURL M4_CONFIG PERSISTENT_PERL DOCS
OPTIONS_DEFAULT=SSL PCRE
SSL_USES= ssl
SSL_CONFIGURE_WITH= ssl